summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/bsnes/files/bsnes-0.058_gentoo.patch')
-rw-r--r--games-emulation/bsnes/files/bsnes-0.058_gentoo.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-emulation/bsnes/files/bsnes-0.058_gentoo.patch b/games-emulation/bsnes/files/bsnes-0.058_gentoo.patch
new file mode 100644
index 0000000..c621c8d
--- /dev/null
+++ b/games-emulation/bsnes/files/bsnes-0.058_gentoo.patch
@@ -0,0 +1,34 @@
+diff -ur a/Makefile b/Makefile
+--- a/Makefile 2010-01-01 17:04:05.082926765 -0500
++++ b/Makefile 2010-01-01 17:17:27.232927324 -0500
+@@ -7,9 +7,10 @@
+ ################
+
+ c := $(compiler)
+-cpp := $(subst cc,++,$(compiler))
+-flags := -O3 -fomit-frame-pointer -Ilib
+-link :=
++cpp ?= $(subst cc,++,$(compiler))
++flags := $(CXXFLAGS) -Ilib
++cflags := $(CFLAGS) -Ilib
++link := $(LDFLAGS)
+
+ # profile-guided instrumentation:
+ # flags += -fprofile-generate
+@@ -24,6 +25,7 @@
+
+ ifeq ($(platform),x)
+ link += -s
++ link += -ldl `pkg-config --libs x11 xext`
+
+ ruby := video.glx video.xv video.qtraster video.sdl
+ ruby += audio.alsa audio.openal audio.oss audio.pulseaudio audio.ao
+@@ -90,7 +92,7 @@
+ compile = \
+ $(strip \
+ $(if $(filter %.c,$<), \
+- $(c) $(flags) $1 -c $< -o $@, \
++ $(c) $(cflags) $1 -c $< -o $@, \
+ $(if $(filter %.cpp,$<), \
+ $(cpp) $(flags) $1 -c $< -o $@ \
+ ) \