summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRussell Harmon <russ@eatnumber1.com>2009-03-24 16:56:06 -0400
committerRussell Harmon <russ@eatnumber1.com>2009-03-24 16:56:06 -0400
commita5c4aa039746f24296797fc14b21456293bdda21 (patch)
treeccbff55f16d453fd359b0d6fa86953cc5f9fc427
parentAdd ebuilds needed to compile chromium (diff)
downloadeatnumber1-a5c4aa039746f24296797fc14b21456293bdda21.tar.gz
eatnumber1-a5c4aa039746f24296797fc14b21456293bdda21.tar.bz2
eatnumber1-a5c4aa039746f24296797fc14b21456293bdda21.zip
Fix stuff
-rw-r--r--dev-libs/arch/Manifest6
-rw-r--r--dev-libs/arch/arch-2.5a.ebuild (renamed from dev-util/arch/arch-2.5a.ebuild)3
-rw-r--r--dev-libs/arch/files/Makefile.am8
-rw-r--r--dev-libs/arch/files/arch.pc.in4
-rw-r--r--dev-libs/arch/files/configure.ac (renamed from dev-util/arch/files/configure.ac)3
-rw-r--r--dev-libs/arch/files/libarch_autotools-gcc.patch (renamed from dev-util/arch/files/libarch_autotools-gcc.patch)0
-rw-r--r--dev-util/arch/Manifest5
-rw-r--r--dev-util/arch/files/Makefile.am6
8 files changed, 22 insertions, 13 deletions
diff --git a/dev-libs/arch/Manifest b/dev-libs/arch/Manifest
new file mode 100644
index 0000000..f0c5ec2
--- /dev/null
+++ b/dev-libs/arch/Manifest
@@ -0,0 +1,6 @@
+AUX Makefile.am 607 RMD160 2f5fe06e5061db1d1d3c3f0d9bc5d8f49302c71d SHA1 50b4731d8ca33e3f6d2235a81a9809a85a554e9c SHA256 e6cbd3d979d858983e7d299fbc1fdd7083736c72e61e18a3a662d339c48c5140
+AUX arch.pc.in 104 RMD160 b7bf13d42d0b017f887a3ad91b2a3ab9988c5232 SHA1 d45e091509408f1e1a5231972b5123b7a65f58e8 SHA256 a5803bf0b5576ee5e8d28ff9ee913e9f3dcfe1ddf0c57526abe9805690a709e8
+AUX configure.ac 184 RMD160 c414dca1010b62b790a547dcd168a92dbda8d1d6 SHA1 d89de810d13c848efac77f533344124dc4d22aae SHA256 966b2e2ad361aa87a181ee4403c12fbd4c8d7e80c4772d54f86196f8b64ec662
+AUX libarch_autotools-gcc.patch 1599 RMD160 9a23a7db201c8172be7ca12524a2d59fd730ba92 SHA1 4278b2c5327a1ee79895adfe82383b78e1f7af6c SHA256 6f60aef2f23be2a6f92712df89bffbdde447418a490d3a7c791e5e5174737a9e
+DIST arch2-5a.tar.gz 19986 RMD160 be62d70a2808c6ac7f0ac967904060ee61d3010a SHA1 05ba5421771026d508cb3f8bef1ac79bcbf12478 SHA256 21810f9ff76d2020768929a134d5c2dd4fd6f35ac699452ee5d5beef19a23ec5
+EBUILD arch-2.5a.ebuild 637 RMD160 4cff6f7be7afe181b5834dc6f86c5fa11807e97b SHA1 d326fd4b76916a0aed1cb394da29cfd0b80512cb SHA256 27d153bf0e034674fba1abb61dc1833e7aeeda9fdda5651bafcd1d37d75d6a90
diff --git a/dev-util/arch/arch-2.5a.ebuild b/dev-libs/arch/arch-2.5a.ebuild
index 106aa72..05e7a6c 100644
--- a/dev-util/arch/arch-2.5a.ebuild
+++ b/dev-libs/arch/arch-2.5a.ebuild
@@ -6,7 +6,7 @@ EAPI="2"
inherit eutils autotools
-DESCRIPTION=""
+DESCRIPTION="RIT's computer architecture simulation library."
HOMEPAGE=""
SRC_URI="http://www.cs.rit.edu/~icsg720/pub/misc/${PN}${PV/./-}.tar.gz"
@@ -24,6 +24,7 @@ src_prepare() {
epatch "${FILESDIR}/libarch_autotools-gcc.patch"
cp "${FILESDIR}/Makefile.am" .
cp "${FILESDIR}/configure.ac" .
+ cp "${FILESDIR}/arch.pc.in" .
rm "Makefile"
eautoreconf || die
}
diff --git a/dev-libs/arch/files/Makefile.am b/dev-libs/arch/files/Makefile.am
new file mode 100644
index 0000000..ac5e8f7
--- /dev/null
+++ b/dev-libs/arch/files/Makefile.am
@@ -0,0 +1,8 @@
+AUTOMAKE_OPTIONS = foreign
+
+lib_LTLIBRARIES = libarch.la
+libarch_la_SOURCES = ArchLibError.C Bus.C BusALU.C COSet.C CPUObject.C Clearable.C Clock.C ClockedObject.C Connector.C Constant.C Counter.C Flow.C FlowSet.C InFlow.C Memory.C OutFlow.C PseudoInput.C PseudoOutput.C ShiftRegister.C StorageObject.C
+include_HEADERS = ArchLibError.h Bus.h BusALU.h COSet.h CPUObject.h Clearable.h Clock.h ClockedObject.h Connector.h Constant.h Counter.h Flow.h FlowSet.h InFlow.h Memory.h OutFlow.h PseudoInput.h PseudoOutput.h ShiftRegister.h StorageObject.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = arch.pc
diff --git a/dev-libs/arch/files/arch.pc.in b/dev-libs/arch/files/arch.pc.in
new file mode 100644
index 0000000..4ebc081
--- /dev/null
+++ b/dev-libs/arch/files/arch.pc.in
@@ -0,0 +1,4 @@
+Name: arch
+Description: RIT's computer architecture simulation library.
+Version: @VERSION@
+Libs: -larch
diff --git a/dev-util/arch/files/configure.ac b/dev-libs/arch/files/configure.ac
index 2abe4d3..c1c88e4 100644
--- a/dev-util/arch/files/configure.ac
+++ b/dev-libs/arch/files/configure.ac
@@ -11,4 +11,5 @@ CFLAGS+=" -Wall "
CXXFLAGS+=" -Wall "
AM_PROG_LIBTOOL
-AC_OUTPUT(Makefile)
+AC_OUTPUT( Makefile \
+ arch.pc )
diff --git a/dev-util/arch/files/libarch_autotools-gcc.patch b/dev-libs/arch/files/libarch_autotools-gcc.patch
index 4521ec0..4521ec0 100644
--- a/dev-util/arch/files/libarch_autotools-gcc.patch
+++ b/dev-libs/arch/files/libarch_autotools-gcc.patch
diff --git a/dev-util/arch/Manifest b/dev-util/arch/Manifest
deleted file mode 100644
index e14fd2b..0000000
--- a/dev-util/arch/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX Makefile.am 812 RMD160 baec1405470e80bd4510be04b19a802e5869e948 SHA1 f5f5ddd76969740c5d03a4c09f7634163d3fdd75 SHA256 082d272f48057ef30012c58bf9e829bb23c0a99200f338e8de79a981140a58cb
-AUX configure.ac 171 RMD160 62bd0941f422903d6413389748c079a1e3d1808a SHA1 d726d910df815848f21436ae4e01869f4a9ede34 SHA256 4f4002803103a31f0fbcf4f97d9cd5dd359bab8e70235add6b894b74bdfe0821
-AUX libarch_autotools-gcc.patch 1599 RMD160 9a23a7db201c8172be7ca12524a2d59fd730ba92 SHA1 4278b2c5327a1ee79895adfe82383b78e1f7af6c SHA256 6f60aef2f23be2a6f92712df89bffbdde447418a490d3a7c791e5e5174737a9e
-DIST arch2-5a.tar.gz 19986 RMD160 be62d70a2808c6ac7f0ac967904060ee61d3010a SHA1 05ba5421771026d508cb3f8bef1ac79bcbf12478 SHA256 21810f9ff76d2020768929a134d5c2dd4fd6f35ac699452ee5d5beef19a23ec5
-EBUILD arch-2.5a.ebuild 559 RMD160 c1aefaf14a044fbdf5c5ff5464134213dcdb8796 SHA1 61759dd698795fc03be63ddee26766035903cd35 SHA256 2b0bfc5cf0c2cd1e85e2a07b2e22081225f5824da9cdfa45f437dabd02754e93
diff --git a/dev-util/arch/files/Makefile.am b/dev-util/arch/files/Makefile.am
deleted file mode 100644
index 9080bc4..0000000
--- a/dev-util/arch/files/Makefile.am
+++ /dev/null
@@ -1,6 +0,0 @@
-AUTOMAKE_OPTIONS = foreign
-
-lib_LTLIBRARIES = libarch.la
-libarch_la_SOURCES = ArchLibError.C Bus.C BusALU.C COSet.C CPUObject.C Clearable.C Clock.C ClockedObject.C Connector.C Constant.C Counter.C Flow.C FlowSet.C InFlow.C Memory.C OutFlow.C PseudoInput.C PseudoOutput.C ShiftRegister.C StorageObject.C
-#libarch_la_LDFLAGS = -Wl,-soname,@ARCH_SONAME@
-#libarch_la_SOURCES = ArchLibError.C Bus.C BusALU.C BusALU.h COSet.C COSet.h CPUObject.C CPUObject.h Clearable.C Clearable.h Clock.C Clock.h ClockedObject.C ClockedObject.h Connector.C Connector.h Constant.C Constant.h Counter.C Counter.h Flow.C Flow.h FlowSet.C FlowSet.h InFlow.C InFlow.h Memory.C Memory.h OutFlow.C OutFlow.h PseudoInput.C PseudoInput.h PseudoOutput.C PseudoOutput.h ShiftRegister.C ShiftRegister.h StorageObject.C StorageObject.h Version.h