summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIvan Baidakou <the.dmol@gmail.com>2012-10-14 11:33:35 +0300
committerIvan Baidakou <the.dmol@gmail.com>2012-10-14 11:33:35 +0300
commit845115b5c30cfdce7315fb49139237111228d76e (patch)
tree75ad0830725b86af6721a1d2de55b2d5b73b9852
parentadd test flag to JAVA_PKG_IUSE (diff)
downloaddmol-845115b5c30cfdce7315fb49139237111228d76e.tar.gz
dmol-845115b5c30cfdce7315fb49139237111228d76e.tar.bz2
dmol-845115b5c30cfdce7315fb49139237111228d76e.zip
version bump wrt#426384
-rw-r--r--dev-java/jaxen/Manifest4
-rw-r--r--dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml201
-rw-r--r--dev-java/jaxen/jaxen-1.1.4.ebuild49
-rw-r--r--dev-java/jaxen/metadata.xml7
4 files changed, 261 insertions, 0 deletions
diff --git a/dev-java/jaxen/Manifest b/dev-java/jaxen/Manifest
new file mode 100644
index 0000000..f32fe23
--- /dev/null
+++ b/dev-java/jaxen/Manifest
@@ -0,0 +1,4 @@
+AUX jaxen-1.1.4_maven1-build.xml 13183 SHA256 6c2000822b16baf2788681713815b7b8c7c358b3aa3a4c523e64541fcf5c9aa7 SHA512 eaa53770cbf02c9752e72d58d32c19981b3e58a6d448181828e9369f4dc7703e23ca9a47adb3cddf1888f4f42c5668248ee39dcdc0ae070d63107383d45485b9 WHIRLPOOL a0e03adf01c2515281a7a4b6d5dbb8bb15eb1ab395263b118fafbf86f1d3a2c2d9dc27a8e3c90c9930287bca0ab7417c24874e876a4e81b53ccb46f2a6188754
+DIST jaxen-1.1.4-src.tar.gz 268493 SHA256 97d039a029ccaddf5ef301cafd1da8549b8360fe3ca0c15d65fc57162cd4433e SHA512 11c1c744af030c50579f872d8c8bf437e48ab4a01e6dd34529f2d9039c154533edaa9b5a367a866e2b57f311f1111717be300db8f80423c5492be38e0cffc031 WHIRLPOOL 44e3449ec8c0c15496c9528c668593d3dde67da67108e5927aee630df6ee3803999f812ab7597f37a68829e95a435fe6699bc9681583f6a500cd55cc51fbd6dc
+EBUILD jaxen-1.1.4.ebuild 1191 SHA256 de347b715334f17fd1ca58601aa817afa3542583e870914f1fff51e6c0a1a3ca SHA512 95bf7ef8a1363cb062e177977cd93e27c748ae63660dcd544aa87bb3e681050761a05c097950288d4a19df0a6fef22acf2cf1084d40a317727d35cda795f7496 WHIRLPOOL df3e35eede07c50cd551c2d4d337c8911b40a0b5a8eaf4ab4edb0311f7337f949a21484c3d9672c8c0ba8e1b537e625f41affe12c166f39a07fa4f46e08c3f9a
+MISC metadata.xml 205 SHA256 2ff0740a5424b0e10c7888541a248d1bd363a60911b0921b4cfe5c36590498ce SHA512 e7c77c724739d0af43cc338ded09dcbeee2a710eb0e49f1e656dc4c891bee85bfd6935bf70a191a1c5823f473643e676d64970416e5f1820ea466681016757c5 WHIRLPOOL 5b7f0c2a5243244fa06b072c8f0d9f53e7b6f45c7e1b74a0d945bdcc28b7137fddfd58e85b0d3e721e80963916ceae0d4cca59f48114ba26c47b24a91d6abb27
diff --git a/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml b/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml
new file mode 100644
index 0000000..ab65873
--- /dev/null
+++ b/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml
@@ -0,0 +1,201 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--build.xml generated by maven from project.xml version 1.1.4
+ on date October 14 2012, time 0755-->
+<project default="jar" name="jaxen" basedir=".">
+ <!--Load local and user build preferences-->
+ <property file="build.properties"></property>
+ <property file="${user.home}/build.properties"></property>
+ <!--Build properties-->
+ <property name="defaulttargetdir" value="${basedir}/target"></property>
+ <property name="libdir" value="${user.home}/.maven/repository"></property>
+ <property name="classesdir" value="${basedir}/target/classes"></property>
+ <property name="testclassesdir" value="${basedir}/target/test-classes"></property>
+ <property name="testreportdir" value="${basedir}/target/test-reports"></property>
+ <property name="distdir" value="${basedir}/dist"></property>
+ <property name="javadocdir" value="${basedir}/dist/docs/api"></property>
+ <property name="final.name" value="jaxen-1.1.4"></property>
+ <property name="proxy.host" value=""></property>
+ <property name="proxy.port" value=""></property>
+ <property name="proxy.username" value=""></property>
+ <property name="proxy.password" value=""></property>
+ <path id="build.classpath">
+ <pathelement location="${libdir}/dom4j/jars/dom4j-1.6.1.jar"></pathelement>
+ <pathelement location="${libdir}/jdom/jars/jdom-1.0.jar"></pathelement>
+ <pathelement location="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar"></pathelement>
+ <pathelement location="${libdir}/xerces/jars/xercesImpl-2.6.2.jar"></pathelement>
+ <pathelement location="${libdir}/xom/jars/xom-1.0.jar"></pathelement>
+ <pathelement location="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></pathelement>
+ <pathelement location="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></pathelement>
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}"></mkdir>
+ <condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}"></equals>
+ </condition>
+ <!--Test if JUNIT is present in ANT classpath-->
+ <available property="Junit.present" classname="junit.framework.Test"></available>
+ <!--Test if user defined a proxy-->
+ <condition property="useProxy">
+ <and>
+ <isset property="proxy.host"></isset>
+ <not>
+ <equals trim="true" arg2="" arg1="${proxy.host}"></equals>
+ </not>
+ </and>
+ </condition>
+ </target>
+ <target name="compile" description="o Compile the code" depends="get-deps">
+ <mkdir dir="${classesdir}"></mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/java/main"></pathelement>
+ </src>
+ <classpath refid="build.classpath"></classpath>
+ </javac>
+ </target>
+ <target name="jar" description="o Create the jar" depends="compile,test">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}"></jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}"></delete>
+ <delete dir="${distdir}"></delete>
+ </target>
+ <target name="dist" description="o Create a distribution" depends="jar, javadoc">
+ <mkdir dir="dist"></mkdir>
+ <copy todir="dist">
+ <fileset dir="${defaulttargetdir}" includes="*.jar"></fileset>
+ <fileset dir="${basedir}" includes="LICENSE*, README*"></fileset>
+ </copy>
+ </target>
+ <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test">
+ <fail message="There were test failures."></fail>
+ </target>
+ <target name="internal-test" if="Junit.present" depends="junit-present,compile-tests">
+ <mkdir dir="${testreportdir}"></mkdir>
+ <junit dir="${basedir}" failureproperty="test.failure" printSummary="yes" fork="true" haltonerror="true">
+ <sysproperty key="basedir" value="."></sysproperty>
+ <formatter type="xml"></formatter>
+ <formatter usefile="false" type="plain"></formatter>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${testclassesdir}"></pathelement>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ <batchtest todir="${testreportdir}">
+ <fileset dir="${basedir}/src/java/test">
+ <include name="**/*Test.java"></include>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="junit-present" unless="Junit.present" depends="init">
+ <echo>================================= WARNING ================================</echo>
+ <echo>Junit isn't present in your ${ANT_HOME}/lib directory. Tests not executed.</echo>
+ <echo>==========================================================================</echo>
+ </target>
+ <target name="compile-tests" if="Junit.present" depends="junit-present,compile">
+ <mkdir dir="${testclassesdir}"></mkdir>
+ <javac destdir="${testclassesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/java/test"></pathelement>
+ </src>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ </javac>
+ </target>
+ <target name="javadoc" description="o Generate javadoc" depends="get-deps">
+ <mkdir dir="${javadocdir}"></mkdir>
+ <tstamp>
+ <format pattern="2001-yyyy" property="year"></format>
+ </tstamp>
+ <property name="copyright" value="Copyright &amp;copy; Codehaus. All Rights Reserved."></property>
+ <property name="title" value="jaxen 1.1.4 API"></property>
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="${basedir}/src/java/main" packagenames="org.jaxen.*">
+ <classpath>
+ <path refid="build.classpath"></path>
+ </classpath>
+ </javadoc>
+ </target>
+ <target name="get-dep-dom4j.jar" description="o Download the dependency : dom4j.jar" unless="dom4j.jar" depends="init,setProxy,noProxy,get-custom-dep-dom4j.jar">
+ <mkdir dir="${libdir}/dom4j/jars/"></mkdir>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/dom4j/jars/dom4j-1.6.1.jar"></get>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//dom4j/jars/dom4j-1.6.1.jar"></get>
+ </target>
+ <target name="get-custom-dep-dom4j.jar" if="dom4j.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/dom4j/jars/"></mkdir>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="${dom4j.jar}"></get>
+ </target>
+ <target name="get-dep-jdom.jar" description="o Download the dependency : jdom.jar" unless="jdom.jar" depends="init,setProxy,noProxy,get-custom-dep-jdom.jar">
+ <mkdir dir="${libdir}/jdom/jars/"></mkdir>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/jdom/jars/jdom-1.0.jar"></get>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//jdom/jars/jdom-1.0.jar"></get>
+ </target>
+ <target name="get-custom-dep-jdom.jar" if="jdom.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/jdom/jars/"></mkdir>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="${jdom.jar}"></get>
+ </target>
+ <target name="get-dep-xml-apis.jar" description="o Download the dependency : xml-apis.jar" unless="xml-apis.jar" depends="init,setProxy,noProxy,get-custom-dep-xml-apis.jar">
+ <mkdir dir="${libdir}/xml-apis/jars/"></mkdir>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xml-apis/jars/xml-apis-1.3.02.jar"></get>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xml-apis/jars/xml-apis-1.3.02.jar"></get>
+ </target>
+ <target name="get-custom-dep-xml-apis.jar" if="xml-apis.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xml-apis/jars/"></mkdir>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="${xml-apis.jar}"></get>
+ </target>
+ <target name="get-dep-xercesImpl.jar" description="o Download the dependency : xercesImpl.jar" unless="xercesImpl.jar" depends="init,setProxy,noProxy,get-custom-dep-xercesImpl.jar">
+ <mkdir dir="${libdir}/xerces/jars/"></mkdir>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xerces/jars/xercesImpl-2.6.2.jar"></get>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xerces/jars/xercesImpl-2.6.2.jar"></get>
+ </target>
+ <target name="get-custom-dep-xercesImpl.jar" if="xercesImpl.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xerces/jars/"></mkdir>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="${xercesImpl.jar}"></get>
+ </target>
+ <target name="get-dep-xom.jar" description="o Download the dependency : xom.jar" unless="xom.jar" depends="init,setProxy,noProxy,get-custom-dep-xom.jar">
+ <mkdir dir="${libdir}/xom/jars/"></mkdir>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xom/jars/xom-1.0.jar"></get>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xom/jars/xom-1.0.jar"></get>
+ </target>
+ <target name="get-custom-dep-xom.jar" if="xom.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xom/jars/"></mkdir>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="${xom.jar}"></get>
+ </target>
+ <target name="get-dep-maven-cobertura-plugin.jar" description="o Download the dependency : maven-cobertura-plugin.jar" unless="maven-cobertura-plugin.jar" depends="init,setProxy,noProxy,get-custom-dep-maven-cobertura-plugin.jar">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></get>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></get>
+ </target>
+ <target name="get-custom-dep-maven-cobertura-plugin.jar" if="maven-cobertura-plugin.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="${maven-cobertura-plugin.jar}"></get>
+ </target>
+ <target name="get-dep-maven-findbugs-plugin.jar" description="o Download the dependency : maven-findbugs-plugin.jar" unless="maven-findbugs-plugin.jar" depends="init,setProxy,noProxy,get-custom-dep-maven-findbugs-plugin.jar">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></get>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></get>
+ </target>
+ <target name="get-custom-dep-maven-findbugs-plugin.jar" if="maven-findbugs-plugin.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="${maven-findbugs-plugin.jar}"></get>
+ </target>
+ <target name="get-deps" unless="noget"></target>
+ <target name="setProxy" if="useProxy" depends="init">
+ <!--Proxy settings works only with a JDK 1.2 and higher.-->
+ <echo>Proxy used :</echo>
+ <echo>Proxy host [${proxy.host}]</echo>
+ <echo>Proxy port [${proxy.port}]</echo>
+ <echo>Proxy user [${proxy.username}]</echo>
+ <setproxy proxyuser="${proxy.username}" proxyport="${proxy.port}" proxypassword="${proxy.password}" proxyhost="${proxy.host}"></setproxy>
+ </target>
+ <target name="noProxy" unless="useProxy" depends="init">
+ <echo>Proxy not used.</echo>
+ </target>
+ <target name="install-maven">
+ <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${repo}/maven/maven-install-latest.jar"></get>
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar"></unjar>
+ </target>
+</project> \ No newline at end of file
diff --git a/dev-java/jaxen/jaxen-1.1.4.ebuild b/dev-java/jaxen/jaxen-1.1.4.ebuild
new file mode 100644
index 0000000..618a3c2
--- /dev/null
+++ b/dev-java/jaxen/jaxen-1.1.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java XPath Engine"
+HOMEPAGE="http://jaxen.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.gz"
+
+LICENSE="jaxen"
+SLOT="1.1"
+KEYWORDS="amd64 ~ia64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc source test"
+
+COMMON_DEP="~dev-java/jdom-1.0
+ =dev-java/dom4j-1*
+ dev-java/xom"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit =dev-java/junit-3* )
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/${P}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="dom4j-1,jdom-1.0,xom"
+EANT_TEST_EXTRA_ARGS="-DJunit.present=true"
+
+java_prepare() {
+ cp -v "${FILESDIR}"/${P}_maven1-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use examples && java-pkg_doexamples src/java/samples
+ use source && java-pkg_dosrc src/java/main/*
+}
diff --git a/dev-java/jaxen/metadata.xml b/dev-java/jaxen/metadata.xml
new file mode 100644
index 0000000..80859ae
--- /dev/null
+++ b/dev-java/jaxen/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>the.dmol@gmail.com</email>
+ </maintainer>
+</pkgmetadata>