summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/melt/melt-0.9.7.ebuild')
-rw-r--r--dev-util/melt/melt-0.9.7.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/melt/melt-0.9.7.ebuild b/dev-util/melt/melt-0.9.7.ebuild
new file mode 100644
index 0000000..0c3ed0b
--- /dev/null
+++ b/dev-util/melt/melt-0.9.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="High-level domain specific language for extending or customizing the Gnu Compiler Collection"
+HOMEPAGE="http://gcc-melt.org/"
+SRC_URI="http://gcc-melt.org/${P}-plugin-for-gcc-4.6-or-4.7-or-4.8.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+DEPEND="
+doc? ( app-text/texi2html )
+>=sys-devel/gcc-4.6
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-plugin-for-gcc-4.6-or-4.7-or-4.8"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.diff"
+}
+
+src_configure() { :; }
+
+src_compile() {
+ make
+
+ if use doc; then
+ emake melt-gendoc
+ emake doc
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ if use doc; then
+ dohtml *.html
+ dodoc *.pdf
+ fi
+} \ No newline at end of file