summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-09-12 22:21:16 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-09-12 22:21:16 +0200
commit53ffd1ed48484f84520a1996cdd5d2a0ef1c5e24 (patch)
treef9918e76b6ffc9ef5f5645585e51b0cd7ad3aa8c
parentnss-myhostname: Update description (diff)
downloadbenf-53ffd1ed48484f84520a1996cdd5d2a0ef1c5e24.tar.gz
benf-53ffd1ed48484f84520a1996cdd5d2a0ef1c5e24.tar.bz2
benf-53ffd1ed48484f84520a1996cdd5d2a0ef1c5e24.zip
protobuf-c: Add protoc useflag
Controlls whether the protoc compiler is build, and if pulls in c++ dev-libs/protobuf.
-rw-r--r--dev-libs/protobuf-c/Manifest2
-rw-r--r--dev-libs/protobuf-c/protobuf-c-0.15.ebuild13
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-libs/protobuf-c/Manifest b/dev-libs/protobuf-c/Manifest
index 9159f9f..0a80977 100644
--- a/dev-libs/protobuf-c/Manifest
+++ b/dev-libs/protobuf-c/Manifest
@@ -1,2 +1,2 @@
DIST protobuf-c-0.15.tar.gz 500911 RMD160 50319bba2b173aafb96dd1fe70550d378e69f871 SHA1 4fbd93f492c52154713de1951c0a2133ddd43abb SHA256 8fcb538e13a5431c46168fc8f2e6ad2574e2db9b684c0c72b066e24f010a0036
-EBUILD protobuf-c-0.15.ebuild 420 RMD160 3bb8c938a33ffd34b22d9b96001be29f3d0255b3 SHA1 758f4eaf2d99850aa73f2f18c5c3f880371b3181 SHA256 ee13423a435ec76743ff143e8ad7533faacc45869a67b39333df7febebd92ba2
+EBUILD protobuf-c-0.15.ebuild 528 RMD160 c758f9a60bca2ddad6af0d699382d0e5a807b08b SHA1 18f8b04cc102c3e22253145a24e0fab5541c964e SHA256 2a92951ee9e79ebd26d951c577d6fcfe2ed7ab5f370a75a002814d159f140480
diff --git a/dev-libs/protobuf-c/protobuf-c-0.15.ebuild b/dev-libs/protobuf-c/protobuf-c-0.15.ebuild
index a2b195b..e4d05a3 100644
--- a/dev-libs/protobuf-c/protobuf-c-0.15.ebuild
+++ b/dev-libs/protobuf-c/protobuf-c-0.15.ebuild
@@ -4,7 +4,7 @@
EAPI=3
-inherit autotools autotools-utils
+inherit autotools-utils
DESCRIPTION="C bindings for Google's Protocol Buffers"
HOMEPAGE="http://protobuf-c.googlecode.com/"
@@ -13,8 +13,15 @@ SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE="static-libs"
+IUSE="protoc static-libs"
-DEPEND="dev-libs/protobuf"
+DEPEND="protoc? ( dev-libs/protobuf )"
RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable protoc)
+ )
+ autotools-utils_src_configure
+}