summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/tilda/tilda-0.9.6-r1.ebuild')
-rw-r--r--x11-terms/tilda/tilda-0.9.6-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-terms/tilda/tilda-0.9.6-r1.ebuild b/x11-terms/tilda/tilda-0.9.6-r1.ebuild
new file mode 100644
index 0000000..c5ee03f
--- /dev/null
+++ b/x11-terms/tilda/tilda-0.9.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/tilda/tilda-0.9.6.ebuild,v 1.7 2010/04/04 13:52:04 steev Exp $
+
+inherit eutils
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="http://tilda.sourceforge.net"
+SRC_URI="mirror://sourceforge/tilda/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/vte
+ >=dev-libs/glib-2.8.4
+ dev-libs/confuse
+ gnome-base/libglade"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.9.6-gdk_resources.patch
+ epatch "${FILESDIR}"/${PN}-0.9.6-palette.diff
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO
+}