summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim A. Misbakh-Soloviov <git@mva.name>2017-09-17 06:01:27 +0700
committerVadim A. Misbakh-Soloviov <git@mva.name>2017-09-17 06:01:27 +0700
commit780d880d7c01b3a4f63aa3d58fdcba2d58e4b787 (patch)
treefa26a5c934e1d9319a589855f1fe368f55cbb327
parentsvox: added; sphinx: dropped (buildsystem is crazy, release model is crazy, n... (diff)
downloadactivehome-780d880d7c01b3a4f63aa3d58fdcba2d58e4b787.tar.gz
activehome-780d880d7c01b3a4f63aa3d58fdcba2d58e4b787.tar.bz2
activehome-780d880d7c01b3a4f63aa3d58fdcba2d58e4b787.zip
openocd,rhvoice: fixing URIs, fixing build
-rw-r--r--app-accessibility/rhvoice/rhvoice-9999.ebuild30
-rw-r--r--dev-embedded/openocd/openocd-9999.ebuild13
2 files changed, 22 insertions, 21 deletions
diff --git a/app-accessibility/rhvoice/rhvoice-9999.ebuild b/app-accessibility/rhvoice/rhvoice-9999.ebuild
index c0ad1aa..1c097e5 100644
--- a/app-accessibility/rhvoice/rhvoice-9999.ebuild
+++ b/app-accessibility/rhvoice/rhvoice-9999.ebuild
@@ -1,42 +1,40 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/iulib/iulib-0.4.ebuild,v 1.7 2012/06/03 02:42:24 vapier Exp $
-EAPI="5"
+EAPI=6
inherit scons-utils eutils toolchain-funcs multilib git-r3
-DESCRIPTION="A speech synthesizer for Russian language"
+DESCRIPTION="A speech synthesizer for Russian (and similar) language"
HOMEPAGE="https://github.com/Olga-Yakovleva/RHVoice"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/Olga-Yakovleva/RHVoice git://github.com/Olga-Yakovleva/RHVoice.git"
+EGIT_REPO_URI="https://github.com/Olga-Yakovleva/RHVoice"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="rewrite"
RDEPEND=""
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
dev-lang/python
app-accessibility/flite
dev-libs/libunistring
dev-libs/expat
dev-libs/libpcre
media-sound/sox
- dev-util/scons"
+ dev-util/scons
+"
-src_unpack() {
- use rewrite && EGIT_BRANCH="rewrite"
- git-r3_src_unpack;
-}
+DOCS=(README)
+
+# TODO: multilib support (just in case)
src_compile() {
- escons prefix=/usr sysconfdir=/etc
+ escons prefix=/usr sysconfdir=/etc libdir=/usr/$(get_libdir)
}
src_install() {
# Dirty hack, since it fails to install with multijob
SCONSOPTS=""
- escons DESTDIR="${D}" prefix=/usr sysconfdir=/etc install
- dodoc README
+ escons DESTDIR="${D}" prefix=/usr sysconfdir=/etc libdir=/usr/$(get_libdir) install
+ einstalldocs
}
diff --git a/dev-embedded/openocd/openocd-9999.ebuild b/dev-embedded/openocd/openocd-9999.ebuild
index 34c5a03..b87671a 100644
--- a/dev-embedded/openocd/openocd-9999.ebuild
+++ b/dev-embedded/openocd/openocd-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI="5"
+EAPI=6
inherit eutils multilib flag-o-matic toolchain-funcs udev autotools git-r3
-EGIT_REPO_URI="git://git.code.sf.net/p/${PN}/code"
+EGIT_REPO_URI="https://git.code.sf.net/p/${PN}/code"
+EGIT_SUBMODULES=("-*libjaylink" "-jimtcl")
DESCRIPTION="OpenOCD - Open On-Chip Debugger"
HOMEPAGE="http://openocd.sourceforge.net"
@@ -17,6 +17,7 @@ RESTRICT="strip" # includes non-native binaries
RDEPEND="
>=dev-lang/jimtcl-0.76
+ >=dev-embedded/libjaylink-0.1.0
cmsis-dap? ( dev-libs/hidapi )
usb? (
virtual/libusb:0
@@ -32,7 +33,8 @@ DEPEND="
"
src_prepare() {
- epatch_user
+ default
+
AT_NO_RECURSIVE=yes eautoreconf
}
@@ -42,6 +44,7 @@ src_configure() {
--enable-buspirate
--disable-werror
--disable-internal-jimtcl
+ --disable-internal-libjaylink
--enable-amtjtagaccel
--enable-ep93xx
--enable-at91rm9200