summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/autofs/files')
-rw-r--r--net-fs/autofs/files/autofs-5.0.3-heimdal.patch35
-rw-r--r--net-fs/autofs/files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch28
-rw-r--r--net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch61
-rw-r--r--net-fs/autofs/files/autofs-5.0.5-fix-install-deadlink.patch12
-rw-r--r--net-fs/autofs/files/autofs-5.0.6-make-piddir-specifiable-by-user.patch42
-rw-r--r--net-fs/autofs/files/autofs-5.0.6-respect-user-flags-and-fix-asneeded-r2.patch158
-rw-r--r--net-fs/autofs/files/autofs-5.0.6-revert-ldap.patch18
-rw-r--r--net-fs/autofs/files/autofs5-auto.master24
-rw-r--r--net-fs/autofs/files/autofs5.initd70
9 files changed, 0 insertions, 448 deletions
diff --git a/net-fs/autofs/files/autofs-5.0.3-heimdal.patch b/net-fs/autofs/files/autofs-5.0.3-heimdal.patch
deleted file mode 100644
index 707364d..0000000
--- a/net-fs/autofs/files/autofs-5.0.3-heimdal.patch
+++ /dev/null
@@ -1,35 +0,0 @@
---- autofs-5.0.3.orig/modules/cyrus-sasl.c 2008-04-28 16:17:03.000000000 +0200
-+++ autofs-5.0.3/modules/cyrus-sasl.c 2008-04-28 16:41:58.000000000 +0200
-@@ -66,6 +66,15 @@
- #endif
- #endif
-
-+/**
-+ * The type of a principal is different for MIT Krb5 and Heimdal.
-+ * These macros are provided by Heimdal, and introduced here for MIT.
-+ */
-+#ifndef krb5_realm_length
-+#define krb5_realm_length(r) ((r).length)
-+#define krb5_realm_data(r) ((r).data)
-+#endif
-+
- /*
- * Once a krb5 credentials cache is setup, we need to set the KRB5CCNAME
- * environment variable so that the library knows where to find it.
-@@ -452,11 +461,11 @@
-
- /* setup a principal for the ticket granting service */
- ret = krb5_build_principal_ext(ctxt->krb5ctxt, &tgs_princ,
-- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->length,
-- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->data,
-+ krb5_realm_length(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
-+ krb5_realm_data(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
- strlen(KRB5_TGS_NAME), KRB5_TGS_NAME,
-- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->length,
-- krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)->data,
-+ krb5_realm_length(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
-+ krb5_realm_data(*krb5_princ_realm(ctxt->krb5ctxt, krb5_client_princ)),
- 0);
- if (ret) {
- error(logopt,
-
diff --git a/net-fs/autofs/files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch b/net-fs/autofs/files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
deleted file mode 100644
index 4d70d2a..0000000
--- a/net-fs/autofs/files/autofs-5.0.5-add-missing-endif-HAVE_SASL-in-modules-lookup_ldap.c.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- ./modules/lookup_ldap.c
-+++ ./modules/lookup_ldap.c
-@@ -591,10 +591,12 @@ static LDAP *do_connect(unsigned logopt, const char *uri, struct lookup_context
- {
- LDAP *ldap;
-
-+#ifdef HAVE_SASL
- if (ctxt->extern_cert && ctxt->extern_key) {
- set_env(logopt, ENV_LDAPTLS_CERT, ctxt->extern_cert);
- set_env(logopt, ENV_LDAPTLS_KEY, ctxt->extern_key);
- }
-+#endif
-
- ldap = init_ldap_connection(logopt, uri, ctxt);
- if (ldap) {
-@@ -1372,10 +1374,12 @@ static void free_context(struct lookup_context *ctxt)
- defaults_free_searchdns(ctxt->sdns);
- if (ctxt->dclist)
- free_dclist(ctxt->dclist);
-+#ifdef HAVE_SASL
- if (ctxt->extern_cert)
- free(ctxt->extern_cert);
- if (ctxt->extern_key)
- free(ctxt->extern_key);
-+#endif
- free(ctxt);
-
- return;
diff --git a/net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch b/net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch
deleted file mode 100644
index 8086961..0000000
--- a/net-fs/autofs/files/autofs-5.0.5-fix-building-without-ldap.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-=== modified file 'lib/defaults.c'
---- lib/defaults.c 2011-04-30 18:13:36 +0000
-+++ lib/defaults.c 2011-04-30 18:12:37 +0000
-@@ -19,7 +19,10 @@
-
- #include "list.h"
- #include "defaults.h"
-+#include "config.h"
-+#ifdef WITH_LDAP
- #include "lookup_ldap.h"
-+#endif
- #include "log.h"
- #include "automount.h"
-
-@@ -197,6 +200,7 @@
- return 1;
- }
-
-+#ifdef WITH_LDAP
- void defaults_free_uris(struct list_head *list)
- {
- struct list_head *next;
-@@ -252,9 +256,11 @@
-
- return 1;
- }
-+#endif
-
- struct list_head *defaults_get_uris(void)
- {
-+#ifdef WITH_LDAP
- FILE *f;
- char buf[MAX_LINE_LEN];
- char *res;
-@@ -288,6 +294,9 @@
-
- fclose(f);
- return list;
-+#else
-+ return NULL;
-+#endif
- }
-
- /*
-@@ -450,6 +459,7 @@
- return res;
- }
-
-+#ifdef WITH_LDAP
- struct ldap_schema *defaults_get_default_schema(void)
- {
- struct ldap_schema *schema;
-@@ -645,6 +655,7 @@
-
- return schema;
- }
-+#endif
-
- unsigned int defaults_get_mount_nfs_default_proto(void)
- {
-
diff --git a/net-fs/autofs/files/autofs-5.0.5-fix-install-deadlink.patch b/net-fs/autofs/files/autofs-5.0.5-fix-install-deadlink.patch
deleted file mode 100644
index 8ab10fc..0000000
--- a/net-fs/autofs/files/autofs-5.0.5-fix-install-deadlink.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- modules/Makefile.old 2010-06-19 20:43:45.373371321 +0200
-+++ modules/Makefile 2010-06-19 20:45:26.062417092 +0200
-@@ -63,7 +63,9 @@ install: all
- -rm -f $(INSTALLROOT)$(autofslibdir)/mount_smbfs.so
- ln -fs lookup_file.so $(INSTALLROOT)$(autofslibdir)/lookup_files.so
- ln -fs lookup_yp.so $(INSTALLROOT)$(autofslibdir)/lookup_nis.so
-+ifeq ($(SASL), 1)
- ln -fs lookup_ldap.so $(INSTALLROOT)$(autofslibdir)/lookup_ldaps.so
-+endif
- ln -fs mount_nfs.so $(INSTALLROOT)$(autofslibdir)/mount_nfs4.so
- ifeq ($(EXT2FS), 1)
- ifeq ($(EXT3FS), 1)
diff --git a/net-fs/autofs/files/autofs-5.0.6-make-piddir-specifiable-by-user.patch b/net-fs/autofs/files/autofs-5.0.6-make-piddir-specifiable-by-user.patch
deleted file mode 100644
index 32b5b79..0000000
--- a/net-fs/autofs/files/autofs-5.0.6-make-piddir-specifiable-by-user.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 584468f3c8eb5574811b67cd4a3f0b8736a3d99c Mon Sep 17 00:00:00 2001
-From: Dustin Polke <dustin.polke@uni-siegen.de>
-Date: Thu, 15 Dec 2011 21:35:21 +0100
-Subject: [PATCH] autofs-5.0.6 - make piddir specifiable by user
-
-Let the user specify where to put pid files. This is helpful if /var/run
-and /run exist and the user wants to supersede the use of /run by
-/var/run.
----
- configure.in | 15 +++++++++++++++
- 1 files changed, 15 insertions(+), 0 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index 05ee67f..d2cd73a 100644
---- a/configure.in
-+++ b/configure.in
-@@ -43,7 +43,22 @@ AF_LINUX_PROCFS()
- #
- AF_INIT_D()
- AC_SUBST(initdir)
-+
-+#
-+# Location of pid file directory?
-+#
- AF_PID_D()
-+AC_ARG_WITH(piddir,
-+[ --with-piddir=DIR use DIR for autofs pid file directory],
-+ if test -z "$withval" -o "$withval" = "yes" -o "$withval" = "no"
-+ then
-+ :
-+ else
-+ piddir="${withval}"
-+ fi
-+)
-+AC_MSG_CHECKING([for autofs pid file directory])
-+AC_MSG_RESULT([$piddir])
- AC_SUBST(piddir)
-
- #
---
-1.7.3.4
-
diff --git a/net-fs/autofs/files/autofs-5.0.6-respect-user-flags-and-fix-asneeded-r2.patch b/net-fs/autofs/files/autofs-5.0.6-respect-user-flags-and-fix-asneeded-r2.patch
deleted file mode 100644
index 21d74be..0000000
--- a/net-fs/autofs/files/autofs-5.0.6-respect-user-flags-and-fix-asneeded-r2.patch
+++ /dev/null
@@ -1,158 +0,0 @@
---- a/Makefile.conf.in
-+++ b/Makefile.conf.in
-@@ -100,3 +100,6 @@ initdir = @initdir@
-
- # Location of systemd unit files
- systemddir = @systemddir@
-+
-+# Use the compiler determined by configure
-+CC := @CC@
---- a/Makefile.rules
-+++ b/Makefile.rules
-@@ -16,44 +16,34 @@ INSTALLROOT = $(DESTDIR)
- AUTOFS_LIB = ../lib/autofs.a
-
- # Compilers, linkers and flags
--# The STRIP defined here *must not* remove any dynamic-loading symbols
--
- ifdef DMALLOCLIB
- DEBUG=1
- endif
-
- ifdef DEBUG
- CFLAGS ?= -g -Wall -DDEBUG
--LDFLAGS = -g
--STRIP = :
- else
--ifdef DONTSTRIP
- CFLAGS ?= -O2 -g
--LDFLAGS = -g
--STRIP = :
--else
--CFLAGS ?= -O2 -Wall
--LDFLAGS = -s
--STRIP = strip --strip-debug
--endif
- endif
-+AUTOFS_LDFLAGS = -g
-
--CC = gcc
--CXX = g++
- CXXFLAGS = $(CFLAGS)
- LD = ld
- SOLDFLAGS = -shared
-
- CFLAGS += -D_REENTRANT -D_FILE_OFFSET_BITS=64
--LDFLAGS += -lpthread
-
- ifdef TIRPCLIB
- CFLAGS += -I/usr/include/tirpc
--LDFLAGS += $(TIRPCLIB)
-+AUTOFS_LDFLAGS += $(TIRPCLIB)
- endif
-
- ifdef DMALLOCLIB
--LDFLAGS += $(DMALLOCLIB)
-+AUTOFS_LDFLAGS += $(DMALLOCLIB)
-+endif
-+
-+ifdef SASL
-+CFLAGS += $(XML_FLAGS)
- endif
-
- # Standard rules
-@@ -67,5 +57,4 @@ endif
- $(CC) $(CFLAGS) -S $<
-
- .c.so:
-- $(CC) $(SOLDFLAGS) $(CFLAGS) -o $*.so $< $(AUTOFS_LIB) $(DMALLOCLIB) $(LIBNSL)
-- $(STRIP) $*.so
-+ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) -o $*.so $< $(AUTOFS_LIB) $(DMALLOCLIB) $(LIBNSL)
---- a/configure.in
-+++ b/configure.in
-@@ -183,7 +183,7 @@ AC_ARG_WITH(hesiod,
- : Search for Hesiod in normal directory path
- else
- : Search for Hesiod in specific directory
-- LDFLAGS="$LDFLAGS -L${withval}/lib"
-+ LDFLAGS="$LDFLAGS -Wl,--no-as-needed -L${withval}/lib"
- LIBHESIOD="-L${withval}/lib"
- HESIOD_FLAGS="-I${withval}/include"
- fi
---- a/daemon/Makefile
-+++ b/daemon/Makefile
-@@ -2,8 +2,8 @@
- # Makefile for autofs
- #
-
---include ../Makefile.conf
- include ../Makefile.rules
-+-include ../Makefile.conf
-
- SRCS = automount.c indirect.c direct.c spawn.c module.c mount.c \
- lookup.c state.c flag.c
-@@ -20,7 +20,7 @@ CFLAGS += -DAUTOFS_FIFO_DIR=\"$(autofsfi
- CFLAGS += -DAUTOFS_FLAG_DIR=\"$(autofsflagdir)\"
- CFLAGS += -DVERSION_STRING=\"$(version)\"
- LDFLAGS += -rdynamic
--LIBS = -ldl
-+LIBS = -ldl -lpthread
-
- ifeq ($(LDAP), 1)
- CFLAGS += $(XML_FLAGS)
-@@ -30,8 +30,7 @@ endif
- all: automount
-
- automount: $(OBJS) $(AUTOFS_LIB)
-- $(CC) $(LDFLAGS) $(DAEMON_LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
-- $(STRIP) automount
-+ $(CC) $(AUTOFS_LDFLAGS) $(DAEMON_LDFLAGS) $(LDFLAGS) -o automount $(OBJS) $(AUTOFS_LIB) $(LIBS)
-
- clean:
- rm -f *.o *.s *~ automount
---- a/lib/Makefile
-+++ b/lib/Makefile
-@@ -41,14 +41,12 @@ mount_clnt.c: mount.h
-
- mount_clnt.o: mount_clnt.c
- $(CC) $(CFLAGS) -o mount_clnt.o -c mount_clnt.c
-- $(STRIP) mount_clnt.o
-
- mount_xdr.c: mount.h
- $(RPCGEN) -c -o mount_xdr.c mount.x
-
- mount_xdr.o: mount_xdr.c
- $(CC) $(CFLAGS) -Wno-unused-variable -o mount_xdr.o -c mount_xdr.c
-- $(STRIP) mount_xdr.o
-
- master_tok.c: master_tok.l
- $(LEX) -o$@ -Pmaster_ $?
---- a/modules/Makefile
-+++ b/modules/Makefile
-@@ -87,9 +87,8 @@ endif
- # Ad hoc compilation rules for modules which need auxilliary libraries
- #
- lookup_hesiod.so: lookup_hesiod.c
-- $(CC) $(SOLDFLAGS) $(CFLAGS) $(HESIOD_FLAGS) -o lookup_hesiod.so \
-+ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) $(HESIOD_FLAGS) -o lookup_hesiod.so \
- lookup_hesiod.c $(AUTOFS_LIB) $(LIBHESIOD) $(LIBRESOLV)
-- $(STRIP) lookup_hesiod.so
-
- cyrus-sasl.o: cyrus-sasl.c
- $(CC) $(CFLAGS) $(LDAP_FLAGS) -c $<
-@@ -98,13 +97,10 @@ cyrus-sasl-extern.o: cyrus-sasl-extern.c
- $(CC) $(CFLAGS) $(LDAP_FLAGS) -c $<
-
- lookup_ldap.so: lookup_ldap.c dclist.o base64.o $(SASL_OBJ)
-- $(CC) $(SOLDFLAGS) $(CFLAGS) $(LDAP_FLAGS) -o lookup_ldap.so \
-+ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) $(LDAP_FLAGS) -o lookup_ldap.so \
- lookup_ldap.c dclist.o base64.o $(SASL_OBJ) \
- $(AUTOFS_LIB) $(LIBLDAP) $(LIBRESOLV)
-- $(STRIP) lookup_ldap.so
-
- mount_nfs.so: mount_nfs.c replicated.o
-- $(CC) $(SOLDFLAGS) $(CFLAGS) -o mount_nfs.so \
-+ $(CC) $(LDFLAGS) $(SOLDFLAGS) $(CFLAGS) -o mount_nfs.so \
- mount_nfs.c replicated.o $(AUTOFS_LIB) $(LIBNSL)
-- $(STRIP) mount_nfs.so
--
diff --git a/net-fs/autofs/files/autofs-5.0.6-revert-ldap.patch b/net-fs/autofs/files/autofs-5.0.6-revert-ldap.patch
deleted file mode 100644
index 49901dd..0000000
--- a/net-fs/autofs/files/autofs-5.0.6-revert-ldap.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- modules/lookup_ldap.c
-+++ modules/lookup_ldap.c
-@@ -1488,6 +1488,7 @@ int lookup_init(const char *mapfmt, int
- }
- }
-
-+#ifdef WITH_SASL
- /*
- * First, check to see if a preferred authentication method was
- * specified by the user. parse_ldap_config will return error
-@@ -1500,7 +1501,6 @@ int lookup_init(const char *mapfmt, int
- return 1;
- }
-
--#ifdef WITH_SASL
- /* Init the sasl callbacks */
- if (!autofs_sasl_client_init(LOGOPT_NONE)) {
- error(LOGOPT_ANY, "failed to init sasl client");
diff --git a/net-fs/autofs/files/autofs5-auto.master b/net-fs/autofs/files/autofs5-auto.master
deleted file mode 100644
index 4b10001..0000000
--- a/net-fs/autofs/files/autofs5-auto.master
+++ /dev/null
@@ -1,24 +0,0 @@
-# $Id: autofs5-auto.master,v 1.1 2011/05/23 08:29:05 pva Exp $
-# Sample auto.master file
-# This is an automounter map and it has the following format
-# key [ -mount-options-separated-by-comma ] location
-# For details of the format look at autofs(5).
-#
-#/misc /etc/autofs/auto.misc
-#/net /etc/autofs/auto.net
-#
-# NOTE: mounts done from a hosts map will be mounted with the
-# "nosuid" and "nodev" options unless the "suid" and "dev"
-# options are explicitly given.
-#
-#/net -hosts
-#
-# Include central master map if it can be found using
-# nsswitch sources.
-#
-# Note that if there are entries for /net or /misc (as
-# above) in the included master map any keys that are the
-# same will not be seen as the first read key seen takes
-# precedence.
-#
-#+auto.master
diff --git a/net-fs/autofs/files/autofs5.initd b/net-fs/autofs/files/autofs5.initd
deleted file mode 100644
index 47939f0..0000000
--- a/net-fs/autofs/files/autofs5.initd
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/autofs/files/autofs5.initd,v 1.3 2011/10/05 14:27:26 pva Exp $
-
-DAEMON=/usr/sbin/automount
-PIDFILE=/var/run/autofs.pid
-DEVICE=autofs
-
-depend() {
- need localmount
- use ypbind nfs slapd portmap net
-}
-
-extra_started_commands="reload"
-
-start() {
- ebegin "Starting automounter"
-
- # Ensure autofs support is loaded
- grep -q autofs /proc/filesystems || modprobe -q autofs4
- if [ $? -ne 0 ]; then
- eend 1 "No autofs support available in kernel"
- return 1
- fi
-
- # Check misc device
- if [ -n "${USE_MISC_DEVICE}" -a "${USE_MISC_DEVICE}" = "yes" ]; then
- sleep 1
- if [ -e "/proc/misc" ]; then
- MINOR=$(awk "/${DEVICE}/ {print \$1}" /proc/misc)
- if [ -n "${MINOR}" -a ! -c "/dev/${DEVICE}" ]; then
- mknod -m 0600 "/dev/${DEVICE}" c 10 ${MINOR}
- if [ $? -ne 0 ]; then
- eend 1 "Could not create '/dev/${DEVICE}'"
- return 1
- fi
- fi
- fi
- if [ -x /sbin/restorecon -a -c "/dev/${DEVICE}" ]; then
- /sbin/restorecon "/dev/${DEVICE}"
- if [ $? -ne 0 ]; then
- eend 1 "Failed to execute '/sbin/restorecon \"/dev/${DEVICE}\"'"
- return 1
- fi
- fi
- else
- [ -c "/dev/${DEVICE}" ] && rm -rf "/dev/${DEVICE}"
- fi
-
- start-stop-daemon --start --exec ${DAEMON} -- -p ${PIDFILE} ${OPTIONS}
-
- eend $?
-}
-
-stop() {
- ebegin "Stopping automounter"
- start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
- eend $?
-}
-
-reload() {
- ebegin "Reloading automounter"
- if [ ! -r "${PIDFILE}" ]; then
- eend 1 "automount not running"
- else
- kill -HUP $(cat "${PIDFILE}") 2> /dev/null
- eend $?
- fi
-}