aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot@mac <root@mac.(none)>2012-09-17 14:33:21 +0200
committerroot@mac <root@mac.(none)>2012-09-17 14:33:21 +0200
commit54328a302ecd1eb7c6e9699cd782dab61e6a313f (patch)
tree9fd2fa0710577c6b4b3079a5bade5e27e834066a /dev-python
downloadAstroFloyd-54328a302ecd1eb7c6e9699cd782dab61e6a313f.tar.gz
AstroFloyd-54328a302ecd1eb7c6e9699cd782dab61e6a313f.tar.bz2
AstroFloyd-54328a302ecd1eb7c6e9699cd782dab61e6a313f.zip
Added local ebuilds from Aug 2007 - Feb 2012
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tweepy/tweepy-1.7.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/tweepy/tweepy-1.7.1.ebuild b/dev-python/tweepy/tweepy-1.7.1.ebuild
new file mode 100644
index 0000000..d231543
--- /dev/null
+++ b/dev-python/tweepy/tweepy-1.7.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit distutils
+
+DESCRIPTION="A Python Library for the Twitter (and Identi.ca) API. Includes Oauth and Xauth authentification"
+#HOMEPAGE="http://github.com/joshthecoder/tweepy"
+HOMEPAGE="http://pypi.python.org/pypi/tweepy/"
+# The original URL would be
+#SRC_URI="http://github.com/joshthecoder/tweepy/tarball/${PV}"
+# but github's downloads give bad names which confuses src_unpack
+# so I mirrored the archive under
+#SRC_URI="http://packages.monkeycode.org/${P}.tar.gz"
+#MvdS:
+SRC_URI="http://pypi.python.org/packages/source/t/tweepy/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4
+ dev-python/simplejson"
+RDEPEND="${DEPEND}"
+