summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'guide/distutils-legacy.html')
-rw-r--r--guide/distutils-legacy.html28
1 files changed, 14 insertions, 14 deletions
diff --git a/guide/distutils-legacy.html b/guide/distutils-legacy.html
index a47fb79..1280f34 100644
--- a/guide/distutils-legacy.html
+++ b/guide/distutils-legacy.html
@@ -1,16 +1,16 @@
<!DOCTYPE html>
-<html lang="en">
+<html lang="en" data-content_root="./">
<head>
<meta charset="utf-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" /><meta name="viewport" content="width=device-width, initial-scale=1" />
<title>distutils-r1 legacy concepts &#8212; Gentoo Python Guide documentation</title>
- <link rel="stylesheet" type="text/css" href="_static/pygments.css?v=b3523f8e" />
+ <link rel="stylesheet" type="text/css" href="_static/pygments.css?v=4f649999" />
<link rel="stylesheet" type="text/css" href="_static/alabaster.css?v=039e1c02" />
- <script data-url_root="./" id="documentation_options" src="_static/documentation_options.js?v=b3ba4146"></script>
+ <script src="_static/documentation_options.js?v=5929fcd5"></script>
<script src="_static/doctools.js?v=888ff710"></script>
- <script src="_static/sphinx_highlight.js?v=4825356b"></script>
+ <script src="_static/sphinx_highlight.js?v=dc90522c"></script>
<link rel="index" title="Index" href="genindex.html" />
<link rel="search" title="Search" href="search.html" />
<link rel="next" title="pypi — helper eclass for PyPI archives" href="pypi.html" />
@@ -32,12 +32,12 @@
<div class="body" role="main">
<section id="distutils-r1-legacy-concepts">
-<h1>distutils-r1 legacy concepts<a class="headerlink" href="#distutils-r1-legacy-concepts" title="Permalink to this heading">¶</a></h1>
+<h1>distutils-r1 legacy concepts<a class="headerlink" href="#distutils-r1-legacy-concepts" title="Link to this heading">¶</a></h1>
<p>This section describes concepts specific to the legacy mode
of the <code class="docutils literal notranslate"><span class="pre">distutils-r1</span></code> eclass. When using the modern PEP 517 mode,
none of the features described here are available.</p>
<section id="different-build-system-variations">
-<span id="index-0"></span><h2>Different build system variations<a class="headerlink" href="#different-build-system-variations" title="Permalink to this heading">¶</a></h2>
+<span id="index-0"></span><h2>Different build system variations<a class="headerlink" href="#different-build-system-variations" title="Link to this heading">¶</a></h2>
<p>The commonly used build systems specific to Python packages can be
classified for eclass support into following groups:</p>
<ol class="arabic simple">
@@ -54,7 +54,7 @@ are used, the package needs to have a runtime dependency
on <code class="docutils literal notranslate"><span class="pre">dev-python/setuptools</span></code>. Otherwise, a build-time dependency
is sufficient.</p>
<section id="distutils-use-setuptools">
-<h3>DISTUTILS_USE_SETUPTOOLS<a class="headerlink" href="#distutils-use-setuptools" title="Permalink to this heading">¶</a></h3>
+<h3>DISTUTILS_USE_SETUPTOOLS<a class="headerlink" href="#distutils-use-setuptools" title="Link to this heading">¶</a></h3>
<p>The most common case right now is a package using setuptools as a build
system, and therefore needing a build-time dependency only. This
is the eclass’ default. If your package does not fit this profile,
@@ -105,7 +105,7 @@ An example report is:</p>
</div>
</section>
<section id="distutils-and-setuptools-build-systems">
-<h3>distutils and setuptools build systems<a class="headerlink" href="#distutils-and-setuptools-build-systems" title="Permalink to this heading">¶</a></h3>
+<h3>distutils and setuptools build systems<a class="headerlink" href="#distutils-and-setuptools-build-systems" title="Link to this heading">¶</a></h3>
<p>Distutils and setuptools are the two most common build systems
for Python packages right now. Their common feature is that they use
a <code class="docutils literal notranslate"><span class="pre">setup.py</span></code> script that interfaces with the build system. Generally,
@@ -146,7 +146,7 @@ be necessary if you want to force distutils (e.g. to enable clean
bootstrap) or the upstream condition requiers that.</p>
</section>
<section id="setuptools-entry-points">
-<h3>Setuptools’ entry points<a class="headerlink" href="#setuptools-entry-points" title="Permalink to this heading">¶</a></h3>
+<h3>Setuptools’ entry points<a class="headerlink" href="#setuptools-entry-points" title="Link to this heading">¶</a></h3>
<div class="admonition important">
<p class="admonition-title">Important</p>
<p>With removal of Python 3.7, the correct <code class="docutils literal notranslate"><span class="pre">DISTUTILS_USE_SETUPTOOLS</span></code>
@@ -195,7 +195,7 @@ the QA check will also trigger the wrong value because of leftover
explicit dependencies on setuptools.</p>
</section>
<section id="other-runtime-uses-of-setuptools">
-<h3>Other runtime uses of setuptools<a class="headerlink" href="#other-runtime-uses-of-setuptools" title="Permalink to this heading">¶</a></h3>
+<h3>Other runtime uses of setuptools<a class="headerlink" href="#other-runtime-uses-of-setuptools" title="Link to this heading">¶</a></h3>
<p>Besides the generated wrapper scripts, the package code itself may use
the <code class="docutils literal notranslate"><span class="pre">setuptools</span></code> or <code class="docutils literal notranslate"><span class="pre">pkg_resources</span></code> packages. The common cases
for this include getting package metadata and resource files. This
@@ -209,7 +209,7 @@ dependency. If <code class="docutils literal notranslate"><span class="pre">ins
in the installed modules, please submit a patch upstream.</p>
</section>
<section id="pyproject-toml-based-projects">
-<h3>pyproject.toml-based projects<a class="headerlink" href="#pyproject-toml-based-projects" title="Permalink to this heading">¶</a></h3>
+<h3>pyproject.toml-based projects<a class="headerlink" href="#pyproject-toml-based-projects" title="Link to this heading">¶</a></h3>
<p>The newer build systems used for Python packages avoid supplying
<code class="docutils literal notranslate"><span class="pre">setup.py</span></code> and instead declare package’s metadata and build system
information in <code class="docutils literal notranslate"><span class="pre">pyproject.toml</span></code>. Examples of these build systems
@@ -229,7 +229,7 @@ points is not updated.</p>
</section>
</section>
<section id="in-source-vs-out-of-source-builds">
-<span id="index-1"></span><h2>In-source vs out-of-source builds<a class="headerlink" href="#in-source-vs-out-of-source-builds" title="Permalink to this heading">¶</a></h2>
+<span id="index-1"></span><h2>In-source vs out-of-source builds<a class="headerlink" href="#in-source-vs-out-of-source-builds" title="Link to this heading">¶</a></h2>
<p>In the general definition, an <em>out-of-source build</em> is a build where
output files are placed in a directory separate from source files.
By default, distutils and its derivatives always do out-of-source builds
@@ -280,7 +280,7 @@ files are contained within the copy used for the current interpreter.</p>
</div>
</section>
<section id="installing-the-package-before-testing">
-<span id="index-2"></span><h2>Installing the package before testing<a class="headerlink" href="#installing-the-package-before-testing" title="Permalink to this heading">¶</a></h2>
+<span id="index-2"></span><h2>Installing the package before testing<a class="headerlink" href="#installing-the-package-before-testing" title="Link to this heading">¶</a></h2>
<p>The tests are executed in <code class="docutils literal notranslate"><span class="pre">src_test</span></code> phase, after <code class="docutils literal notranslate"><span class="pre">src_compile</span></code>
installed package files into the build directory. The eclass
automatically adds appropriate <code class="docutils literal notranslate"><span class="pre">PYTHONPATH</span></code> so that the installed
@@ -407,7 +407,7 @@ has broken it for most of the consumers.</p>
&copy;2020, Michał Górny, license: CC BY 4.0.
|
- Powered by <a href="http://sphinx-doc.org/">Sphinx 7.1.2</a>
+ Powered by <a href="http://sphinx-doc.org/">Sphinx 7.2.6</a>
&amp; <a href="https://github.com/bitprophet/alabaster">Alabaster 0.7.13</a>
|