summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'guide/concept.html')
-rw-r--r--guide/concept.html23
1 files changed, 12 insertions, 11 deletions
diff --git a/guide/concept.html b/guide/concept.html
index 15e72e8..9e2c713 100644
--- a/guide/concept.html
+++ b/guide/concept.html
@@ -1,10 +1,10 @@
<!DOCTYPE html>
-<html>
+<html lang="en">
<head>
<meta charset="utf-8" />
- <meta name="viewport" content="width=device-width, initial-scale=1.0" /><meta name="generator" content="Docutils 0.17.1: http://docutils.sourceforge.net/" />
+ <meta name="viewport" content="width=device-width, initial-scale=1.0" /><meta name="generator" content="Docutils 0.18.1: http://docutils.sourceforge.net/" />
<title>Advanced concepts &#8212; Gentoo Python Guide documentation</title>
<link rel="stylesheet" type="text/css" href="_static/pygments.css" />
@@ -12,6 +12,7 @@
<script data-url_root="./" id="documentation_options" src="_static/documentation_options.js"></script>
<script src="_static/jquery.js"></script>
<script src="_static/underscore.js"></script>
+ <script src="_static/_sphinx_javascript_frameworks_compat.js"></script>
<script src="_static/doctools.js"></script>
<link rel="index" title="Index" href="genindex.html" />
<link rel="search" title="Search" href="search.html" />
@@ -34,11 +35,11 @@
<div class="body" role="main">
<section id="advanced-concepts">
-<h1>Advanced concepts<a class="headerlink" href="#advanced-concepts" title="Permalink to this headline">¶</a></h1>
+<h1>Advanced concepts<a class="headerlink" href="#advanced-concepts" title="Permalink to this heading">¶</a></h1>
<section id="namespace-packages">
-<h2>Namespace packages<a class="headerlink" href="#namespace-packages" title="Permalink to this headline">¶</a></h2>
+<h2>Namespace packages<a class="headerlink" href="#namespace-packages" title="Permalink to this heading">¶</a></h2>
<section id="hierarchical-package-structure">
-<h3>Hierarchical package structure<a class="headerlink" href="#hierarchical-package-structure" title="Permalink to this headline">¶</a></h3>
+<h3>Hierarchical package structure<a class="headerlink" href="#hierarchical-package-structure" title="Permalink to this heading">¶</a></h3>
<p>Traditionally, Python packages were organized into a hierarchical
structure with modules and subpackages being located inside the parent
package directory. When submodules are imported, they are represented
@@ -83,7 +84,7 @@ package directory:</p>
to the build directory. However, there is a better solution.</p>
</section>
<section id="namespace-package-structure">
-<h3>Namespace package structure<a class="headerlink" href="#namespace-package-structure" title="Permalink to this headline">¶</a></h3>
+<h3>Namespace package structure<a class="headerlink" href="#namespace-package-structure" title="Permalink to this heading">¶</a></h3>
<p>Unlike traditional packages, namespace packages act as a kind of proxy.
They are not strictly bound to the containing directory, and instead
permit loading subpackages from all directories found in module search
@@ -129,7 +130,7 @@ of Python.</p>
namespace packages</a> in Python Packaging User Guide.</p>
</section>
<section id="determining-whether-namespaces-are-used">
-<h3>Determining whether namespaces are used<a class="headerlink" href="#determining-whether-namespaces-are-used" title="Permalink to this headline">¶</a></h3>
+<h3>Determining whether namespaces are used<a class="headerlink" href="#determining-whether-namespaces-are-used" title="Permalink to this heading">¶</a></h3>
<p>The exact method of detecting namespace packages depends on the type
of namespace used.</p>
<p>PEP 420 namespaces can generally be recognized by the lack
@@ -150,7 +151,7 @@ they can also be recognized by <code class="docutils literal notranslate"><span
in <code class="docutils literal notranslate"><span class="pre">setup.py</span></code> or <code class="docutils literal notranslate"><span class="pre">setup.cfg</span></code>.</p>
</section>
<section id="adding-new-namespace-packages-to-gentoo">
-<h3>Adding new namespace packages to Gentoo<a class="headerlink" href="#adding-new-namespace-packages-to-gentoo" title="Permalink to this headline">¶</a></h3>
+<h3>Adding new namespace packages to Gentoo<a class="headerlink" href="#adding-new-namespace-packages-to-gentoo" title="Permalink to this heading">¶</a></h3>
<p>If the package uses PEP 420 namespaces, no special action is required.
Per PEP 420 layout, the package must not install <code class="docutils literal notranslate"><span class="pre">__init__.py</span></code> files
for namespaces.</p>
@@ -198,7 +199,7 @@ sources, this dependency needs to be stripped, e.g.:</p>
</div>
</section>
<section id="legacy-namespace-packages-in-gentoo">
-<h3>Legacy namespace packages in Gentoo<a class="headerlink" href="#legacy-namespace-packages-in-gentoo" title="Permalink to this headline">¶</a></h3>
+<h3>Legacy namespace packages in Gentoo<a class="headerlink" href="#legacy-namespace-packages-in-gentoo" title="Permalink to this heading">¶</a></h3>
<p>Historically, Gentoo has used <code class="docutils literal notranslate"><span class="pre">dev-python/namespace-*</span></code> packages
to support namespaces. This method is deprecated and it is in process
of being retired.</p>
@@ -268,7 +269,7 @@ of being retired.</p>
</form>
</div>
</div>
-<script>$('#searchbox').show(0);</script>
+<script>document.getElementById('searchbox').style.display = "block"</script>
@@ -285,7 +286,7 @@ of being retired.</p>
&copy;2020, Michał Górny, license: CC BY 4.0.
|
- Powered by <a href="http://sphinx-doc.org/">Sphinx 4.5.0</a>
+ Powered by <a href="http://sphinx-doc.org/">Sphinx 5.0.1</a>
&amp; <a href="https://github.com/bitprophet/alabaster">Alabaster 0.7.12</a>
|