summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2018-06-12 20:18:36 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2018-06-12 20:18:36 -0400
commit60445b7a0e44a2537f01122c90f344f7c9998638 (patch)
treebef6932456d9775ba5c56d5475806bf1d7193843 /games-sports
parentmanifest (diff)
downloadsuperposition-60445b7a0e44a2537f01122c90f344f7c9998638.tar.gz
superposition-60445b7a0e44a2537f01122c90f344f7c9998638.tar.bz2
superposition-60445b7a0e44a2537f01122c90f344f7c9998638.zip
add Monster Truck Destrucktion
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/monstertruckdestruction/Manifest3
-rw-r--r--games-sports/monstertruckdestruction/metadata.xml17
-rw-r--r--games-sports/monstertruckdestruction/monstertruckdestruction-1.ebuild81
3 files changed, 101 insertions, 0 deletions
diff --git a/games-sports/monstertruckdestruction/Manifest b/games-sports/monstertruckdestruction/Manifest
new file mode 100644
index 0000000..83c5fe1
--- /dev/null
+++ b/games-sports/monstertruckdestruction/Manifest
@@ -0,0 +1,3 @@
+DIST monstertruckdestruction_linux.zip 155708482 BLAKE2B 4cac815823f60ad42dcb28a4443063e8c79d4156186c102657c7b9a8835d5574184c7ba4a64a125de31b485a58cda251deacf830bc04e41e89d391edf3e26905 SHA512 dff0cb587f2e3ad5988e506f41634fcc34be466b53ae028b664f66806b4f6e2cdd718fad57daa0778b4b38c6c1401cfed7d20969a6a5e3c76e1b89b922f5d2a7
+EBUILD monstertruckdestruction-1.ebuild 1615 BLAKE2B 68fbfbfe866b9a9d726d928a81285daf460cf11a9e05ff8e4c8b033a5133acdfa7835ce798b1020289e0af5dfdc6e8ca0ae9a13fa85bd1061a044257b32df6d6 SHA512 c22af7e320ac787464cf0bb44f881c7f2779ade758edfad704c48ad363315ee359f0b7fc6225f2d3822687d53017909e5f70340e923037e1bce483b2ff85fe02
+MISC metadata.xml 743 BLAKE2B b511c04c842b8d8ddcf8634bcddadde8999e74103299f1a97b9ee9a2433addaff7f44e58ef958d1578a6bec346bbb5641b3ce45e32899aad68ecad11028a5760 SHA512 5619d223c4809e97d84c56412060ac1aa849ae40f3942b65448096dbcd55f1932d3276c39c3632a18b4faab1a51484061b43c1520f95fee4369d7e8e99a05d36
diff --git a/games-sports/monstertruckdestruction/metadata.xml b/games-sports/monstertruckdestruction/metadata.xml
new file mode 100644
index 0000000..962088c
--- /dev/null
+++ b/games-sports/monstertruckdestruction/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>phil_miess@yahoo.com</email>
+</maintainer>
+<longdescription lang="en">
+MONSTER
+Compete in 4 championships across 28 offroad tracks in drag or freestyle, land insane jumps, backflips and master your monster truck.
+
+TRUCK
+Drive over 60 licensed monster trucks such as BIGFOOT, USA-1, Boogey Van, Outback Thunda, Virginia Beast tanks, Traxxas RC trucks and upgrade your engine exhaust, intake, suspension and transmission to keep up with the competition.
+
+DESTRUCTION
+Realistic real-time damage and physics make this sim the ultimate Monster Truck game.
+</longdescription>
+</pkgmetadata>
diff --git a/games-sports/monstertruckdestruction/monstertruckdestruction-1.ebuild b/games-sports/monstertruckdestruction/monstertruckdestruction-1.ebuild
new file mode 100644
index 0000000..80789f9
--- /dev/null
+++ b/games-sports/monstertruckdestruction/monstertruckdestruction-1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit unpacker eutils gnome2-utils
+
+DESCRIPTION="Monster Truck Destruction is the best monster truck game! Great physics, real-time destruction and over 60 licensed trucks such as BIGFOOT and USA-1 to race in 28 dirt and snow covered tracks."
+HOMEPAGE="https://www.oddgames.com.au/games/monstertruckdestruction"
+SRC_URI="monstertruckdestruction_linux.zip"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="bindist fetch"
+
+MYGAMEDIR=/opt/${PN}
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}
+ dev-libs/expat
+ media-libs/glu
+ media-libs/mesa
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXxf86vm
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxshmfence
+"
+
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " https://www.humblebundle.com/store"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack_zip ${A}
+}
+
+src_configure() { :; }
+src_compile() { :; }
+
+src_install() {
+ arch=x86_64
+
+ insinto ${MYGAMEDIR}
+ exeinto ${MYGAMEDIR}
+ newexe "Linux/MTD.${arch}" "${PN}"
+ doins -r "Linux/MTD_Data"
+
+ newicon -s 128 Linux/MTD_Data/Resources/UnityPlayer.png ${PN}.png
+ make_wrapper ${PN} "${MYGAMEDIR}/${PN}" "${HOME}"
+ make_desktop_entry "${PN}" "MTD" "${PN}" "Game"
+
+
+ domenu ${PN}
+
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
+