summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2022-04-22 16:58:11 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2022-04-22 16:58:11 -0400
commita0d4e778b6cd0137f9c3ff82dac5a3304855d8be (patch)
treed6923f459fa6073c9d42af7242a9d5a9152e20fd /games-action
parentrestore eapi7 version (diff)
downloadsuperposition-a0d4e778b6cd0137f9c3ff82dac5a3304855d8be.tar.gz
superposition-a0d4e778b6cd0137f9c3ff82dac5a3304855d8be.tar.bz2
superposition-a0d4e778b6cd0137f9c3ff82dac5a3304855d8be.zip
try lastest version on eapi7x
Signed-off-by: Philip Miess <Philip_Miess@yahoo.com>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/minecraft-launcher/minecraft-launcher-1121.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/games-action/minecraft-launcher/minecraft-launcher-1121.ebuild b/games-action/minecraft-launcher/minecraft-launcher-1121.ebuild
new file mode 100644
index 0000000..37a5edf
--- /dev/null
+++ b/games-action/minecraft-launcher/minecraft-launcher-1121.ebuild
@@ -0,0 +1,64 @@
+ Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg
+
+# We can find which url we need for the latest release here:
+# https://launchermeta.mojang.com/v1/products/launcher/6f083b80d5e6fabbc4236f81d0d8f8a350c665a9/linux.json
+
+DESCRIPTION="An open-world game whose gameplay revolves around breaking and placing blocks"
+HOMEPAGE="https://www.minecraft.net/"
+SRC_URI="https://launcher.mojang.com/v1/objects/ce9e6169550628003e22de8086e9fe1186c2285e/minecraft-launcher -> ${P}
+ https://launcher.mojang.com/download/minecraft-launcher.svg"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+LICENSE="Mojang"
+SLOT="0"
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.24.32-r1[X(+)]
+ app-crypt/libsecret
+ dev-libs/nss
+ dev-libs/libbsd
+ dev-libs/libffi:0/8
+ dev-libs/libpcre
+ media-libs/alsa-lib
+ media-libs/openal
+ net-libs/gnutls[idn]
+ net-misc/curl[adns]
+ net-print/cups
+ sys-apps/dbus
+ virtual/jre:*
+ virtual/opengl
+ x11-apps/xrandr
+ x11-libs/libXScrnSaver
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/xcb-util
+"
+
+QA_PREBUILT="
+ usr/bin/minecraft-launcher
+"
+
+src_install() {
+ newbin "${DISTDIR}/${P}" ${PN}
+
+ doicon -s scalable "${DISTDIR}/${PN}.svg"
+ make_desktop_entry ${PN} "Minecraft" ${PN} Game
+}
+
+
+
+