summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-17 14:56:57 -0700
committerJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-17 14:56:57 -0700
commitd30de1fd683f7c28f312499dd2fde6f1089978c5 (patch)
treeb6d16cd64fe8a8ab9f3f6b6a9a428b09212ae99e /gui-apps/hyprlock/hyprlock-9999.ebuild
parentgui-libs/hyprutils: Add ebuild (diff)
downloadjohnmh-d30de1fd683f7c28f312499dd2fde6f1089978c5.tar.gz
johnmh-d30de1fd683f7c28f312499dd2fde6f1089978c5.tar.bz2
johnmh-d30de1fd683f7c28f312499dd2fde6f1089978c5.zip
gui-apps/hyprlock: Add ebuild
Signed-off-by: John M. Harris, Jr. <johnmh@johnmh.me>
Diffstat (limited to 'gui-apps/hyprlock/hyprlock-9999.ebuild')
-rw-r--r--gui-apps/hyprlock/hyprlock-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/gui-apps/hyprlock/hyprlock-9999.ebuild b/gui-apps/hyprlock/hyprlock-9999.ebuild
new file mode 100644
index 0000000..9e0551a
--- /dev/null
+++ b/gui-apps/hyprlock/hyprlock-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Hyprland's GPU-accelerated screen locking utility"
+HOMEPAGE="https://github.com/hyprwm/hyprlock"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/date
+ dev-libs/wayland
+ media-libs/mesa[opengl]
+ sys-libs/pam
+ dev-libs/glib:2
+ >=dev-libs/hyprlang-0.4.0
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ x11-libs/libdrm
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/0001-fix-CFLAGS-CXXFLAGS-hyprlock.patch"
+)