aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2016-03-15 01:37:55 +0100
committerGerion Entrup <gerion.entrup@flump.de>2016-03-15 01:37:55 +0100
commit8e76e37a957de30bf025b0eb0631d072feda7920 (patch)
treeef5f2058443f62173bdd5aebf6f39073371336dd /media-plugins
parentrename platform to p8-platform and add 2.0.1 release (diff)
downloadgerislay-8e76e37a957de30bf025b0eb0631d072feda7920.tar.gz
gerislay-8e76e37a957de30bf025b0eb0631d072feda7920.tar.bz2
gerislay-8e76e37a957de30bf025b0eb0631d072feda7920.zip
use jarvis release of kodi-pvr-hts
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/kodi-pvr-hts/Manifest4
-rw-r--r--media-plugins/kodi-pvr-hts/files/kodi-pvr-hts-2.2.13-platform-renaming.patch391
-rw-r--r--media-plugins/kodi-pvr-hts/kodi-pvr-hts-2.2.13.ebuild (renamed from media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild)15
3 files changed, 403 insertions, 7 deletions
diff --git a/media-plugins/kodi-pvr-hts/Manifest b/media-plugins/kodi-pvr-hts/Manifest
index 4b52128..670b7a5 100644
--- a/media-plugins/kodi-pvr-hts/Manifest
+++ b/media-plugins/kodi-pvr-hts/Manifest
@@ -1 +1,3 @@
-EBUILD kodi-pvr-hts-9999.ebuild 585 SHA256 e6939835d22a84af1e35bbf0f1389c3d9df9542194255faa114ac8971d350dd1 SHA512 bf5f7a753095a9a3570b9eccc700e80d86c07c08cab3cf395ce9dd69eb674181763599b9f0d8e64a9e8da7f42bef23e695b5bae8a86b57613fc30281b0f79ba7 WHIRLPOOL 082706d55c81fdde8ce4b6eaa67376401982618b2a60c0c812878d49f938e93612ddc92078b19bca25465432ad0088c79444906e43888858fa2a4e26213854d3
+AUX kodi-pvr-hts-2.2.13-platform-renaming.patch 11344 SHA256 a060fb9a2461bab36c5ff617f56f4179283c0ce252946792a53f7b58dc159ecc SHA512 c01b19a07248f3217c0342f273e105a9d91e5fd55aa3d66f8c9fd7b129db01b152a4397a217941299ed03567a278172c666a56f5138378972b7ab9f924f99651 WHIRLPOOL 1fceb3f8aefb949f5b75477400e0237a8f2ee3e33647ae292edb4242788ba5f5dd48046d8d3c3886e61623833ed96aade818ff7a947baefc26b32baece51d9d9
+DIST 2.2.13.tar.gz 184912 SHA256 74100c9b50bebf2c647c46c0a6998adffb89051a920b8b1a102118ce57d0f32c SHA512 62859b04788f7f975c6bdfa7814a425a55a6b2812ed40bfb7b6258b176dfe9b73dfdc02e103278ee1bbc5c54aa903b11d3db5332028b68bfcef99e60431f0b03 WHIRLPOOL 1386f892b7999401d909cedaa31eb95a445d8a96bb5b1e48e8144b973243074d094fd29109ccc9c625d0dcfee1dbc8b9128571014401ef2c9ee504efdb345a87
+EBUILD kodi-pvr-hts-2.2.13.ebuild 691 SHA256 7914a32a21d56d8939722ed1304428f5950e62a5ef388cb04dd225668fee8967 SHA512 5368d7bfe5c0d0a61a6e1185ab1d6650c59f33c15133e7a8e5f7dcbad1e35700a3058bc8df4e41df6f41a59a79cfb4d471e9a8e2c5cae505461d30b1899164bf WHIRLPOOL dd70ed3687590c4e5bd8fd7d70f87143f082a0529d19a23eedd5e0fbb292548ee3322fd350f6669846aa4553feb92f3c364adaa03ee2660ec2eded845fbd4b23
diff --git a/media-plugins/kodi-pvr-hts/files/kodi-pvr-hts-2.2.13-platform-renaming.patch b/media-plugins/kodi-pvr-hts/files/kodi-pvr-hts-2.2.13-platform-renaming.patch
new file mode 100644
index 0000000..ec4fe9e
--- /dev/null
+++ b/media-plugins/kodi-pvr-hts/files/kodi-pvr-hts-2.2.13-platform-renaming.patch
@@ -0,0 +1,391 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0842682..cb04942 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,10 +6,10 @@ enable_language(CXX)
+
+ find_package(kodi REQUIRED)
+ find_package(kodiplatform REQUIRED)
+-find_package(platform REQUIRED)
++find_package(p8-platform REQUIRED)
+
+ include_directories(${kodiplatform_INCLUDE_DIRS}
+- ${platform_INCLUDE_DIRS}
++ ${p8-platform_INCLUDE_DIRS}
+ ${KODI_INCLUDE_DIR}
+ ${PROJECT_SOURCE_DIR}/lib)
+
+@@ -95,7 +95,7 @@ list(APPEND HTS_SOURCES
+
+ add_subdirectory(lib/libhts)
+
+-set(DEPLIBS ${platform_LIBRARIES} hts)
++set(DEPLIBS ${p8-platform_LIBRARIES} hts)
+ if(WIN32)
+ list(APPEND DEPLIBS ws2_32)
+ endif()
+diff --git a/lib/libhts/OSXGNUReplacements.h b/lib/libhts/OSXGNUReplacements.h
+index 052bf34..f5f3353 100644
+--- a/lib/libhts/OSXGNUReplacements.h
++++ b/lib/libhts/OSXGNUReplacements.h
+@@ -1,5 +1,5 @@
+-#ifndef __OSXPLATFORM_H__
+-#define __OSXPLATFORM_H__
++#ifndef __OSXP8PLATFORM_H__
++#define __OSXP8PLATFORM_H__
+ /*
+ * Copyright (C) 2005-2009 Team XBMC
+ * http://www.xbmc.org
+diff --git a/src/AutoRecordings.cpp b/src/AutoRecordings.cpp
+index 5fa60a0..d9e5e1d 100644
+--- a/src/AutoRecordings.cpp
++++ b/src/AutoRecordings.cpp
+@@ -26,7 +26,7 @@
+ #include "tvheadend/utilities/Utilities.h"
+ #include "tvheadend/utilities/Logger.h"
+
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+ using namespace tvheadend;
+ using namespace tvheadend::entity;
+ using namespace tvheadend::utilities;
+diff --git a/src/HTSPConnection.cpp b/src/HTSPConnection.cpp
+index aec1296..86f5004 100644
+--- a/src/HTSPConnection.cpp
++++ b/src/HTSPConnection.cpp
+@@ -19,9 +19,9 @@
+ *
+ */
+
+-#include "platform/threads/mutex.h"
+-#include "platform/util/StringUtils.h"
+-#include "platform/sockets/tcp.h"
++#include "p8-platform/threads/mutex.h"
++#include "p8-platform/util/StringUtils.h"
++#include "p8-platform/sockets/tcp.h"
+
+ extern "C" {
+ #include "libhts/htsmsg_binary.h"
+@@ -33,7 +33,7 @@ extern "C" {
+
+ using namespace std;
+ using namespace ADDON;
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+ using namespace tvheadend;
+ using namespace tvheadend::utilities;
+
+diff --git a/src/HTSPDemuxer.cpp b/src/HTSPDemuxer.cpp
+index a6e1f12..7f45345 100644
+--- a/src/HTSPDemuxer.cpp
++++ b/src/HTSPDemuxer.cpp
+@@ -27,7 +27,7 @@
+
+ using namespace std;
+ using namespace ADDON;
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+ using namespace tvheadend;
+ using namespace tvheadend::utilities;
+
+diff --git a/src/HTSPVFS.cpp b/src/HTSPVFS.cpp
+index 0463f56..0404bab 100644
+--- a/src/HTSPVFS.cpp
++++ b/src/HTSPVFS.cpp
+@@ -19,8 +19,8 @@
+ *
+ */
+
+-#include "platform/threads/mutex.h"
+-#include "platform/util/StringUtils.h"
++#include "p8-platform/threads/mutex.h"
++#include "p8-platform/util/StringUtils.h"
+ #include "tvheadend/utilities/Logger.h"
+
+ extern "C" {
+@@ -30,7 +30,7 @@ extern "C" {
+ #include "Tvheadend.h"
+
+ using namespace std;
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+ using namespace tvheadend::utilities;
+
+ /*
+diff --git a/src/TimeRecordings.cpp b/src/TimeRecordings.cpp
+index 5d34938..97aae09 100644
+--- a/src/TimeRecordings.cpp
++++ b/src/TimeRecordings.cpp
+@@ -25,7 +25,7 @@
+ #include "tvheadend/utilities/Utilities.h"
+ #include "tvheadend/utilities/Logger.h"
+
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+ using namespace tvheadend;
+ using namespace tvheadend::entity;
+ using namespace tvheadend::utilities;
+diff --git a/src/Tvheadend.cpp b/src/Tvheadend.cpp
+index 2057241..14c3bd4 100644
+--- a/src/Tvheadend.cpp
++++ b/src/Tvheadend.cpp
+@@ -23,7 +23,7 @@
+ #include <ctime>
+ #include <memory>
+
+-#include "platform/util/StringUtils.h"
++#include "p8-platform/util/StringUtils.h"
+
+ #include "Tvheadend.h"
+ #include "tvheadend/utilities/Utilities.h"
+@@ -31,7 +31,7 @@
+
+ using namespace std;
+ using namespace ADDON;
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+ using namespace tvheadend;
+ using namespace tvheadend::entity;
+ using namespace tvheadend::utilities;
+diff --git a/src/Tvheadend.h b/src/Tvheadend.h
+index 2ce4552..e794716 100644
+--- a/src/Tvheadend.h
++++ b/src/Tvheadend.h
+@@ -22,10 +22,10 @@
+ */
+
+ #include "client.h"
+-#include "platform/sockets/tcp.h"
+-#include "platform/threads/threads.h"
+-#include "platform/threads/mutex.h"
+-#include "platform/util/buffer.h"
++#include "p8-platform/sockets/tcp.h"
++#include "p8-platform/threads/threads.h"
++#include "p8-platform/threads/mutex.h"
++#include "p8-platform/util/buffer.h"
+ #include "kodi/xbmc_codec_types.h"
+ #include "kodi/xbmc_stream_utils.hpp"
+ #include "kodi/libXBMC_addon.h"
+@@ -88,7 +88,7 @@ class CHTSPMessage;
+
+ /* Typedefs */
+ typedef std::map<uint32_t,CHTSPResponse*> CHTSPResponseList;
+-typedef PLATFORM::SyncedBuffer<CHTSPMessage> CHTSPMessageQueue;
++typedef P8PLATFORM::SyncedBuffer<CHTSPMessage> CHTSPMessageQueue;
+
+ /*
+ * HTSP Response handler
+@@ -98,10 +98,10 @@ class CHTSPResponse
+ public:
+ CHTSPResponse();
+ ~CHTSPResponse();
+- htsmsg_t *Get ( PLATFORM::CMutex &mutex, uint32_t timeout );
++ htsmsg_t *Get ( P8PLATFORM::CMutex &mutex, uint32_t timeout );
+ void Set ( htsmsg_t *m );
+ private:
+- PLATFORM::CCondition<volatile bool> m_cond;
++ P8PLATFORM::CCondition<volatile bool> m_cond;
+ bool m_flag;
+ htsmsg_t *m_msg;
+ };
+@@ -146,7 +146,7 @@ public:
+ * HTSP Connection registration thread
+ */
+ class CHTSPRegister
+- : public PLATFORM::CThread
++ : public P8PLATFORM::CThread
+ {
+ friend class CHTSPConnection;
+
+@@ -163,7 +163,7 @@ private:
+ * HTSP Connection
+ */
+ class CHTSPConnection
+- : public PLATFORM::CThread
++ : public P8PLATFORM::CThread
+ {
+ friend class CHTSPRegister;
+
+@@ -190,7 +190,7 @@ public:
+ inline bool IsConnected ( void ) const { return m_ready; }
+ bool WaitForConnection ( void );
+
+- inline PLATFORM::CMutex& Mutex ( void ) { return m_mutex; }
++ inline P8PLATFORM::CMutex& Mutex ( void ) { return m_mutex; }
+
+ void OnSleep ( void );
+ void OnWake ( void );
+@@ -202,10 +202,10 @@ private:
+ bool SendHello ( void );
+ bool SendAuth ( const std::string &u, const std::string &p );
+
+- PLATFORM::CTcpSocket *m_socket;
+- PLATFORM::CMutex m_mutex;
++ P8PLATFORM::CTcpSocket *m_socket;
++ P8PLATFORM::CMutex m_mutex;
+ CHTSPRegister m_regThread;
+- PLATFORM::CCondition<volatile bool> m_regCond;
++ P8PLATFORM::CCondition<volatile bool> m_regCond;
+ bool m_ready;
+ uint32_t m_seq;
+ std::string m_serverName;
+@@ -273,13 +273,13 @@ public:
+ void SetStreamingProfile(const std::string &profile);
+
+ private:
+- PLATFORM::CMutex m_mutex;
++ P8PLATFORM::CMutex m_mutex;
+ CHTSPConnection &m_conn;
+- PLATFORM::SyncedBuffer<DemuxPacket*> m_pktBuffer;
++ P8PLATFORM::SyncedBuffer<DemuxPacket*> m_pktBuffer;
+ ADDON::XbmcStreamProperties m_streams;
+ std::map<int,int> m_streamStat;
+ int64_t m_seekTime;
+- PLATFORM::CCondition<volatile int64_t> m_seekCond;
++ P8PLATFORM::CCondition<volatile int64_t> m_seekCond;
+ bool m_seeking;
+ bool m_speedChange;
+ tvheadend::status::SourceInfo m_sourceInfo;
+@@ -350,7 +350,7 @@ private:
+ * Root object for Tvheadend connection
+ */
+ class CTvheadend
+- : public PLATFORM::CThread
++ : public P8PLATFORM::CThread
+ {
+ public:
+ CTvheadend();
+@@ -422,7 +422,7 @@ private:
+ */
+ tvheadend::Profiles m_profiles;
+
+- PLATFORM::CMutex m_mutex;
++ P8PLATFORM::CMutex m_mutex;
+
+ CHTSPConnection m_conn;
+
+@@ -519,7 +519,7 @@ public:
+ */
+ bool WaitForConnection ( void )
+ {
+- PLATFORM::CLockObject lock(m_conn.Mutex());
++ P8PLATFORM::CLockObject lock(m_conn.Mutex());
+ return m_conn.WaitForConnection();
+ }
+ std::string GetServerName ( void )
+diff --git a/src/client.cpp b/src/client.cpp
+index 94d2db9..3295914 100644
+--- a/src/client.cpp
++++ b/src/client.cpp
+@@ -22,14 +22,14 @@
+ #include "client.h"
+ #include "kodi/xbmc_pvr_dll.h"
+ #include "kodi/libKODI_guilib.h"
+-#include "platform/util/util.h"
++#include "p8-platform/util/util.h"
+ #include "Tvheadend.h"
+ #include "tvheadend/Settings.h"
+ #include "tvheadend/utilities/Logger.h"
+
+ using namespace std;
+ using namespace ADDON;
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+ using namespace tvheadend;
+ using namespace tvheadend::utilities;
+
+diff --git a/src/client.h b/src/client.h
+index 3a5f950..a10659b 100644
+--- a/src/client.h
++++ b/src/client.h
+@@ -20,8 +20,8 @@
+ *
+ */
+
+-#include "platform/os.h"
+-#include "platform/threads/mutex.h"
++#include "p8-platform/os.h"
++#include "p8-platform/threads/mutex.h"
+ #include "kodi/libXBMC_addon.h"
+ #include "kodi/libXBMC_pvr.h"
+ #include "kodi/libXBMC_codec.h"
+diff --git a/src/tvheadend/Subscription.cpp b/src/tvheadend/Subscription.cpp
+index 182ca7f..e18af1e 100644
+--- a/src/tvheadend/Subscription.cpp
++++ b/src/tvheadend/Subscription.cpp
+@@ -23,7 +23,7 @@
+ #include "utilities/Logger.h"
+ #include "../Tvheadend.h"
+
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+ using namespace tvheadend;
+ using namespace tvheadend::utilities;
+
+diff --git a/src/tvheadend/Subscription.h b/src/tvheadend/Subscription.h
+index b03bcce..363e5ef 100644
+--- a/src/tvheadend/Subscription.h
++++ b/src/tvheadend/Subscription.h
+@@ -22,7 +22,7 @@
+ */
+
+ #include <string>
+-#include "platform/threads/mutex.h"
++#include "p8-platform/threads/mutex.h"
+
+ extern "C"
+ {
+@@ -146,6 +146,6 @@ namespace tvheadend
+ std::string m_profile;
+ CHTSPConnection &m_conn;
+
+- mutable PLATFORM::CMutex m_mutex;
++ mutable P8PLATFORM::CMutex m_mutex;
+ };
+ }
+diff --git a/src/tvheadend/utilities/AsyncState.cpp b/src/tvheadend/utilities/AsyncState.cpp
+index 0c30a93..1f4fdf3 100644
+--- a/src/tvheadend/utilities/AsyncState.cpp
++++ b/src/tvheadend/utilities/AsyncState.cpp
+@@ -22,7 +22,7 @@
+ #include "AsyncState.h"
+
+ using namespace tvheadend::utilities;
+-using namespace PLATFORM;
++using namespace P8PLATFORM;
+
+ struct Param {
+ eAsyncState state;
+@@ -37,7 +37,7 @@ AsyncState::AsyncState(int timeout)
+
+ eAsyncState AsyncState::GetState()
+ {
+- PLATFORM::CLockObject lock(m_mutex);
++ P8PLATFORM::CLockObject lock(m_mutex);
+ return m_state;
+ }
+
+diff --git a/src/tvheadend/utilities/AsyncState.h b/src/tvheadend/utilities/AsyncState.h
+index 1d672da..0819cd8 100644
+--- a/src/tvheadend/utilities/AsyncState.h
++++ b/src/tvheadend/utilities/AsyncState.h
+@@ -22,7 +22,7 @@
+ #ifndef ASYNCSTATE_H
+ #define ASYNCSTATE_H
+
+-#include "platform/threads/mutex.h"
++#include "p8-platform/threads/mutex.h"
+
+ namespace tvheadend {
+ namespace utilities {
+@@ -75,8 +75,8 @@ namespace tvheadend {
+ static bool PredicateCallback ( void *param );
+
+ eAsyncState m_state;
+- PLATFORM::CMutex m_mutex;
+- PLATFORM::CCondition<bool> m_condition;
++ P8PLATFORM::CMutex m_mutex;
++ P8PLATFORM::CCondition<bool> m_condition;
+ int m_timeout;
+
+ };
diff --git a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-2.2.13.ebuild
index 3b201ea..51d1e53 100644
--- a/media-plugins/kodi-pvr-hts/kodi-pvr-hts-9999.ebuild
+++ b/media-plugins/kodi-pvr-hts/kodi-pvr-hts-2.2.13.ebuild
@@ -4,22 +4,25 @@
EAPI=5
-inherit git-r3 cmake-utils
-
-EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.hts.git"
+inherit cmake-utils
DESCRIPTION="Tvheadend HTSP PVR client addon for Kodi"
HOMEPAGE="https://github.com/kodi-pvr/pvr.hts"
-SRC_URI=""
+SRC_URI="https://github.com/kodi-pvr/pvr.hts/archive/2.2.13.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
IUSE=""
-DEPEND="media-libs/kodi-platform"
+DEPEND="media-libs/kodi-platform
+ =media-tv/kodi-16*"
RDEPEND="${DEPEND}"
+S="${WORKDIR}/pvr.hts-${PV}"
+
+PATCHES=( "${FILESDIR}/${P}-platform-renaming.patch" )
+
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_LIBDIR="${EPREFIX}"/usr/lib64/kodi