aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:27:57 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commit9130228e29b0cc61ab6ad3c7373d0b7e33ffebed (patch)
tree32daebd2997b21c313018b1d8c2ccbb2faa8cb99
parentRevert "sys-devel/lld: Remove LLVM 14" (diff)
downloadgerislay-9130228e29b0cc61ab6ad3c7373d0b7e33ffebed.tar.gz
gerislay-9130228e29b0cc61ab6ad3c7373d0b7e33ffebed.tar.bz2
gerislay-9130228e29b0cc61ab6ad3c7373d0b7e33ffebed.zip
Revert "sys-devel/lld-toolchain-symlinks: Remove LLVM 14"
This reverts commit e0560045f6c88a9707df1fc0578e0e43319efaff. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild
new file mode 100644
index 0000000..833ce1b
--- /dev/null
+++ b/sys-devel/lld-toolchain-symlinks/lld-toolchain-symlinks-14-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib
+
+DESCRIPTION="Symlinks to use LLD on binutils-free system"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:LLVM"
+S=${WORKDIR}
+
+LICENSE="public-domain"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="multilib-symlinks +native-symlinks"
+
+RDEPEND="
+ sys-devel/lld:${SLOT}
+"
+
+src_install() {
+ use native-symlinks || return
+
+ local chosts=( "${CHOST}" )
+ if use multilib-symlinks; then
+ local abi
+ for abi in $(get_all_abis); do
+ chosts+=( "$(get_abi_CHOST "${abi}")" )
+ done
+ fi
+
+ local dest=/usr/lib/llvm/${SLOT}/bin
+ dodir "${dest}"
+ dosym ld.lld "${dest}/ld"
+ for chost in "${chosts[@]}"; do
+ dosym ld.lld "${dest}/${chost}-ld"
+ done
+}