aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:27:20 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commit8acf9b84da31a783243693ca62c1ee54d85fb1da (patch)
tree8adbf3382bef2d0c69ba9d368966b9c9b19478b1
parentRevert "dev-ml/llvm-ocaml: Remove LLVM 14" (diff)
downloadgerislay-8acf9b84da31a783243693ca62c1ee54d85fb1da.tar.gz
gerislay-8acf9b84da31a783243693ca62c1ee54d85fb1da.tar.bz2
gerislay-8acf9b84da31a783243693ca62c1ee54d85fb1da.zip
Revert "sys-devel/clang-common: Remove LLVM 14"
This reverts commit bee3e15ba3d44d1d55cab86b7a2bf97b2a932b9e. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--sys-devel/clang-common/clang-common-14.0.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/clang-common/clang-common-14.0.6.ebuild b/sys-devel/clang-common/clang-common-14.0.6.ebuild
new file mode 100644
index 0000000..38e08a5
--- /dev/null
+++ b/sys-devel/clang-common/clang-common-14.0.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+
+PDEPEND="
+ sys-devel/clang:*
+"
+
+LLVM_COMPONENTS=( clang/utils )
+llvm.org_set_globals
+
+src_install() {
+ newbashcomp bash-autocomplete.sh clang
+}