aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2023-07-15 00:07:40 +0200
committerGerion Entrup <gerion.entrup@flump.de>2023-07-15 00:07:40 +0200
commit6d0461d9e98369a351b0f8b3bc00d25afbed387d (patch)
tree6ac1a75efa16fa0e7b8d17ab1c66fcdfc7eff8ca
parentdev-python/ptpython: fix dependencies (diff)
downloadgerislay-6d0461d9e98369a351b0f8b3bc00d25afbed387d.tar.gz
gerislay-6d0461d9e98369a351b0f8b3bc00d25afbed387d.tar.bz2
gerislay-6d0461d9e98369a351b0f8b3bc00d25afbed387d.zip
net-libs/libquotient: add 0.8.0
However, Neochat does not build with it yet. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--net-libs/libquotient/Manifest5
-rw-r--r--net-libs/libquotient/files/libquotient-0.7.0-no-tests.patch34
-rw-r--r--net-libs/libquotient/files/libquotient-0.8.0-no-android.patch15
-rw-r--r--net-libs/libquotient/libquotient-0.8.0.ebuild62
-rw-r--r--net-libs/libquotient/metadata.xml11
5 files changed, 127 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
new file mode 100644
index 0000000..8e408fd
--- /dev/null
+++ b/net-libs/libquotient/Manifest
@@ -0,0 +1,5 @@
+AUX libquotient-0.7.0-no-tests.patch 1234 BLAKE2B 60a3da8a15c9c77d8c997b0c0d95a6e13e9d332fdcbee2e6a88882269969519a82daea1280721ff6661a410f03fbd43d5233d8f4804896af637dfca67dd7111f SHA512 e2aa9d7ddca5d7cbb9323d3be9551515b726293c14eb34b4374f701082d9ce21af9f39836ecfada4247b25f1fe6b8fdd2f62976c32658e7d48266f02123ff582
+AUX libquotient-0.8.0-no-android.patch 623 BLAKE2B 77717188e7fad578ffc6ca673136e99bf002884e2d96457650c63cd6dbe749e31874c3b237f824962e49ec962e8845f4cd94f37c73e6e9e28cd289add1b85d83 SHA512 753b09f318142447711870746cd6a581aec0348521382659f753a58ec283adf0e189348ad229c9f4ab1d13315eb729658a2d53bb27efdf0f5852cfa9fba0c5a7
+DIST libquotient-0.8.0.tar.gz 725645 BLAKE2B f8374e31755f73957bef5ec960e04e131bddaba8f05b43cb369dd2dda62021f22ab1e7c640f73c874db83b580a5ef789df1c5cf4590d8395d2aaaa5fdce7c506 SHA512 5ea12d8c1e0091a0dd1a6130b9ca540f993ad560acbe6391522eacae6c38ef83665338bb407d0898d03bac5e0660b46db2f735b9ded35ff4b195a8d34c8c96ff
+EBUILD libquotient-0.8.0.ebuild 1269 BLAKE2B d76481e9441dea41a3bf5a7366593915e3fe49f510cbdb5f0f6237f538c8c9b77cce7b60c4d8f54e5c8d05b3b2460ab574c901327d6798fd679e661815f5ce09 SHA512 47e0480e75630922e8f0995783644c943ae5a78f376e879c4a94a2c38d04d5111fbd2b062b2ee743b5736cc2aaa473bb76480038646ec987dfd3dd9ce57957b5
+MISC metadata.xml 338 BLAKE2B 84af57de6f4faeb65a9a9bd272a29e6cb4491e8eff3d79c4704566baa4af7cfa2f9c6c14a52a0a44e8751848b9e89f30807a6d0c304eb28d8b2cb9f43f0b37c5 SHA512 f93f27e29f09f8e6e6c0038a403990260c8998213c8248c2acbfc1f7e76faa07c296d4b30214c746f30d42b37d636be92720e692280098d4d72d3d542b5004aa
diff --git a/net-libs/libquotient/files/libquotient-0.7.0-no-tests.patch b/net-libs/libquotient/files/libquotient-0.7.0-no-tests.patch
new file mode 100644
index 0000000..510b8a0
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.7.0-no-tests.patch
@@ -0,0 +1,34 @@
+From e5cc442f13aee922f6b2a954ad52b7aa8c558b2c Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 24 Dec 2022 22:51:12 +0100
+Subject: [PATCH] Put Qt5Test dependency behind -DBUILD_TESTING
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 523f5ae7..9ae697b2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -93,7 +93,7 @@ else()
+ set(QtExtraModules "Multimedia") # See #483
+ endif()
+ string(REGEX REPLACE "^(.).*" "Qt\\1" Qt ${QtMinVersion}) # makes "Qt5" or "Qt6"
+-find_package(${Qt} ${QtMinVersion} REQUIRED Core Network Gui Test ${QtExtraModules})
++find_package(${Qt} ${QtMinVersion} REQUIRED Core Network Gui ${QtExtraModules})
+ get_filename_component(Qt_Prefix "${${Qt}_DIR}/../../../.." ABSOLUTE)
+ message(STATUS "Using Qt ${${Qt}_VERSION} at ${Qt_Prefix}")
+
+@@ -342,6 +342,7 @@ configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}
+ # Configure testing
+
+ if (BUILD_TESTING)
++ find_package(${Qt}Test ${QtMinVersion} REQUIRED)
+ enable_testing()
+ add_subdirectory(quotest)
+ add_subdirectory(autotests)
+--
+2.39.0
+
diff --git a/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch b/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch
new file mode 100644
index 0000000..19dca18
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch
@@ -0,0 +1,15 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0a32ee4e..4200f29c 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -387,7 +387,9 @@ install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/${QUOTIENT_LIB_NAME}/${QUOTIENT_LIB_NAME}ConfigVersion.cmake"
+ DESTINATION ${CMakeFilesLocation}
+ )
+-install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++if (ANDROID)
++ install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++endif ()
+
+ if (WIN32)
+ install(FILES mime/packages/freedesktop.org.xml DESTINATION mime/packages)
diff --git a/net-libs/libquotient/libquotient-0.8.0.ebuild b/net-libs/libquotient/libquotient-0.8.0.ebuild
new file mode 100644
index 0000000..ec06eb2
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/olm
+ dev-libs/openssl:=
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qttest:5
+ )
+"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.8.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.7.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DQuotient_ENABLE_E2EE=ON
+ )
+ use test && mycmakeargs+=(
+ -DQuotient_INSTALL_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # https://github.com/quotient-im/libQuotient/issues/435
+ # testolmaccount requires network connection/server set up
+ local myctestargs=(
+ -j1
+ -E "(testolmaccount)"
+ )
+ cmake_src_test
+}
diff --git a/net-libs/libquotient/metadata.xml b/net-libs/libquotient/metadata.xml
new file mode 100644
index 0000000..046004b
--- /dev/null
+++ b/net-libs/libquotient/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">quotient-im/libQuotient</remote-id>
+ </upstream>
+</pkgmetadata>