aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerion Entrup <gerion.entrup@flump.de>2024-06-25 10:26:31 +0200
committerGerion Entrup <gerion.entrup@flump.de>2024-06-30 23:07:04 +0200
commit42282972feec5bd2d5215291dec83363651b2ec5 (patch)
tree6cfe4d52997b5accf5a654aed67a48d349aa625d
parentclang: preperations (diff)
downloadgerislay-42282972feec5bd2d5215291dec83363651b2ec5.tar.gz
gerislay-42282972feec5bd2d5215291dec83363651b2ec5.tar.bz2
gerislay-42282972feec5bd2d5215291dec83363651b2ec5.zip
Revert "sys-devel/llvm-common: Remove LLVM 14"
This reverts commit de863472925ed651c98ed7148ca3217ad50b33f8. Signed-off-by: Gerion Entrup <gerion.entrup@flump.de>
-rw-r--r--sys-devel/llvm-common/llvm-common-14.0.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-devel/llvm-common/llvm-common-14.0.6.ebuild b/sys-devel/llvm-common/llvm-common-14.0.6.ebuild
new file mode 100644
index 0000000..c8fdea8
--- /dev/null
+++ b/sys-devel/llvm-common/llvm-common-14.0.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="emacs"
+
+RDEPEND="
+ !sys-devel/llvm:0
+"
+BDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+LLVM_COMPONENTS=( llvm/utils )
+llvm.org_set_globals
+
+SITEFILE="50llvm-gentoo.el"
+BYTECOMPFLAGS="-L emacs"
+
+src_compile() {
+ default
+
+ use emacs && elisp-compile emacs/*.el
+}
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/*/
+ # some users may find it useful
+ newdoc vim/README README.vim
+ dodoc vim/vimrc
+
+ if use emacs ; then
+ elisp-install llvm emacs/*.{el,elc}
+ elisp-make-site-file "${SITEFILE}" llvm
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}