aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrei Horodniceanu <a.horodniceanu@proton.me>2024-03-13 23:26:56 +0200
committerAndrei Horodniceanu <a.horodniceanu@proton.me>2024-03-13 23:26:56 +0200
commit67a4acd140ec6a9207b42b0c60d43346a1d3523f (patch)
tree3950b296b4be7fd00d1061c566623a591b2ac594 /dev-lang
parentdev-lang/ldc2: drop 1.32.2 (diff)
downloaddlang-67a4acd140ec6a9207b42b0c60d43346a1d3523f.tar.gz
dlang-67a4acd140ec6a9207b42b0c60d43346a1d3523f.tar.bz2
dlang-67a4acd140ec6a9207b42b0c60d43346a1d3523f.zip
dev-lang/ldc2: drop 1.33.0
Signed-off-by: Andrei Horodniceanu <a.horodniceanu@proton.me>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ldc2/ldc2-1.33.0.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/dev-lang/ldc2/ldc2-1.33.0.ebuild b/dev-lang/ldc2/ldc2-1.33.0.ebuild
deleted file mode 100644
index 37cc843..0000000
--- a/dev-lang/ldc2/ldc2-1.33.0.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-build cmake llvm
-
-MY_PV="${PV//_/-}"
-MY_P="ldc-${MY_PV}-src"
-SRC_URI="https://github.com/ldc-developers/ldc/releases/download/v${MY_PV}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="LLVM D Compiler"
-HOMEPAGE="https://github.com/ldc-developers/ldc"
-KEYWORDS="amd64 ~arm64 x86"
-LICENSE="BSD"
-SLOT="$(ver_cut 1-2)/$(ver_cut 3)"
-
-IUSE="static-libs"
-
-# Upstream supports LLVM 9.0 through 15.0.
-RDEPEND="
- || (
- sys-devel/llvm:15
- sys-devel/llvm:14
- )
- <sys-devel/llvm-16:=
- >=app-eselect/eselect-dlang-20140709"
-DEPEND="${RDEPEND}"
-LLVM_MAX_SLOT=15
-PATCHES="${FILESDIR}/ldc2-1.15.0-link-defaultlib-shared.patch"
-
-# For now, we support amd64 multilib. Anyone is free to add more support here.
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-
-# Upstream supports "2.079-"
-DLANG_VERSION_RANGE="2.075-2.080 2.082-2.106"
-DLANG_PACKAGE_TYPE="single"
-
-inherit dlang
-
-src_prepare() {
- cmake_src_prepare
-}
-
-d_src_configure() {
- # Make sure libphobos2 is installed into ldc2's directory.
- export LIBDIR_${ABI}="${LIBDIR_HOST}"
- local mycmakeargs=(
- -DD_VERSION=2
- -DCMAKE_INSTALL_PREFIX=/usr/lib/ldc2/$(ver_cut 1-2)
- -DD_COMPILER="${DMD} $(dlang_dmdw_dcflags)"
- -DLDC_WITH_LLD=OFF
- )
- use static-libs && mycmakeargs+=( -DBUILD_SHARED_LIBS=BOTH ) || mycmakeargs+=( -DBUILD_SHARED_LIBS=ON )
- use abi_x86_32 && use abi_x86_64 && mycmakeargs+=( -DMULTILIB=ON )
- cmake_src_configure
-}
-
-d_src_compile()
-{
- cmake_src_compile
-}
-
-d_src_install() {
- cmake_src_install
-
- rm -rf "${ED}"/usr/share/bash-completion
-}
-
-pkg_postinst() {
- # Update active ldc2
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}
-
-pkg_postrm() {
- "${ROOT}"/usr/bin/eselect dlang update ldc2
-}