aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorILMostro <ilmostro7@gmail.com>2018-06-21 15:40:34 -0500
committerILMostro <ilmostro7@gmail.com>2018-06-21 15:40:34 -0500
commit50a18804ae259b4946de28edab5c2620c26f3fa0 (patch)
treed08ba756babc442795c5c55ffed4fd9e62c97d7c /dev-lang/luajit/luajit-2.0.5.ebuild
parentupdate list of packages with weechat (diff)
downloadag-ops-50a18804ae259b4946de28edab5c2620c26f3fa0.tar.gz
ag-ops-50a18804ae259b4946de28edab5c2620c26f3fa0.tar.bz2
ag-ops-50a18804ae259b4946de28edab5c2620c26f3fa0.zip
added `dev-lang/luajit`; upgraded to EAPI=7 w/support for slotted dev-lang/lua.
A patch is added to correct prefix to `/usr` and to get the currect LUA_VERSION. HOTFIX and other stuff is removed
Diffstat (limited to 'dev-lang/luajit/luajit-2.0.5.ebuild')
-rw-r--r--dev-lang/luajit/luajit-2.0.5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/luajit/luajit-2.0.5.ebuild b/dev-lang/luajit/luajit-2.0.5.ebuild
new file mode 100644
index 0000000..b689aa7
--- /dev/null
+++ b/dev-lang/luajit/luajit-2.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils multilib pax-utils toolchain-funcs
+
+MY_PV="$(ver_cut 1-3)"
+MY_P="LuaJIT-${MY_PV}"
+
+DESCRIPTION="Just-In-Time Compiler for the Lua programming language"
+HOMEPAGE="http://luajit.org/"
+SRC_URI="http://luajit.org/download/${MY_P}.tar.gz"
+LICENSE="MIT"
+# this should probably be pkgmoved to 2.0 for sake of consistency.
+SLOT="2.0.5"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${MY_P}"
+
+# LUA_VERSION=$(readlink -e "${EROOT}"/usr/bin/lua | sed -ne 's:.*/usr/bin/lua\([\d.-]*\):\1:p')
+
+HTML_DOCS=( doc/* )
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+src_prepare(){
+ default
+ eapply_user
+}
+
+src_install(){
+ default
+
+ pax-mark m "${ED}usr/bin/luajit-${MY_PV}"
+
+ einstalldocs
+}