aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorILMostro <ilmostro7@gmail.com>2018-06-22 23:31:48 -0500
committerILMostro <ilmostro7@gmail.com>2018-06-22 23:31:48 -0500
commitaa3b462be2ea1d91bf05c89ed5157569fd7230f1 (patch)
treeb810c34ce21c6011c2d1fadb2107755b732c4fb1
parentnet-libs/zeromq asciidoc --> asciidoctor (diff)
downloadag-ops-aa3b462be2ea1d91bf05c89ed5157569fd7230f1.tar.gz
ag-ops-aa3b462be2ea1d91bf05c89ed5157569fd7230f1.tar.bz2
ag-ops-aa3b462be2ea1d91bf05c89ed5157569fd7230f1.zip
sys-auth/ykpers asciidoc --> asciidoctor
-rw-r--r--sys-auth/ykpers/Manifest5
-rw-r--r--sys-auth/ykpers/metadata.xml18
-rw-r--r--sys-auth/ykpers/ykpers-1.18.0.ebuild45
-rw-r--r--sys-auth/ykpers/ykpers-1.18.1.ebuild47
4 files changed, 115 insertions, 0 deletions
diff --git a/sys-auth/ykpers/Manifest b/sys-auth/ykpers/Manifest
new file mode 100644
index 0000000..bc2e432
--- /dev/null
+++ b/sys-auth/ykpers/Manifest
@@ -0,0 +1,5 @@
+DIST ykpers-1.18.0.tar.gz 124932 BLAKE2B 48e7045429081c1e577ca560b3a10a4cc380820add40526dbb2a8e0fe347eae79c1dff8335c5363148da55cb374e193230ecb6273b08566ef94959848ceb848e SHA512 d636fcabf94a3fb48841572b7b0f03a12a3b3243b11ed7377654d01c33c7282dc321ee13b13c1ee3f2a49fc5015e326a96ef5bc1594b8592d07c1e5aa0521d20
+DIST ykpers-1.18.1.tar.gz 125397 BLAKE2B 7393373414f9f2f9474408c86b8abba0f2034f5908ab8c14fd1dbf9acab40994b43b19031a58f5e889acaf289869b82bd429199237da173e3fa19154b4424374 SHA512 faf9c98fc41a64ae17e2002cd22e89fa2f51de9941aa6eb10c49aa78fd2e2867a5d47fc91fd91ab8e916117cba08629f3f1b076d91698ac2fee6e43366d948a8
+EBUILD ykpers-1.18.0.ebuild 937 BLAKE2B ea45c65f0927b0a6c810b90c5662505f68f85e78eeb6aa1f0be6a83ffe13c3237d46aef84614da11321cdf02224629a2344413f1f5d8880fd0cbeb9db660cb5a SHA512 8313c2c13adeacf11427cfa6dfd8455f141ac5d992a3bd418731867e3d599a946edb02e0b9cfc319ceef9506c4e6e60ee75b46ce78f8a5f3c0925cab9a9f348c
+EBUILD ykpers-1.18.1.ebuild 981 BLAKE2B af4f36e8d758a125997188c48e16083d3d45cc66334fdc3330dafa175ee552ebbf0a4a88a78c598e6f00b6d12097f7295d874381fcd653c3e0f60d209fe32beb SHA512 b118dd9c1897a434460ca12f3887868c7240eaa5c81035e3f6101300f4519267802aae1f6882e3a24b5a40e669031697635fb87ad8caa1ea35262b93665b0e3f
+MISC metadata.xml 632 BLAKE2B b03dff691e31f6d0ff188f1e10156140f0b9d5a91993be3be01f291e5edb75a0e8776a550ad3a66ac0244c402bbb40aa9e7948307d498d05d5c8d6b9b1997c4a SHA512 1cb1ba38e29077530438a94c0a2c4e6724abc4b8e3f946466d141497495b6f316094c5f6d2313e260b163c979f65a777570de03a7630c2908a085ce5da34580b
diff --git a/sys-auth/ykpers/metadata.xml b/sys-auth/ykpers/metadata.xml
new file mode 100644
index 0000000..46e7a0c
--- /dev/null
+++ b/sys-auth/ykpers/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Yubico/yubikey-personalization</remote-id>
+ <bugs-to>https://github.com/Yubico/yubikey-personalization/issues</bugs-to>
+ </upstream>
+ <use>
+ <flag name="consolekit">
+ Use <pkg>sys-auth/consolekit</pkg> and <pkg>virtual/udev</pkg>
+ to allow access to the YubiKey HID device to the console user.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/sys-auth/ykpers/ykpers-1.18.0.ebuild b/sys-auth/ykpers/ykpers-1.18.0.ebuild
new file mode 100644
index 0000000..71e5a10
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.18.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ dev-ruby/asciidoctor
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+S="${WORKDIR}/yubikey-personalization-${PV}"
+
+DOCS=( doc/. AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use consolekit && udev_dorules *.rules
+}
diff --git a/sys-auth/ykpers/ykpers-1.18.1.ebuild b/sys-auth/ykpers/ykpers-1.18.1.ebuild
new file mode 100644
index 0000000..079b08b
--- /dev/null
+++ b/sys-auth/ykpers/ykpers-1.18.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools udev
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey"
+SRC_URI="https://github.com/Yubico/yubikey-personalization/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/Yubico/yubikey-personalization"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="BSD-2"
+IUSE="static-libs consolekit"
+
+RDEPEND="
+ >=sys-auth/libyubikey-1.6
+ virtual/libusb:1"
+DEPEND="${RDEPEND}
+ dev-ruby/asciidoctor
+ virtual/pkgconfig"
+RDEPEND="${RDEPEND}
+ consolekit? ( sys-auth/consolekit[acl] )"
+
+S="${WORKDIR}/yubikey-personalization-${PV}"
+
+DOCS=( doc/. AUTHORS NEWS README )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use consolekit && udev_dorules *.rules
+
+ find "${D}" -name '*.la' -delete || die
+}