summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-engines/love/love-0.10.2.ebuild')
-rw-r--r--games-engines/love/love-0.10.2.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/games-engines/love/love-0.10.2.ebuild b/games-engines/love/love-0.10.2.ebuild
deleted file mode 100644
index 3ee6c43..0000000
--- a/games-engines/love/love-0.10.2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit games
-
-if [[ ${PV} == 9999* ]]; then
- inherit autotools mercurial
- EHG_REPO_URI="https://bitbucket.org/rude/${PN}"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="https://www.bitbucket.org/rude/${PN}/downloads/${P}-linux-src.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~x86"
-fi
-
-DESCRIPTION="A framework for 2D games in Lua"
-HOMEPAGE="http://love2d.org/"
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE="luajit"
-
-RDEPEND="dev-games/physfs
- !luajit? ( dev-lang/lua[deprecated] )
- luajit? ( dev-lang/luajit:2 )
- media-libs/devil[mng,png,tiff]
- media-libs/freetype
- media-libs/libmodplug
- media-libs/libsdl2[joystick,opengl]
- media-libs/libtheora
- media-libs/libvorbis
- media-libs/openal
- media-sound/mpg123
- virtual/opengl"
-DEPEND="${RDEPEND}
- media-libs/libmng
- media-libs/tiff"
-
-DOCS=( "readme.md" "changes.txt" )
-
-src_prepare() {
- if [[ ${PV} == 9999* ]]; then
- sh platform/unix/gen-makefile || die
- mkdir platform/unix/m4 || die
- eautoreconf
- fi
-}
-
-src_configure() {
- econf --with-lua=$(usev luajit || echo lua)
-}
-
-src_install() {
- default
- if [[ "${SLOT}" != "0" ]]; then
- mv "${ED}${GAMES_BINDIR}"/${PN} \
- "${ED}${GAMES_BINDIR}"/${PN}-${SLOT} || die
- fi
-}