summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/aseprite/files')
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.17-system_libarchive.patch19
-rw-r--r--dev-games/aseprite/files/aseprite-1.2.17-system_libwebp.patch41
2 files changed, 46 insertions, 14 deletions
diff --git a/dev-games/aseprite/files/aseprite-1.2.17-system_libarchive.patch b/dev-games/aseprite/files/aseprite-1.2.17-system_libarchive.patch
index 7cd457b..c032508 100644
--- a/dev-games/aseprite/files/aseprite-1.2.17-system_libarchive.patch
+++ b/dev-games/aseprite/files/aseprite-1.2.17-system_libarchive.patch
@@ -2,15 +2,15 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index dae638be8..dd5d17794 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -64,6 +64,7 @@ option(USE_SHARED_CURL "Use your installed copy of curl" off)
+@@ -60,6 +60,7 @@ option(USE_SHARED_CURL "Use your installed copy of curl" off)
option(USE_SHARED_GIFLIB "Use your installed copy of giflib" off)
option(USE_SHARED_JPEGLIB "Use your installed copy of jpeglib" off)
option(USE_SHARED_ZLIB "Use your installed copy of zlib" off)
+option(USE_SHARED_LIBARCHIVE "Use your installed copy of libarchive" off)
option(USE_SHARED_LIBPNG "Use your installed copy of libpng" off)
- option(USE_SHARED_LIBLOADPNG "Use your installed copy of libloadpng" off)
option(USE_SHARED_TINYXML "Use your installed copy of tinyxml" off)
-@@ -193,6 +194,15 @@ else()
+ option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
+@@ -202,6 +202,15 @@ else()
endif()
include_directories(${ZLIB_INCLUDE_DIRS})
@@ -26,20 +26,11 @@ index dae638be8..dd5d17794 100644
# libpng
if(USE_SHARED_LIBPNG)
find_package(PNG REQUIRED)
-@@ -294,7 +304,7 @@ if(USE_SHARED_CMARK)
- else()
- add_definitions(-DCMARK_STATIC_DEFINE)
- set(CMARK_LIBRARIES libcmark_static)
-- include_directories(${CMAKE_CURRENT_BINARY_DIR}/third_party/cmark)
-+ include_directories(${CMARK_DIR})
- endif()
-
- if(REQUIRE_CURL)
diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
index a9e80d73c..619acac92 100644
--- a/src/app/CMakeLists.txt
+++ b/src/app/CMakeLists.txt
-@@ -82,9 +82,6 @@ if(WITH_WEBP_SUPPORT)
+@@ -91,9 +91,6 @@ if(WITH_WEBP_SUPPORT)
add_definitions(-DASEPRITE_WITH_WEBP_SUPPORT)
endif()
@@ -62,7 +53,7 @@ diff --git a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
index 596ffa2e4..977816439 100644
--- a/third_party/CMakeLists.txt
+++ b/third_party/CMakeLists.txt
-@@ -113,16 +113,18 @@ endif()
+@@ -105,16 +105,18 @@ endif()
add_subdirectory(json11)
# libarchive
diff --git a/dev-games/aseprite/files/aseprite-1.2.17-system_libwebp.patch b/dev-games/aseprite/files/aseprite-1.2.17-system_libwebp.patch
new file mode 100644
index 0000000..8c7e417
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.2.17-system_libwebp.patch
@@ -0,0 +1,41 @@
+diff -uNr a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2020-03-06 18:47:37.000000000 +0100
++++ b/CMakeLists.txt 2020-04-14 09:25:00.270728334 +0200
+@@ -65,6 +65,7 @@
+ option(USE_SHARED_PIXMAN "Use your installed copy of pixman" off)
+ option(USE_SHARED_FREETYPE "Use shared FreeType library" off)
+ option(USE_SHARED_HARFBUZZ "Use shared HarfBuzz library" off)
++option(USE_SHARED_WEBP "Use your installed copy of webp" off)
+ option(ENABLE_ASEPRITE_EXE "Compile main Aseprite executable" on)
+ option(ENABLE_MEMLEAK "Enable memory-leaks detector (only for developers)" off)
+ option(ENABLE_NEWS "Enable the news in Home tab" on)
+@@ -219,9 +220,14 @@
+
+ # libwebp
+ if(WITH_WEBP_SUPPORT)
+- set(WEBP_LIBRARIES webp webpdemux webpmux)
+- set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
+- include_directories(${WEBP_INCLUDE_DIR})
++ if(USE_SHARED_WEBP)
++ find_library(WEBP_LIBRARIES NAMES webp)
++ find_path(WEBP_INCLUDE_DIRS NAMES decode.h PATH_SUFFIXES webp)
++ else()
++ set(WEBP_LIBRARIES webp webpdemux webpmux)
++ set(WEBP_INCLUDE_DIR ${LIBWEBP_DIR}/src)
++ include_directories(${WEBP_INCLUDE_DIR})
++ endif()
+ endif()
+
+ # tinyxml
+diff -uNr a/third_party/CMakeLists.txt b/third_party/CMakeLists.txt
+--- a/third_party/CMakeLists.txt 2019-10-24 01:54:06.000000000 +0200
++++ b/third_party/CMakeLists.txt 2020-04-14 09:22:20.799744576 +0200
+@@ -32,7 +32,7 @@
+ add_subdirectory(giflib)
+ endif()
+
+-if(WITH_WEBP_SUPPORT)
++if(WITH_WEBP_SUPPORT AND NOT USE_SHARED_WEBP)
+ # Enable img2webp so "webpmux" library is built
+ set(WEBP_BUILD_IMG2WEBP ON CACHE BOOL "Build the img2webp animation tool.")
+ add_subdirectory(libwebp)