summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/papirus-icon-theme/papirus-icon-theme-20230601.ebuild')
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20230601.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20230601.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20230601.ebuild
new file mode 100644
index 000000000000..0279bb437c4d
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20230601.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit xdg
+
+DESCRIPTION="Free and open source SVG icon theme"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r Papirus{,-Dark,-Light}
+
+ # Install variants designed for elementary OS and Pantheon Desktop only
+ doins -r ePapirus{,-Dark}
+}