summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/kitty/files/kitty-0.14.4-flags.patch')
-rw-r--r--x11-terms/kitty/files/kitty-0.14.4-flags.patch49
1 files changed, 0 insertions, 49 deletions
diff --git a/x11-terms/kitty/files/kitty-0.14.4-flags.patch b/x11-terms/kitty/files/kitty-0.14.4-flags.patch
deleted file mode 100644
index 5bf301efd5a8..000000000000
--- a/x11-terms/kitty/files/kitty-0.14.4-flags.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-Respect user CFLAGS.
-
---- kitty-0.14.4/setup.py
-+++ kitty-0.14.4/setup.py
-@@ -202,7 +202,7 @@
- df = '-g3'
- if ccver >= (5, 0):
- df += ' -Og'
-- optimize = df if debug or sanitize else '-O3'
-+ optimize = ''
- sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
- cppflags = os.environ.get(
- 'OVERRIDE_CPPFLAGS', '-D{}DEBUG'.format('' if debug else 'N'),
-@@ -213,7 +213,7 @@
- cflags = os.environ.get(
- 'OVERRIDE_CFLAGS', (
- '-Wextra -Wno-missing-field-initializers -Wall -Wstrict-prototypes -std=c11'
-- ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden'
-+ ' -pedantic-errors {} {} -fwrapv {} {} {} -fvisibility=hidden'
- ).format(
- optimize,
- ' '.join(sanitize_args),
-@@ -227,7 +227,7 @@
- )
- ldflags = os.environ.get(
- 'OVERRIDE_LDFLAGS',
-- '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
-+ '-Wall ' + ' '.join(sanitize_args)
- )
- ldflags = shlex.split(ldflags)
- ldflags.append('-shared')
-@@ -608,7 +608,7 @@
-
-
- def build_launcher(args, launcher_dir='.', bundle_type='source'):
-- cflags = '-Wall -Werror -fpie'.split()
-+ cflags = '-Wall -fpie'.split()
- cppflags = []
- libs = []
- if args.profile or args.sanitize:
-@@ -620,8 +620,6 @@
- cflags.append('-g')
- if args.profile:
- libs.append('-lprofiler')
-- else:
-- cflags.append('-O3')
- if bundle_type.endswith('-freeze'):
- cppflags.append('-DFOR_BUNDLE')
- cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))