summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/asclock/asclock-2.0.12-r2.ebuild (renamed from x11-plugins/asclock/asclock-2.0.12-r1.ebuild)15
1 files changed, 9 insertions, 6 deletions
diff --git a/x11-plugins/asclock/asclock-2.0.12-r1.ebuild b/x11-plugins/asclock/asclock-2.0.12-r2.ebuild
index eb6bcd3414b2..e7b14ca2e97a 100644
--- a/x11-plugins/asclock/asclock-2.0.12-r1.ebuild
+++ b/x11-plugins/asclock/asclock-2.0.12-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
+EAPI=6
+
inherit eutils toolchain-funcs
IUSE=""
@@ -17,8 +18,10 @@ RDEPEND="${DEPEND}
x11-proto/xextproto
x11-proto/xproto"
+PATCHES=( "${FILESDIR}"/${PN}-gcc41.patch )
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-gcc41.patch
+ default
ln -s themes/classic default_theme
}
@@ -58,7 +61,7 @@ src_install() {
insinto ${themesdir}
doins -r themes/*
dodoc README README.THEMES TODO
- cd "${D}"/${themesdir}
- rm -f Freeamp/Makefile{,.*}
- ln -s classic default_theme
+ cd "${D}"/${themesdir} || die
+ rm -f Freeamp/Makefile{,.*} || die
+ ln -s classic default_theme || die
}