summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmMoonClock')
-rw-r--r--x11-plugins/wmMoonClock/Manifest1
-rw-r--r--x11-plugins/wmMoonClock/files/wmMoonClock-1.27-implicit.patch9
-rw-r--r--x11-plugins/wmMoonClock/files/wmMoonClock-1.27-makefile.patch36
-rw-r--r--x11-plugins/wmMoonClock/metadata.xml13
-rw-r--r--x11-plugins/wmMoonClock/wmMoonClock-1.27-r1.ebuild39
5 files changed, 98 insertions, 0 deletions
diff --git a/x11-plugins/wmMoonClock/Manifest b/x11-plugins/wmMoonClock/Manifest
new file mode 100644
index 000000000000..dc80d32fee1f
--- /dev/null
+++ b/x11-plugins/wmMoonClock/Manifest
@@ -0,0 +1 @@
+DIST wmMoonClock-1.27.tar.gz 155197 SHA256 439d330a30ee1cb084e0512e894f5e1a2e9869745a2274fbd9a56832c1527c77
diff --git a/x11-plugins/wmMoonClock/files/wmMoonClock-1.27-implicit.patch b/x11-plugins/wmMoonClock/files/wmMoonClock-1.27-implicit.patch
new file mode 100644
index 000000000000..22ac78bd141a
--- /dev/null
+++ b/x11-plugins/wmMoonClock/files/wmMoonClock-1.27-implicit.patch
@@ -0,0 +1,9 @@
+diff -aur wmMoonClock-1.27-orig/Src/CalcEphem.h wmMoonClock-1.27/Src/CalcEphem.h
+--- wmMoonClock-1.27-orig/Src/CalcEphem.h 1998-12-31 13:25:16.000000000 -0500
++++ wmMoonClock-1.27/Src/CalcEphem.h 2008-06-26 10:29:30.000000000 -0400
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <string.h>
+ #include <math.h>
+
+ #define DegPerRad 57.29577951308232087680
diff --git a/x11-plugins/wmMoonClock/files/wmMoonClock-1.27-makefile.patch b/x11-plugins/wmMoonClock/files/wmMoonClock-1.27-makefile.patch
new file mode 100644
index 000000000000..f140a7dbbcb7
--- /dev/null
+++ b/x11-plugins/wmMoonClock/files/wmMoonClock-1.27-makefile.patch
@@ -0,0 +1,36 @@
+--- Makefile.orig 1999-03-23 03:20:32.000000000 +0100
++++ Makefile 2008-01-27 23:44:28.000000000 +0100
+@@ -1,8 +1,9 @@
+-CC = gcc
+-CFLAGS = -O2
+-INCDIR = -I/usr/X11R6/include/X11
+-DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++CC ?= gcc
++CFLAGS +=
++INCDIR = -I/usr/include/X11
++PREFIX ?= /usr
++LIBDIR ?= /usr/lib
++MANDIR = $(PREFIX)/share/man
+
+ # for Linux
+ LIBS = -lXpm -lX11 -lXext
+@@ -22,7 +23,7 @@
+
+ wmMoonClock.o: wmMoonClock_master.xpm wmMoonClock_mask.xbm CalcEphem.h
+ wmMoonClock: $(OBJS)
+- $(CC) $(COPTS) $(SYSTEM) -lm -o wmMoonClock $^ $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(COPTS) $(SYSTEM) -o wmMoonClock $^ $(INCDIR) -L$(LIBDIR) $(LDFLAGS) $(LIBS) -lm
+
+ clean:
+ for i in $(OBJS) ; do \
+@@ -31,6 +32,7 @@
+ rm -f wmMoonClock
+
+ install:: wmMoonClock
+- install -s -m 0755 wmMoonClock $(DESTDIR)/bin
+- install -m 0644 wmMoonClock.1 $(DESTDIR)/man/man1
++ install -d $(DESTDIR)$(PREFIX)/bin $(DESTDIR)$(MANDIR)/man1
++ install -m 0755 wmMoonClock $(DESTDIR)$(PREFIX)/bin
++ install -m 0644 wmMoonClock.1 $(DESTDIR)$(MANDIR)/man1
+
diff --git a/x11-plugins/wmMoonClock/metadata.xml b/x11-plugins/wmMoonClock/metadata.xml
new file mode 100644
index 000000000000..b883de84dbb9
--- /dev/null
+++ b/x11-plugins/wmMoonClock/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <longdescription>
+ wmMoonClock displays phases and ephemeris of the Moon. Clicking on the App
+ cycles the user through several `pages' of ephemeris information. Included are
+ age, fraction of current lunar cycle, the % illumination, whether its currently
+ visible or not, the rise/set times for yesterday, today and tomorrow, the
+ `horizon coordinates", and the "ecliptic coordinates". wmMoonClock supports
+ 8-bit and high-color displays.
+ </longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmMoonClock/wmMoonClock-1.27-r1.ebuild b/x11-plugins/wmMoonClock/wmMoonClock-1.27-r1.ebuild
new file mode 100644
index 000000000000..3c13e5b8c838
--- /dev/null
+++ b/x11-plugins/wmMoonClock/wmMoonClock-1.27-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="dockapp that shows lunar ephemeris to a high accuracy"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/21/${P}.tar.gz"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/14"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ppc sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${P}/Src"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ epatch "${FILESDIR}"/${P}-implicit.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "parallel make failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ../BUGS
+}