summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsensors')
-rw-r--r--x11-misc/xsensors/files/xsensors-0.70-gtk220.patch4
-rw-r--r--x11-misc/xsensors/xsensors-0.70-r1.ebuild36
2 files changed, 38 insertions, 2 deletions
diff --git a/x11-misc/xsensors/files/xsensors-0.70-gtk220.patch b/x11-misc/xsensors/files/xsensors-0.70-gtk220.patch
index 0aaf2c8026bf..2f36cfba514c 100644
--- a/x11-misc/xsensors/files/xsensors-0.70-gtk220.patch
+++ b/x11-misc/xsensors/files/xsensors-0.70-gtk220.patch
@@ -1,5 +1,5 @@
---- src/gui.c
-+++ src/gui.c
+--- a/src/gui.c
++++ b/src/gui.c
@@ -84,7 +84,7 @@
while ( *digit ) {
get_pm_location( *digit, &x, &y, &w );
diff --git a/x11-misc/xsensors/xsensors-0.70-r1.ebuild b/x11-misc/xsensors/xsensors-0.70-r1.ebuild
new file mode 100644
index 000000000000..f66b915a5049
--- /dev/null
+++ b/x11-misc/xsensors/xsensors-0.70-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A hardware health information viewer, interface to lm-sensors"
+HOMEPAGE="http://www.linuxhardware.org/xsensors/"
+SRC_URI="http://www.linuxhardware.org/xsensors/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=sys-apps/lm_sensors-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gtk220.patch )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ -e 's:-Werror:-Wall:' \
+ src/Makefile.am configure.in || die
+
+ mv configure.{in,ac} || die #426262
+
+ eautoreconf
+}