summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/wininfo/wininfo-0.7.ebuild')
-rw-r--r--x11-misc/wininfo/wininfo-0.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/wininfo/wininfo-0.7.ebuild b/x11-misc/wininfo/wininfo-0.7.ebuild
new file mode 100644
index 000000000000..b990bc66abbf
--- /dev/null
+++ b/x11-misc/wininfo/wininfo-0.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="An X app that follows your pointer providing information about the windows below"
+HOMEPAGE="http://freedesktop.org/Software/wininfo"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXres
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop-entry.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}