summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/rednotebook')
-rw-r--r--x11-misc/rednotebook/Manifest2
-rw-r--r--x11-misc/rednotebook/files/rednotebook-1.2.0-disable-spell.patch17
-rw-r--r--x11-misc/rednotebook/files/rednotebook-1.6.5-disable-spell.patch17
-rw-r--r--x11-misc/rednotebook/metadata.xml18
-rw-r--r--x11-misc/rednotebook/rednotebook-1.4.0.ebuild46
-rw-r--r--x11-misc/rednotebook/rednotebook-1.8.0.ebuild30
6 files changed, 130 insertions, 0 deletions
diff --git a/x11-misc/rednotebook/Manifest b/x11-misc/rednotebook/Manifest
new file mode 100644
index 000000000000..69a2f0de84bc
--- /dev/null
+++ b/x11-misc/rednotebook/Manifest
@@ -0,0 +1,2 @@
+DIST rednotebook-1.4.0.tar.gz 449654 SHA256 ca68e39e5fa3182eef334d160ff9b389aad39c22abfe7caa560a5ff92eb038b0 SHA512 04ba842b4b2050de15ea080af509a95c573664f2947ca7acbd51c0987185dfcff18b65d53db1ca61dba586f6a9f3193c20782c225229268c647c2b5716fc318b WHIRLPOOL a5fcebfb249f38c1a2924b4f8cdfb7b4f691fce20d25a068424eca04f41c512ef4a16e197808a0a384784e182f9f0bc52dd2590ee162170748b9dbbe4a839470
+DIST rednotebook-1.8.0.tar.gz 500452 SHA256 63beacfdc738a9640bcc7b35ae28c18c7310d9f6fc9e9a6afafcc4d37f628213 SHA512 4d165bff34013fb5583a98a77b96d149eea62b67f0f0177778f0f97e9f65beb2d298c6b08fb5f6f8b18fa951b18f19478b52b239ab1af397ee3850d24eb8a9cf WHIRLPOOL 684bf11e2552b0a5030bbfa58a27a2fa6825ecc8657c3954117096e76b28dc8fb18f261d199cf712b67d3f7439b65e15231c984da9e8d04a1e0bc4505c40ce98
diff --git a/x11-misc/rednotebook/files/rednotebook-1.2.0-disable-spell.patch b/x11-misc/rednotebook/files/rednotebook-1.2.0-disable-spell.patch
new file mode 100644
index 000000000000..ac4261b99018
--- /dev/null
+++ b/x11-misc/rednotebook/files/rednotebook-1.2.0-disable-spell.patch
@@ -0,0 +1,17 @@
+Index: rednotebook-1.2.0/rednotebook/gui/editor.py
+===================================================================
+--- rednotebook-1.2.0.orig/rednotebook/gui/editor.py
++++ rednotebook-1.2.0/rednotebook/gui/editor.py
+@@ -25,11 +25,7 @@ import gtk
+ import gobject
+ import pango
+
+-# try to import gtkspell
+-try:
+- import gtkspell
+-except ImportError:
+- gtkspell = None
++gtkspell = None
+
+ from rednotebook.gui import t2t_highlight
+ from rednotebook import undo
diff --git a/x11-misc/rednotebook/files/rednotebook-1.6.5-disable-spell.patch b/x11-misc/rednotebook/files/rednotebook-1.6.5-disable-spell.patch
new file mode 100644
index 000000000000..0648c425249f
--- /dev/null
+++ b/x11-misc/rednotebook/files/rednotebook-1.6.5-disable-spell.patch
@@ -0,0 +1,17 @@
+Index: rednotebook-1.6.5/rednotebook/gui/editor.py
+===================================================================
+--- rednotebook-1.6.5.orig/rednotebook/gui/editor.py
++++ rednotebook-1.6.5/rednotebook/gui/editor.py
+@@ -25,12 +25,7 @@ import gtk
+ import gobject
+ import pango
+
+-# Try to import gtkspell
+ gtkspell = None
+-try:
+- import gtkspell
+-except ImportError:
+- pass
+
+ from rednotebook.gui import t2t_highlight
+ from rednotebook import undo
diff --git a/x11-misc/rednotebook/metadata.xml b/x11-misc/rednotebook/metadata.xml
new file mode 100644
index 000000000000..0b1b70bb42e0
--- /dev/null
+++ b/x11-misc/rednotebook/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <use>
+ <flag name="libyaml">enable libyaml support</flag>
+ <flag name="spell">enable gtk-spell support</flag>
+ </use>
+ <maintainer>
+ <email>mattm@gentoo.org</email>
+ <name>Matthew Marlowe</name>
+ </maintainer>
+ <longdescription lang="en">
+A graphical journal with calendar, templates, tags, keyword searching, and export functionality.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">rednotebook</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/rednotebook/rednotebook-1.4.0.ebuild b/x11-misc/rednotebook/rednotebook-1.4.0.ebuild
new file mode 100644
index 000000000000..75cf524d6384
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+LANGS="ar ast be bg bs ca cs cy da de el en_GB eo es eu fi fo fr gl he hr hu hy
+id it ja ka kk ko lt mn ms nb nds nl nn oc pl pt pt_BR ro ru si sk sr sv ta te
+tl tr ug uk uz vi wa zh_CN zh_HK zh_TW"
+
+inherit python eutils distutils
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="libyaml spell"
+for x in ${LANGS}; do
+ IUSE="${IUSE} linguas_${x}"
+done
+
+RDEPEND="dev-python/pyyaml[libyaml?]
+ >=dev-python/pygtk-2.13
+ dev-python/pywebkitgtk
+ spell? ( dev-python/gtkspell-python )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ ! use spell && epatch "${FILESDIR}/${PN}-1.2.0-disable-spell.patch"
+ # rename wae file. I think this should be wa.po instead of wae.po
+ mv po/wae.po po/wa.po || die
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ rm po/${x}.po || die
+ fi
+ done
+ distutils_src_prepare
+}
diff --git a/x11-misc/rednotebook/rednotebook-1.8.0.ebuild b/x11-misc/rednotebook/rednotebook-1.8.0.ebuild
new file mode 100644
index 000000000000..d862a3c0b542
--- /dev/null
+++ b/x11-misc/rednotebook/rednotebook-1.8.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A graphical journal with calendar, templates, tags, keyword searching, and export functionality"
+HOMEPAGE="http://rednotebook.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="libyaml spell"
+
+RDEPEND="
+ dev-python/pyyaml[libyaml?,${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.13[${PYTHON_USEDEP}]
+ >=dev-python/pywebkitgtk-1.1.5[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ spell? ( dev-python/gtkspell-python[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ ! use spell && epatch "${FILESDIR}/${PN}-1.6.5-disable-spell.patch"
+}