summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/qterm/files/qterm-0.5.12-qtbindir.patch')
-rw-r--r--x11-misc/qterm/files/qterm-0.5.12-qtbindir.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/x11-misc/qterm/files/qterm-0.5.12-qtbindir.patch b/x11-misc/qterm/files/qterm-0.5.12-qtbindir.patch
new file mode 100644
index 000000000000..f23af67c2013
--- /dev/null
+++ b/x11-misc/qterm/files/qterm-0.5.12-qtbindir.patch
@@ -0,0 +1,16 @@
+Ensure that qcollectiongenerator is called from the correct directory.
+
+Even though QT_BINARY_DIR is specified, cmake will try PATH first.
+
+Gentoo-bug: 544108
+
+--- a/src/doc/CMakeLists.txt
++++ b/src/doc/CMakeLists.txt
+@@ -9,6 +9,7 @@
+ FIND_PROGRAM(QT_HELP_COLLECTION_GENERATOR
+ qcollectiongenerator
+ PATHS "${QT_BINARY_DIR}"
++ NO_DEFAULT_PATH
+ DOC "qcollectiongenerator used to compile Qt help collection project files")
+
+ ADD_CUSTOM_COMMAND(