summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/i3lock/i3lock-2.6.ebuild')
-rw-r--r--x11-misc/i3lock/i3lock-2.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/i3lock/i3lock-2.6.ebuild b/x11-misc/i3lock/i3lock-2.6.ebuild
new file mode 100644
index 000000000000..11787237b70e
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="http://i3wm.org/i3lock/"
+SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/pam
+ dev-libs/libev
+ >=x11-libs/libxkbcommon-0.3.1[X]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+ x11-libs/cairo[xcb]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+DOCS=( CHANGELOG README )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i -e 's:login:system-auth:' ${PN}.pam || die
+ epatch_user
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}