summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/dwb/dwb-2014.03.07-r1.ebuild')
-rw-r--r--www-client/dwb/dwb-2014.03.07-r1.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/www-client/dwb/dwb-2014.03.07-r1.ebuild b/www-client/dwb/dwb-2014.03.07-r1.ebuild
deleted file mode 100644
index 3c9fd5409523..000000000000
--- a/www-client/dwb/dwb-2014.03.07-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit toolchain-funcs eutils
-
-DESCRIPTION="Dynamic web browser based on WebKit and GTK+"
-HOMEPAGE="https://portix.bitbucket.org/dwb/"
-SRC_URI="https://www.bitbucket.org/portix/dwb/downloads/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="examples gtk3"
-
-RDEPEND=">=net-libs/libsoup-2.32:2.4
- dev-libs/json-c
- net-libs/gnutls
- !gtk3? (
- >=net-libs/webkit-gtk-1.8.0:2
- x11-libs/gtk+:2
- )
- gtk3? (
- >=net-libs/webkit-gtk-1.8.0:3
- x11-libs/gtk+:3
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
-}
-
-src_compile() {
- local myconf
- use gtk3 && myconf+=" GTK=3"
-
- emake CC="$(tc-getCC)" ${myconf}
-}
-
-src_install() {
- default
-
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}