summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/dillo-3.1.1.ebuild4
-rw-r--r--www-client/dillo/dillo-9999.ebuild4
-rw-r--r--www-client/dillo/files/dillo-3.1.1-remove-which.patch42
3 files changed, 48 insertions, 2 deletions
diff --git a/www-client/dillo/dillo-3.1.1.ebuild b/www-client/dillo/dillo-3.1.1.ebuild
index 1c2a6fcd34a9..9ad9d9bdc955 100644
--- a/www-client/dillo/dillo-3.1.1.ebuild
+++ b/www-client/dillo/dillo-3.1.1.ebuild
@@ -34,15 +34,17 @@ RDEPEND="
openssl? ( dev-libs/openssl:= )
)
test? (
+ media-fonts/dejavu
media-gfx/imagemagick[X]
x11-apps/xwd
x11-apps/xwininfo
)
-
"
+
DEPEND="
${RDEPEND}
"
+
BDEPEND="
doc? (
app-text/doxygen[dot]
diff --git a/www-client/dillo/dillo-9999.ebuild b/www-client/dillo/dillo-9999.ebuild
index 1c2a6fcd34a9..9ad9d9bdc955 100644
--- a/www-client/dillo/dillo-9999.ebuild
+++ b/www-client/dillo/dillo-9999.ebuild
@@ -34,15 +34,17 @@ RDEPEND="
openssl? ( dev-libs/openssl:= )
)
test? (
+ media-fonts/dejavu
media-gfx/imagemagick[X]
x11-apps/xwd
x11-apps/xwininfo
)
-
"
+
DEPEND="
${RDEPEND}
"
+
BDEPEND="
doc? (
app-text/doxygen[dot]
diff --git a/www-client/dillo/files/dillo-3.1.1-remove-which.patch b/www-client/dillo/files/dillo-3.1.1-remove-which.patch
new file mode 100644
index 000000000000..c79f522cbb2a
--- /dev/null
+++ b/www-client/dillo/files/dillo-3.1.1-remove-which.patch
@@ -0,0 +1,42 @@
+https://github.com/dillo-browser/dillo/commit/9880c1ba603a6080b2493c7c399ae36d656a9834.patch
+From: meat <meat@device.domain>
+Date: Thu, 3 Oct 2024 12:48:31 +0200
+Subject: [PATCH] Use command -v instead of which
+
+--- a/autogen.sh
++++ b/autogen.sh
+@@ -15,7 +15,7 @@
+ # Required binaries check
+ #
+ check_bin_file(){
+- which $1 > /dev/null 2>&1
++ command -v $1 > /dev/null 2>&1
+ if [ $? = 0 ]; then
+ return 0
+ else
+--- a/configure.ac
++++ b/configure.ac
+@@ -297,18 +297,18 @@ if test "x$enable_png" = "xyes"; then
+
+ dnl Check if the user hasn't set the variable $PNG_CONFIG
+ if test -z "$PNG_CONFIG"; then
+- PNG_CONFIG=`which libpng16-config`
++ PNG_CONFIG=`command -v libpng16-config`
+ if test -z "$PNG_CONFIG"; then
+- PNG_CONFIG=`which libpng14-config`
++ PNG_CONFIG=`command -v libpng14-config`
+ fi
+ if test -z "$PNG_CONFIG"; then
+- PNG_CONFIG=`which libpng12-config`
++ PNG_CONFIG=`command -v libpng12-config`
+ fi
+ if test -z "$PNG_CONFIG"; then
+- PNG_CONFIG=`which libpng-config`
++ PNG_CONFIG=`command -v libpng-config`
+ fi
+ if test -z "$PNG_CONFIG"; then
+- PNG_CONFIG=`which libpng10-config`
++ PNG_CONFIG=`command -v libpng10-config`
+ fi
+ fi
+