summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild')
-rw-r--r--www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild b/www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild
index 0675641f3211..feb026881ffe 100644
--- a/www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild
+++ b/www-apps/bugzilla/bugzilla-5.0.3-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -79,6 +79,10 @@ RDEPEND="
want_apache modperl
need_httpd_cgi
+PATCHES=(
+ "${FILESDIR}/${PN}"-5.0.3-leftbrace.patch
+)
+
pkg_setup() {
depend.apache_pkg_setup modperl
webapp_pkg_setup
@@ -90,11 +94,12 @@ src_prepare() {
# Remove bundled perl modules
rm -r lib/ || die
- eapply_user
+
+ default
}
src_test() {
- perl runtests.pl || die
+ perl -I. runtests.pl || die
}
src_install () {