summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/criu/files/criu-1.5-automagic-libbsd.patch')
-rw-r--r--sys-process/criu/files/criu-1.5-automagic-libbsd.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-process/criu/files/criu-1.5-automagic-libbsd.patch b/sys-process/criu/files/criu-1.5-automagic-libbsd.patch
new file mode 100644
index 000000000000..8f5e4b4e02d0
--- /dev/null
+++ b/sys-process/criu/files/criu-1.5-automagic-libbsd.patch
@@ -0,0 +1,29 @@
+Control libbsd dependency via SETPROCTITLE definition.
+
+--- criu-1.5/Makefile.config
++++ criu-1.5/Makefile.config
+@@ -3,10 +3,12 @@
+
+ CONFIG := include/config.h
+
++ifeq ($(SETPROCTITLE),yes)
+ ifeq ($(call try-cc,$(LIBBSD_DEV_TEST),-lbsd),y)
+ LIBS += -lbsd
+ DEFINES += -DCONFIG_HAS_LIBBSD
+ endif
++endif
+
+ $(CONFIG): scripts/utilities.mak scripts/feature-tests.mak include/config-base.h
+ $(E) " GEN " $@
+@@ -33,9 +35,11 @@
+ ifeq ($(VDSO),y)
+ $(Q) @echo '#define CONFIG_VDSO' >> $@
+ endif
++ifeq ($(SETPROCTITLE),yes)
+ ifeq ($(call try-cc,$(SETPROCTITLE_INIT_TEST),-lbsd),y)
+ $(Q) @echo '#define CONFIG_HAS_SETPROCTITLE_INIT' >> $@
+ endif
++endif
+ $(Q) @echo '#endif /* __CR_CONFIG_H__ */' >> $@
+
+ config: $(CONFIG)