summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libblockdev/libblockdev-2.18-r1.ebuild')
-rw-r--r--sys-libs/libblockdev/libblockdev-2.18-r1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/sys-libs/libblockdev/libblockdev-2.18-r1.ebuild b/sys-libs/libblockdev/libblockdev-2.18-r1.ebuild
index eb79e1e1cb49..dbb703c07001 100644
--- a/sys-libs/libblockdev/libblockdev-2.18-r1.ebuild
+++ b/sys-libs/libblockdev/libblockdev-2.18-r1.ebuild
@@ -78,9 +78,18 @@ src_configure() {
$(use_with lvm lvm)
$(use_with lvm lvm-dbus)
$(use_with kbd)
- $(use_with python_single_target_python2_7 python2)
- $(use_with !python_single_target_python2_7 python3)
$(use_with vdo)
)
+ if python_is_python3 ; then
+ myeconfargs+=(
+ --without-python2
+ --with-python3
+ )
+ else
+ myeconfargs+=(
+ --with-python2
+ --without-python3
+ )
+ fi
econf "${myeconfargs[@]}"
}