summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bashmount/Manifest1
-rw-r--r--sys-fs/bashmount/bashmount-4.3.2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-fs/bashmount/Manifest b/sys-fs/bashmount/Manifest
index a0dd9e8934c7..c07ee2b90daf 100644
--- a/sys-fs/bashmount/Manifest
+++ b/sys-fs/bashmount/Manifest
@@ -1 +1,2 @@
DIST bashmount-3.2.0.tar.gz 18152 BLAKE2B 61ced33a9d912d1bb9ad7ba4f9331830523ad0a35aa643ca71aa30618b0d94234d74823c6170e4047c9517aa07d1b70a59b780e6950f7888028e0143867d5866 SHA512 9fd287f67ecb61c9b72d1fc6a5b85b39d48671299585ad456ff3e14cf2304ad540de1462bbf3eafd333ac038cf8a7f2286f5077b896ea88dff570306f7c7d642
+DIST bashmount-4.3.2.tar.gz 47450 BLAKE2B 0dc45580b62aa55872753de17ee50e77e716e87498193c8dab0998f5a70994ad5cc9434c104bc1d6cc77d75d63688afae8be8e0e8ee4344249ded5f1719051c5 SHA512 ac18d76dc27099524f4051299dc5421e1e5811e943df21d64a1405b5cdf6401189d78571596f27c89c0d76ab40874392c0c90756ef5fa9c036f447ac884ee062
diff --git a/sys-fs/bashmount/bashmount-4.3.2.ebuild b/sys-fs/bashmount/bashmount-4.3.2.ebuild
new file mode 100644
index 000000000000..7c516f25f479
--- /dev/null
+++ b/sys-fs/bashmount/bashmount-4.3.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Bash script that uses udisks to mount removable devices without GUI"
+HOMEPAGE="https://github.com/jamielinux/bashmount"
+SRC_URI="https://github.com/jamielinux/bashmount/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# sys-apps/util-linux -> lsblk
+RDEPEND="
+ app-shells/bash:=
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-fs/udisks:2
+ virtual/eject"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ insinto /etc
+ doins ${PN}.conf
+ doman ${PN}.1
+ dodoc NEWS
+}