summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/llvm/llvm-3.5.2-r100.ebuild')
-rw-r--r--sys-devel/llvm/llvm-3.5.2-r100.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/sys-devel/llvm/llvm-3.5.2-r100.ebuild b/sys-devel/llvm/llvm-3.5.2-r100.ebuild
index f956d83cf502..07457902436e 100644
--- a/sys-devel/llvm/llvm-3.5.2-r100.ebuild
+++ b/sys-devel/llvm/llvm-3.5.2-r100.ebuild
@@ -12,7 +12,8 @@ HOMEPAGE="http://llvm.org/"
SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
clang? ( http://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
http://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz )
- https://dev.gentoo.org/~voyageur/distfiles/${PN}-3.5.0-manpages.tar.bz2"
+ https://dev.gentoo.org/~voyageur/distfiles/${PN}-3.5.0-manpages.tar.bz2
+ https://dev.gentoo.org/~mgorny/dist/llvm/${P}-patchset.tar.gz"
# Additional licenses:
# 1. OpenBSD regex: Henry Spencer's license ('rc' in Gentoo) + BSD.
@@ -111,17 +112,17 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/3.6.2/nodoctargz.patch
- epatch "${FILESDIR}"/3.6.2/gcc-4.9.patch
- epatch "${FILESDIR}"/3.5.2/gentoo-install.patch
- epatch "${FILESDIR}"/3.5.2/gcc-5.1.patch
+ epatch "${WORKDIR}/${P}-patchset"/nodoctargz.patch
+ epatch "${WORKDIR}/${P}-patchset"/gcc-4.9.patch
+ epatch "${WORKDIR}/${P}-patchset"/gentoo-install.patch
+ epatch "${WORKDIR}/${P}-patchset"/gcc-5.1.patch
if use clang; then
# Automatically select active system GCC's libraries, bugs #406163 and #417913
- epatch "${FILESDIR}"/3.8.1/clang/gentoo-runtime-gcc-detection-v3.patch
+ epatch "${WORKDIR}/${P}-patchset"/clang/gentoo-runtime-gcc-detection-v3.patch
- epatch "${FILESDIR}"/3.5.2/clang/gentoo-install.patch
- epatch "${FILESDIR}"/3.9.1/clang/darwin_prefix-include-paths.patch
+ epatch "${WORKDIR}/${P}-patchset"/clang/gentoo-install.patch
+ epatch "${WORKDIR}/${P}-patchset"/clang/darwin_prefix-include-paths.patch
eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
fi