summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/usbutils/usbutils-013.ebuild')
-rw-r--r--sys-apps/usbutils/usbutils-013.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/sys-apps/usbutils/usbutils-013.ebuild b/sys-apps/usbutils/usbutils-013.ebuild
deleted file mode 100644
index 4b99cf62766f..000000000000
--- a/sys-apps/usbutils/usbutils-013.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit autotools python-single-r1
-
-DESCRIPTION="USB enumeration utilities"
-HOMEPAGE="https://www.kernel.org/pub/linux/utils/usb/usbutils/
- https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usbutils.git/"
-SRC_URI="https://www.kernel.org/pub/linux/utils/usb/${PN}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="virtual/libusb:1=
- virtual/libudev:="
-BDEPEND="
- app-arch/xz-utils
- virtual/pkgconfig"
-RDEPEND="${DEPEND}
- sys-apps/hwids
- python? ( ${PYTHON_DEPS} )"
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_prepare() {
- default
- eautoreconf
- use python && python_fix_shebang lsusb.py.in
-}
-
-src_configure() {
- local myeconfargs=(
- --datarootdir="${EPREFIX}/usr/share"
- --datadir="${EPREFIX}/usr/share/misc"
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- newdoc usbhid-dump/NEWS NEWS.usbhid-dump
-
- use python || rm -f "${ED}"/usr/bin/lsusb.py
-}