summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pick')
-rw-r--r--sys-apps/pick/files/pick-1.8.0-tinfo.patch24
-rw-r--r--sys-apps/pick/pick-1.8.0.ebuild10
2 files changed, 31 insertions, 3 deletions
diff --git a/sys-apps/pick/files/pick-1.8.0-tinfo.patch b/sys-apps/pick/files/pick-1.8.0-tinfo.patch
new file mode 100644
index 000000000000..fec89fb90d4b
--- /dev/null
+++ b/sys-apps/pick/files/pick-1.8.0-tinfo.patch
@@ -0,0 +1,24 @@
+Use pkg-config to determine ncurses libs and cflags to use. Fixes when building
+against ncurses with libtinfo split out.
+
+--- pick-1.8.0/configure.ac
++++ pick-1.8.0/configure.ac
+@@ -5,13 +5,10 @@
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+ AC_CHECK_FUNCS([pledge reallocarray strtonum])
+-AC_SEARCH_LIBS([setupterm], [curses], [],
+- [
+- AC_SEARCH_LIBS([setupterm], [ncursesw],
+- [AC_DEFINE([HAVE_NCURSESW_H], [1], [Define if ncursesw is available])],
+- [AC_MSG_ERROR([unable to find setupterm function])]
+- )
+- ]
+-)
++PKG_CHECK_MODULES([NCURSES], [ncursesw],
++ [AC_DEFINE([HAVE_NCURSESW_H], [1], [Define if ncursesw is available])],
++ [PKG_CHECK_MODULES([NCURSES], [ncurses])])
++CFLAGS="$CFLAGS $NCURSES_CFLAGS"
++LIBS="$LIBS $NCURSES_LIBS"
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
diff --git a/sys-apps/pick/pick-1.8.0.ebuild b/sys-apps/pick/pick-1.8.0.ebuild
index c1bf032eb811..5354631f4573 100644
--- a/sys-apps/pick/pick-1.8.0.ebuild
+++ b/sys-apps/pick/pick-1.8.0.ebuild
@@ -14,10 +14,14 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="sys-libs/ncurses:0="
-RDEPEND="${DEPEND}"
+RDEPEND="sys-libs/ncurses:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
src_prepare() {
default