summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ethtool')
-rw-r--r--sys-apps/ethtool/ethtool-5.10.ebuild5
-rw-r--r--sys-apps/ethtool/ethtool-5.4.ebuild4
-rw-r--r--sys-apps/ethtool/ethtool-5.8-r1.ebuild5
-rw-r--r--sys-apps/ethtool/ethtool-5.9.ebuild5
4 files changed, 11 insertions, 8 deletions
diff --git a/sys-apps/ethtool/ethtool-5.10.ebuild b/sys-apps/ethtool/ethtool-5.10.ebuild
index 804cce9dde3e..b9870d909410 100644
--- a/sys-apps/ethtool/ethtool-5.10.ebuild
+++ b/sys-apps/ethtool/ethtool-5.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,8 +12,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="+netlink"
-DEPEND="app-arch/xz-utils"
+BDEPEND="app-arch/xz-utils"
RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
src_configure() {
econf $(use_enable netlink)
diff --git a/sys-apps/ethtool/ethtool-5.4.ebuild b/sys-apps/ethtool/ethtool-5.4.ebuild
index 25a67f41d620..159377da21d0 100644
--- a/sys-apps/ethtool/ethtool-5.4.ebuild
+++ b/sys-apps/ethtool/ethtool-5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,4 +11,4 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-DEPEND="app-arch/xz-utils"
+BDEPEND="app-arch/xz-utils"
diff --git a/sys-apps/ethtool/ethtool-5.8-r1.ebuild b/sys-apps/ethtool/ethtool-5.8-r1.ebuild
index 74ba8d2656ba..8e1cf0073e37 100644
--- a/sys-apps/ethtool/ethtool-5.8-r1.ebuild
+++ b/sys-apps/ethtool/ethtool-5.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,8 +12,9 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
IUSE="+netlink"
-DEPEND="app-arch/xz-utils"
+BDEPEND="app-arch/xz-utils"
RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-5.8-avoid_bashisms.patch"
diff --git a/sys-apps/ethtool/ethtool-5.9.ebuild b/sys-apps/ethtool/ethtool-5.9.ebuild
index 804cce9dde3e..b9870d909410 100644
--- a/sys-apps/ethtool/ethtool-5.9.ebuild
+++ b/sys-apps/ethtool/ethtool-5.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,8 +12,9 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="+netlink"
-DEPEND="app-arch/xz-utils"
+BDEPEND="app-arch/xz-utils"
RDEPEND="netlink? ( net-libs/libmnl )"
+DEPEND="${RDEPEND}"
src_configure() {
econf $(use_enable netlink)