summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization')
-rw-r--r--sci-visualization/ggobi/Manifest1
-rw-r--r--sci-visualization/ggobi/ggobi-2.1.12.ebuild59
-rw-r--r--sci-visualization/ggobi/metadata.xml3
-rw-r--r--sci-visualization/gnuplot/Manifest1
-rw-r--r--sci-visualization/gnuplot/gnuplot-5.4.8.ebuild210
-rw-r--r--sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild2
-rw-r--r--sci-visualization/gnuplot/gnuplot-6.0.1.ebuild219
-rw-r--r--sci-visualization/gwyddion/Manifest1
-rw-r--r--sci-visualization/gwyddion/files/gwyddion-2.60-automagic.patch35
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.61-r1.ebuild89
-rw-r--r--sci-visualization/gwyddion/gwyddion-2.62-r2.ebuild89
-rw-r--r--sci-visualization/paraview/Manifest1
-rw-r--r--sci-visualization/paraview/paraview-5.13.0.ebuild238
13 files changed, 303 insertions, 645 deletions
diff --git a/sci-visualization/ggobi/Manifest b/sci-visualization/ggobi/Manifest
index b6808716cc84..a25cf60f5039 100644
--- a/sci-visualization/ggobi/Manifest
+++ b/sci-visualization/ggobi/Manifest
@@ -1 +1,2 @@
+DIST ggobi-2.1.12.tar.gz 1730589 BLAKE2B 11ce66d66fc11ed3b7e7dde20e978348eaf8e8d42f46d99de014cd7efb23109d5e50ad2702fb492cdc4939b2c04bb17ff775918f26467e28eb2a1841117709ab SHA512 f4096bf7acc05cf300f4b67f02d7ee7b942fc21cfa26203440f5fe47600b3bf3a9029b8005d757b32cbe047d6a4ec6bd375cdf6d791fa8e1658918f8655dca1c
DIST ggobi_2.1.11.orig.tar.bz2 2787709 BLAKE2B e4b853f3212abda00150e6a3b3a344638225bdc564c109632c7ca2f9cb8cc41d35af9df1ee153d2ede3bd3191d9219e2bdd6bd6bc9c64f42447dfe17562361f1 SHA512 d34c6569d05d1e680101b62745012940c1e18c1588cd37b89b26b89e9eed9bab8fc53e0585a595b6cb4c9f2bb7d603ca4252cb6a6ba344bbc24e5cc5fd8a6dc1
diff --git a/sci-visualization/ggobi/ggobi-2.1.12.ebuild b/sci-visualization/ggobi/ggobi-2.1.12.ebuild
new file mode 100644
index 000000000000..ec5c7c800e29
--- /dev/null
+++ b/sci-visualization/ggobi/ggobi-2.1.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Visualization program for exploring high-dimensional data"
+HOMEPAGE="http://www.ggobi.org/"
+# source code release is not well published
+#SRC_URI="http://www.ggobi.org/downloads/${P}.tar.bz2"
+SRC_URI="https://github.com/ggobi/ggobi/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc minimal nls"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ media-gfx/graphviz
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.10-desktop.patch
+)
+
+src_prepare() {
+ default
+
+ # need the ${S} for recursivity lookup
+ #AT_M4DIR="${S}"/m4 eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake all ggobirc
+}
+
+src_install() {
+ default
+
+ insinto /etc/xdg/ggobi
+ doins ggobirc
+
+ if ! use doc; then
+ rm "${ED}"/usr/share/doc/${PF}/*.pdf || die
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/sci-visualization/ggobi/metadata.xml b/sci-visualization/ggobi/metadata.xml
index 5958ca61110a..d9ff71b39daf 100644
--- a/sci-visualization/ggobi/metadata.xml
+++ b/sci-visualization/ggobi/metadata.xml
@@ -12,4 +12,7 @@
scatterplot, barchart and parallel coordinates plots. Plots are
interactive and linked with brushing and identification.
</longdescription>
+ <upstream>
+ <remote-id type="github">ggobi/ggobi</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sci-visualization/gnuplot/Manifest b/sci-visualization/gnuplot/Manifest
index f1bb6a6f42f6..6b3f100b9ed2 100644
--- a/sci-visualization/gnuplot/Manifest
+++ b/sci-visualization/gnuplot/Manifest
@@ -1,3 +1,2 @@
DIST gnuplot-5.4.10.tar.gz 5687565 BLAKE2B 879159fb4b581aa334b221632af7268047077cd48d89d1cecb0c6c9e855edd40bddfdaa8222177652d6200f81b97b0b52fe719da0641eea817e086832f07664f SHA512 fe5226a243dad62e8617d820764dc5923e76a51a68c58a666a699110f5b5be0f5e759e0586e923472a59ca6d1b30d1093d7a65e9c1d3a36fcd33a95df36ab89f
-DIST gnuplot-5.4.8.tar.gz 5684061 BLAKE2B bd897b55e267f50e2f5ce8a49a3a033277577cd972c9effaaaedb0bb2e75908ce34997e389edcc4bd0db1dd8a0d937925216ed6ebf4e51d6700bac50d12e6a47 SHA512 3fe0ed783db85d95bdbc13e24ec5dc9bb6b2d85b3571cc87d3c17c94f4463fb6e681376394e0918cf3915f8f53896e6423ce76cb8b6fdbefcd6ec3e1b3b80125
DIST gnuplot-6.0.1.tar.gz 7528936 BLAKE2B d385d4dc8a4af83f121bd062e014d8845078f5aeb84244f4cce7c17b7cf71c5fc66bd7b8623504ab53567b4123fc739506f7d2f8e4f8ad184258a7568f0223a2 SHA512 47e72ac444f35e22a5de111da3333c80846226d87411a3168e45a8433a258e351ad9b6f0ba21d76f2456042b755123a697b685fd2552b4bd9edc5b97fafcbc62
diff --git a/sci-visualization/gnuplot/gnuplot-5.4.8.ebuild b/sci-visualization/gnuplot/gnuplot-5.4.8.ebuild
deleted file mode 100644
index 7d12858f2eb6..000000000000
--- a/sci-visualization/gnuplot/gnuplot-5.4.8.ebuild
+++ /dev/null
@@ -1,210 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1,2,3,4} )
-WX_GTK_VER="3.2-gtk3"
-
-inherit autotools lua-single readme.gentoo-r1 toolchain-funcs wxwidgets
-
-DESCRIPTION="Command-line driven interactive plotting program"
-HOMEPAGE="http://www.gnuplot.info/"
-
-if [[ -z ${PV%%*9999} ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.code.sf.net/p/gnuplot/gnuplot-main"
- EGIT_BRANCH="master"
- MY_P="${PN}"
- EGIT_CHECKOUT_DIR="${WORKDIR}/${MY_P}"
-else
- MY_P="${P/_/.}"
- SRC_URI="https://downloads.sourceforge.net/gnuplot/${MY_P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="gnuplot"
-SLOT="0"
-IUSE="aqua bitmap cairo doc examples +gd ggi latex libcaca libcerf lua qt5 readline regis wxwidgets X"
-REQUIRED_USE="
- doc? ( gd )
- lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- cairo? (
- x11-libs/cairo
- x11-libs/pango )
- gd? ( >=media-libs/gd-2.0.35-r3:2=[png] )
- ggi? ( media-libs/libggi )
- latex? (
- virtual/latex-base
- lua? (
- dev-tex/pgf
- >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
- libcaca? ( media-libs/libcaca )
- lua? ( ${LUA_DEPS} )
- qt5? (
- dev-qt/qtcore:5=
- dev-qt/qtgui:5=
- dev-qt/qtnetwork:5=
- dev-qt/qtprintsupport:5=
- dev-qt/qtsvg:5=
- dev-qt/qtwidgets:5= )
- readline? ( sys-libs/readline:0= )
- libcerf? ( sci-libs/libcerf )
- wxwidgets? (
- x11-libs/wxGTK:${WX_GTK_VER}[X]
- x11-libs/cairo
- x11-libs/pango
- x11-libs/gtk+:3 )
- X? (
- x11-libs/libX11
- x11-libs/libXaw )"
-
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-langgreek
- dev-texlive/texlive-mathscience
- app-text/ghostscript-gpl )
- qt5? ( dev-qt/linguist-tools:5 )"
-
-IDEPEND="latex? ( virtual/latex-base )"
-
-GP_VERSION="${PV%.*}"
-TEXMF="${EPREFIX}/usr/share/texmf-site"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-5.0.6-no-picins.patch
-)
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- default
-
- if [[ ${PV##*.} = 9999 ]]; then
- local dir
- for dir in config demo m4 term tutorial; do
- emake -C "$dir" -f Makefile.am.in Makefile.am
- done
- fi
-
- # Add special version identification as required by provision 2
- # of the gnuplot license
- sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
-
- eautoreconf
-
- # Make sure we don't mix build & host flags.
- sed -i \
- -e 's:@CPPFLAGS@:$(BUILD_CPPFLAGS):' \
- -e 's:@CFLAGS@:$(BUILD_CFLAGS):' \
- -e 's:@LDFLAGS@:$(BUILD_LDFLAGS):' \
- -e 's:@CC@:$(CC_FOR_BUILD):' \
- docs/Makefile.in || die
-}
-
-src_configure() {
- if ! use latex; then
- sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
- fi
-
- use wxwidgets && setup-wxwidgets
-
- tc-export CC CXX #453174
- tc-export_build_env BUILD_CC
- export CC_FOR_BUILD=${BUILD_CC}
-
- econf \
- --with-texdir="${TEXMF}/tex/latex/${PN}" \
- --with-readline=$(usex readline gnu builtin) \
- $(use_with bitmap bitmap-terminals) \
- $(use_with cairo) \
- $(use_with gd) \
- "$(use_with ggi ggi "${EPREFIX}/usr/$(get_libdir)")" \
- "$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
- $(use_with libcerf) \
- $(use_with lua) \
- $(use_with regis) \
- $(use_with X x) \
- --enable-stats \
- $(use_with qt5 qt qt5) \
- $(use_enable wxwidgets) \
- DIST_CONTACT="https://bugs.gentoo.org/" \
- EMACS=no
-}
-
-src_compile() {
- # Prevent access violations, see bug 201871
- export VARTEXFONTS="${T}/fonts"
-
- emake all
-
- if use doc; then
- if use cairo; then
- emake -C docs pdf
- else
- ewarn "Cannot build figures unless cairo is enabled."
- ewarn "Building documentation without figures."
- emake -C docs pdf_nofig
- mv docs/nofigures.pdf docs/gnuplot.pdf || die
- fi
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc BUGS NEWS PGPKEYS README* RELEASE_NOTES
- newdoc term/PostScript/README README-ps
- newdoc term/js/README README-js
- use lua && newdoc term/lua/README README-lua
-
- local DOC_CONTENTS='Gnuplot no longer links against pdflib. You can
- use the "pdfcairo" terminal for PDF output.'
- use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
- use gd && DOC_CONTENTS+="\n\nFor font support in png/jpeg/gif output,
- you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
- environment variables. See the FAQ file in /usr/share/doc/${PF}/
- for more information."
- readme.gentoo_create_doc
-
- if use examples; then
- # Demo files
- insinto /usr/share/${PN}/${GP_VERSION}
- doins -r demo
- rm "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary{1,2,3} || die
- rm "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/plugin/*.{o,so} || die
- fi
-
- if use doc; then
- # Manual, FAQ
- dodoc docs/gnuplot.pdf FAQ.pdf
- # Documentation for making PostScript files
- docinto psdoc
- dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
- fi
-}
-
-src_test() {
- emake check GNUTERM="dumb"
-}
-
-pkg_postinst() {
- use latex && texmf-update
- readme.gentoo_print_elog
-}
-
-pkg_postrm() {
- use latex && texmf-update
-}
diff --git a/sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild b/sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild
index 8be4751e4190..90984d5202f6 100644
--- a/sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild
+++ b/sci-visualization/gnuplot/gnuplot-6.0.1-r1.ebuild
@@ -20,7 +20,7 @@ if [[ -z ${PV%%*9999} ]]; then
else
MY_P="${P/_/.}"
SRC_URI="https://downloads.sourceforge.net/gnuplot/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
fi
S="${WORKDIR}/${MY_P}"
diff --git a/sci-visualization/gnuplot/gnuplot-6.0.1.ebuild b/sci-visualization/gnuplot/gnuplot-6.0.1.ebuild
deleted file mode 100644
index 66216ac3e8b4..000000000000
--- a/sci-visualization/gnuplot/gnuplot-6.0.1.ebuild
+++ /dev/null
@@ -1,219 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1,2,3,4} )
-WX_GTK_VER="3.2-gtk3"
-
-inherit autotools lua-single readme.gentoo-r1 toolchain-funcs wxwidgets
-
-DESCRIPTION="Command-line driven interactive plotting program"
-HOMEPAGE="http://www.gnuplot.info/"
-
-if [[ -z ${PV%%*9999} ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.code.sf.net/p/gnuplot/gnuplot-main"
- EGIT_BRANCH="master"
- MY_P="${PN}"
- EGIT_CHECKOUT_DIR="${WORKDIR}/${MY_P}"
-else
- MY_P="${P/_/.}"
- SRC_URI="https://downloads.sourceforge.net/gnuplot/${MY_P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="gnuplot"
-SLOT="0"
-IUSE="amos aqua bitmap cairo doc examples +gd gpic latex libcaca libcerf lua metafont metapost qt5 readline regis tgif wxwidgets X"
-
-REQUIRED_USE="
- doc? ( gd )
- lua? ( ${LUA_REQUIRED_USE} )"
-
-RDEPEND="
- amos? ( dev-libs/openspecfun )
- cairo? (
- x11-libs/cairo
- x11-libs/pango )
- gd? ( >=media-libs/gd-2.0.35-r3:2=[png] )
- latex? (
- virtual/latex-base
- lua? (
- dev-tex/pgf
- >=dev-texlive/texlive-latexrecommended-2008-r2 ) )
- libcaca? ( media-libs/libcaca )
- lua? ( ${LUA_DEPS} )
- qt5? (
- dev-qt/qtcore:5=
- dev-qt/qtgui:5=
- dev-qt/qtnetwork:5=
- dev-qt/qtprintsupport:5=
- dev-qt/qtsvg:5=
- dev-qt/qtwidgets:5= )
- readline? ( sys-libs/readline:0= )
- libcerf? ( sci-libs/libcerf )
- wxwidgets? (
- x11-libs/wxGTK:${WX_GTK_VER}[X]
- x11-libs/cairo
- x11-libs/pango
- x11-libs/gtk+:3 )
- X? (
- x11-libs/libX11
- x11-libs/libXaw )"
-
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-langgreek
- dev-texlive/texlive-mathscience
- app-text/ghostscript-gpl )
- qt5? ( dev-qt/linguist-tools:5 )"
-
-IDEPEND="latex? ( virtual/latex-base )"
-
-GP_VERSION="${PV%.*}"
-TEXMF="${EPREFIX}/usr/share/texmf-site"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-6.1-no-picins.patch
- "${FILESDIR}"/${PN}-6.0.0-configure.patch
- "${FILESDIR}"/${PN}-6.0.1-watchpoints.patch
-)
-
-pkg_setup() {
- use lua && lua-single_pkg_setup
-}
-
-src_prepare() {
- default
-
- if [[ ${PV##*.} = 9999 ]]; then
- local dir
- for dir in config demo m4 term tutorial; do
- emake -C "$dir" -f Makefile.am.in Makefile.am
- done
- fi
-
- # Add special version identification as required by provision 2
- # of the gnuplot license
- sed -i -e "1s/.*/& (Gentoo revision ${PR})/" PATCHLEVEL || die
-
- eautoreconf
-
- # Make sure we don't mix build & host flags.
- sed -i \
- -e 's:@CPPFLAGS@:$(BUILD_CPPFLAGS):' \
- -e 's:@CFLAGS@:$(BUILD_CFLAGS):' \
- -e 's:@LDFLAGS@:$(BUILD_LDFLAGS):' \
- -e 's:@CC@:$(CC_FOR_BUILD):' \
- docs/Makefile.in || die
-}
-
-src_configure() {
- if ! use latex; then
- sed -i -e '/SUBDIRS/s/LaTeX//' share/Makefile.in || die
- fi
-
- use wxwidgets && setup-wxwidgets
-
- tc-export CC CXX #453174
- tc-export_build_env BUILD_CC
- export CC_FOR_BUILD=${BUILD_CC}
-
- econf \
- --with-texdir="${TEXMF}/tex/latex/${PN}" \
- --with-readline=$(usex readline gnu builtin) \
- $(use_with amos) \
- $(use_with bitmap bitmap-terminals) \
- $(use_with cairo) \
- $(use_with gd) \
- $(use_with gpic) \
- "$(use_with libcaca caca "${EPREFIX}/usr/$(get_libdir)")" \
- $(use_with libcerf) \
- $(use_with lua) \
- $(use_with metafont) \
- $(use_with metapost) \
- $(use_with regis) \
- $(use_with tgif) \
- $(use_with X x) \
- --enable-stats \
- $(use_with qt5 qt qt5) \
- $(use_enable wxwidgets) \
- DIST_CONTACT="https://bugs.gentoo.org/" \
- EMACS=no
-}
-
-src_compile() {
- # Prevent access violations, see bug 201871
- export VARTEXFONTS="${T}/fonts"
-
- emake all
-
- # pdflatex fails in titlepag.tex: "Argument of  has an extra }."
- # Install the pre-built gnuplot.pdf instead.
- #if use doc; then
- # if use cairo; then
- # emake -C docs pdf
- # else
- # ewarn "Cannot build figures unless cairo is enabled."
- # ewarn "Building documentation without figures."
- # emake -C docs pdf_nofig
- # mv docs/nofigures.pdf docs/gnuplot.pdf || die
- # fi
- #fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc BUGS NEWS PGPKEYS README* RELEASE_NOTES
- newdoc term/PostScript/README README-ps
- newdoc term/js/README README-js
- use lua && newdoc term/lua/README README-lua
-
- local DOC_CONTENTS='Gnuplot no longer links against pdflib. You can
- use the "pdfcairo" terminal for PDF output.'
- use cairo || DOC_CONTENTS+=' It is available with USE="cairo".'
- use gd && DOC_CONTENTS+="\n\nFor font support in png/jpeg/gif output,
- you may have to set the GDFONTPATH and GNUPLOT_DEFAULT_GDFONT
- environment variables. See the FAQ file in /usr/share/doc/${PF}/
- for more information."
- readme.gentoo_create_doc
-
- if use examples; then
- # Demo files
- insinto /usr/share/${PN}/${GP_VERSION}
- doins -r demo
- rm "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/binary{1,2,3} || die
- rm "${ED}"/usr/share/${PN}/${GP_VERSION}/demo/plugin/*.{o,so} || die
- fi
-
- if use doc; then
- # Manual, FAQ
- dodoc docs/gnuplot.pdf #FAQ.pdf
- # Documentation for making PostScript files
- docinto psdoc
- dodoc docs/psdoc/{*.doc,*.tex,*.ps,*.gpi,README}
- fi
-}
-
-src_test() {
- emake check GNUTERM="dumb"
-}
-
-pkg_postinst() {
- use latex && texmf-update
- readme.gentoo_print_elog
-}
-
-pkg_postrm() {
- use latex && texmf-update
-}
diff --git a/sci-visualization/gwyddion/Manifest b/sci-visualization/gwyddion/Manifest
index 53fcf98561ed..f202ec7c8a41 100644
--- a/sci-visualization/gwyddion/Manifest
+++ b/sci-visualization/gwyddion/Manifest
@@ -1,2 +1 @@
-DIST gwyddion-2.61.tar.xz 4982092 BLAKE2B e4949558c52d2a6e97415b65e6816061c117868bdd2f39b341c3f740500f71dd38500323a389058b65f9c30feb9d5fd1e93bc29881b464cdb66981639fe280ed SHA512 c2fff49d52e4c439bf96e68be3534948c1fd48ade9b1e59e2d2d7d607170b5e7ce09e9cde3873ecca526de1561b028f39785dc363186f9f3d4ef0d259d313675
DIST gwyddion-2.62.tar.xz 5010676 BLAKE2B 18012dfe050753413834e8a3734ec82989f375d81ac0242a6bbaf630da1a7741e9701d3c7a8c0dc03cfde8f93de9848ae106731f057c902f44ba1caf0cd79520 SHA512 93aff13f865fab045e17bd6c7633d714c4a97980ff10093f38c35e6dd39a0ed9680185f7a81a198522b623260cf6086d40e2b6a63a1cb59bc176eadf87fb85e1
diff --git a/sci-visualization/gwyddion/files/gwyddion-2.60-automagic.patch b/sci-visualization/gwyddion/files/gwyddion-2.60-automagic.patch
deleted file mode 100644
index ac68ac0a2861..000000000000
--- a/sci-visualization/gwyddion/files/gwyddion-2.60-automagic.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 5a7465a..cc5a54d 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -660,11 +660,13 @@ AM_CONDITIONAL([HAVE_CXX],[test "x$have_cxx" != xno])
- #############################################################################
- # OpenEXR 2.x+
- # Optional. Used for HDR greyscale OpenEXR pixmap import/export.
--enable_exr=$have_cxx
--PKG_CHECK_MODULES(EXR, [OpenEXR >= 2.0],
-+GWY_WITH([exr],,[build with OpenEXR support])
-+if test "x$enable_exr" != "xno" && "x$have_cxx" != "xno"; then
-+ PKG_CHECK_MODULES(EXR, [OpenEXR],
- [AC_DEFINE(HAVE_EXR,1,
- [Define if we have the OpenEXR 2.x+ package.])],
- [enable_exr=no])
-+fi
- AM_CONDITIONAL([HAVE_EXR],[test "x$enable_exr" != xno])
-
- #############################################################################
-@@ -679,10 +681,13 @@ AM_CONDITIONAL([HAVE_HDF5],[test "x$enable_hdf5" != xno])
- #############################################################################
- # CFITSIO
- # Optional. Used for FITS image import.
--PKG_CHECK_MODULES(CFITSIO, [cfitsio],
-+GWY_WITH([cfitsio],,[build with cfitsio support])
-+if test "x$enable_cfitsio" != "xno"; then
-+ PKG_CHECK_MODULES(CFITSIO, [cfitsio],
- [AC_DEFINE(HAVE_CFITSIO,1,
- [Define if we have the cfitsio package.])],
- [enable_cfitsio=no])
-+fi
- AM_CONDITIONAL([HAVE_CFITSIO],[test "x$enable_cfitsio" != xno])
-
- #############################################################################
diff --git a/sci-visualization/gwyddion/gwyddion-2.61-r1.ebuild b/sci-visualization/gwyddion/gwyddion-2.61-r1.ebuild
deleted file mode 100644
index 1c242c79a51f..000000000000
--- a/sci-visualization/gwyddion/gwyddion-2.61-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools xdg
-
-DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
-HOMEPAGE="http://gwyddion.net/"
-SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 doc fits jansson hdf5 nls openexr openmp perl ruby sourceview unique xml X zlib"
-
-RDEPEND="
- >=dev-libs/glib-2.32
- dev-libs/libzip
- media-libs/libpng:0=
- >=sci-libs/fftw-3.1:3.0=[openmp?]
- virtual/libiconv
- virtual/libintl
- x11-libs/cairo
- >=x11-libs/gtk+-2.18:2
- x11-libs/libXmu
- x11-libs/pango
- bzip2? ( app-arch/bzip2 )
- fits? ( sci-libs/cfitsio[bzip2?] )
- jansson? ( dev-libs/jansson )
- hdf5? ( sci-libs/hdf5:=[hl,zlib?] )
- openexr? ( media-libs/openexr:= )
- perl? ( dev-lang/perl:= )
- ruby? ( dev-ruby/narray )
- unique? ( dev-libs/libunique:3 )
- sourceview? ( x11-libs/gtksourceview:2.0 )
- xml? ( dev-libs/libxml2:2 )
- zlib? ( sys-libs/zlib )
-"
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-util/gtk-doc )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.60-automagic.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-# There are python bindings (--enable-pygwy) but they are py2 only
-# 3D opengl rendering requires deprecated GTK-2 x11-libs/gtkglext
-src_configure() {
- # hack for bug 741840
- use doc && export GTK_DOC_PATH=/usr/share/gtk-doc
-
- econf \
- --disable-rpath \
- --without-kde4-thumbnailer \
- $(use_enable doc gtk-doc) \
- $(use_enable openmp) \
- $(use_enable nls) \
- --disable-pygwy \
- --without-python \
- $(use_with bzip2) \
- $(use_with fits cfitsio) \
- $(use_with hdf5) \
- $(use_with jansson) \
- $(use_with perl) \
- $(use_with ruby) \
- $(use_with openexr exr) \
- --without-gl \
- $(use_with sourceview gtksourceview) \
- $(use_with unique) \
- $(use_with xml libxml2) \
- $(use_with X x) \
- $(use_with zlib) \
- --with-zip=libzip
-}
-
-src_install() {
- default
- find "${ED}" -type f -name "*.la" -delete || die
-}
diff --git a/sci-visualization/gwyddion/gwyddion-2.62-r2.ebuild b/sci-visualization/gwyddion/gwyddion-2.62-r2.ebuild
deleted file mode 100644
index 96d176c56a7e..000000000000
--- a/sci-visualization/gwyddion/gwyddion-2.62-r2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools xdg
-
-DESCRIPTION="Framework for Scanning Mode Microscopy data analysis"
-HOMEPAGE="http://gwyddion.net/"
-SRC_URI="http://gwyddion.net/download/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="bzip2 doc fits jansson hdf5 nls openexr openmp perl ruby sourceview unique xml X zlib"
-
-RDEPEND="
- >=dev-libs/glib-2.32
- dev-libs/libzip
- media-libs/libpng:0=
- >=sci-libs/fftw-3.1:3.0=[openmp?]
- virtual/libiconv
- virtual/libintl
- x11-libs/cairo
- >=x11-libs/gtk+-2.18:2
- x11-libs/libXmu
- x11-libs/pango
- bzip2? ( app-arch/bzip2 )
- fits? ( sci-libs/cfitsio[bzip2?] )
- jansson? ( dev-libs/jansson )
- hdf5? ( sci-libs/hdf5:=[hl,zlib?] )
- openexr? ( media-libs/openexr:= )
- perl? ( dev-lang/perl:= )
- ruby? ( dev-ruby/narray )
- unique? ( dev-libs/libunique:3 )
- sourceview? ( x11-libs/gtksourceview:2.0 )
- xml? ( dev-libs/libxml2:2 )
- zlib? ( sys-libs/zlib )
-"
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( dev-util/gtk-doc )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.60-automagic.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-# There are python bindings (--enable-pygwy) but they are py2 only
-# 3D opengl rendering requires deprecated GTK-2 x11-libs/gtkglext
-src_configure() {
- # hack for bug 741840
- use doc && export GTK_DOC_PATH=/usr/share/gtk-doc
-
- econf \
- --disable-rpath \
- --without-kde4-thumbnailer \
- $(use_enable doc gtk-doc) \
- $(use_enable openmp) \
- $(use_enable nls) \
- --disable-pygwy \
- --without-python \
- $(use_with bzip2) \
- $(use_with fits cfitsio) \
- $(use_with hdf5) \
- $(use_with jansson) \
- $(use_with perl) \
- $(use_with ruby) \
- $(use_with openexr exr) \
- --without-gl \
- $(use_with sourceview gtksourceview) \
- $(use_with unique) \
- $(use_with xml libxml2) \
- $(use_with X x) \
- $(use_with zlib) \
- --with-zip=libzip
-}
-
-src_install() {
- default
- find "${ED}" -type f -name "*.la" -delete || die
-}
diff --git a/sci-visualization/paraview/Manifest b/sci-visualization/paraview/Manifest
index e93bfb6acbac..686959491eb6 100644
--- a/sci-visualization/paraview/Manifest
+++ b/sci-visualization/paraview/Manifest
@@ -1,3 +1,4 @@
DIST ParaView-v5.11.1.tar.xz 79847556 BLAKE2B efef5e519a82ef1c0a7d532578778f6a95f07ebd72ebefd0cbdcff0bfc3af1773601cd102ff81f45f302fcaa4bb6ec7ee68f7dec77f5d4e137c2842fbbb54e11 SHA512 d0e666b49f49e41dba23e23d454a9462f018bd6d832628b0029e8d54760f0439ca97841a26da3126c5144780fc01dc25234a6624fb35346a98d35cbe0e0c98ca
DIST ParaView-v5.12.0-RC1.tar.xz 128908020 BLAKE2B 3222ac21f733559b9f5c7e8c1009a19c0e462e2622805db7d61b683f25d70fc40cf096d699afde6dab9e23c102e3df9251a718d3ecbaac7a56db01c898270cd9 SHA512 1c6a052081e274a120563c5ffc73dadf4e02be237cc0c213a22d0b93a9865713c83992a3fc0cc1c52742b0753546b5b983a3f650989e8a472ac2f7e90383de92
DIST ParaView-v5.12.0.tar.xz 129439820 BLAKE2B b9a59c22d15ee1582704c7e6c70a259d8b8df5d0f59fb87902ade07bce3ef7b52b055d75bb0876b7a0a9b493a7ef8df377f0ac281c370c72d9b89418efec9657 SHA512 d7ad95105f43672c5f0001f673977b7742cca113b78b0d953f4c55f60a6cf72b8a216515136251f63b8294becb0ea717b5118bf48b78ca8db85949a1b59892c1
+DIST ParaView-v5.13.0.tar.xz 133195632 BLAKE2B f4e639d01667dfb7ad02fa51133b1e2d29429aefa89e7f77772d0080aa537d910f9b6f7868e4a31d52b392762c38d94ec228b2a754936409077eb2f8ffcf7f1c SHA512 ba0051902efb2a9c599e500f85f9b20bc46eead1e1f68daa0fea0295ee606844fb72fb8eee04f67f7cced3a35be2b2b442c6f1160fc4f2c2eedfbe9c440b5b1f
diff --git a/sci-visualization/paraview/paraview-5.13.0.ebuild b/sci-visualization/paraview/paraview-5.13.0.ebuild
new file mode 100644
index 000000000000..783e7e442b77
--- /dev/null
+++ b/sci-visualization/paraview/paraview-5.13.0.ebuild
@@ -0,0 +1,238 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DOCS_BUILDER="doxygen"
+inherit cmake flag-o-matic desktop docs python-single-r1 qmake-utils toolchain-funcs xdg
+
+MAJOR_PV="$(ver_cut 1-2)"
+MINOR_PV="$(ver_cut 3)"
+RC_PV="$(ver_cut 4-5)"
+RC_PV="${RC_PV:+-${RC_PV^^}}"
+MY_P="ParaView-v${MAJOR_PV}.${MINOR_PV}${RC_PV}"
+
+DESCRIPTION="Powerful scientific data visualization application"
+HOMEPAGE="https://www.paraview.org"
+SRC_URI="https://www.paraview.org/files/v${MAJOR_PV}/${MY_P}.tar.xz"
+S="${WORKDIR}/${MY_P}"
+
+# TODO: check licenses of plugins (USE=plugins)
+LICENSE="BSD MIT PSF-2 VTK"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="boost cg examples ffmpeg mpi nvcontrol openmp offscreen plugins python +qt6 +sqlite test tk +webengine"
+
+RESTRICT="mirror test"
+
+REQUIRED_USE="
+ python? ( mpi ${PYTHON_REQUIRED_USE} )
+ webengine? ( qt6 )
+ qt6? ( sqlite )
+ ?? ( offscreen qt6 )"
+
+RDEPEND="
+ app-arch/lz4
+ dev-libs/expat
+ dev-libs/jsoncpp:=
+ dev-libs/libxml2:2
+ dev-libs/protobuf:=
+ dev-libs/pugixml
+ media-libs/freetype
+ media-libs/glew:0
+ media-libs/libpng:0
+ media-libs/libtheora
+ media-libs/tiff:=
+ sci-libs/cgnslib
+ sci-libs/hdf5:=[mpi=]
+ >=sci-libs/netcdf-4.2[hdf5]
+ >=sci-libs/netcdf-cxx-4.2:3
+ sys-libs/zlib
+ virtual/glu
+ media-libs/libjpeg-turbo:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXt
+ ffmpeg? ( media-video/ffmpeg )
+ mpi? ( virtual/mpi[cxx,romio] )
+ offscreen? ( >=media-libs/mesa-18.3.6[osmesa] )
+ !offscreen? ( virtual/opengl )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/constantly[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sip:5[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ mpi? ( dev-python/mpi4py )
+ qt6? ( dev-python/PyQt6[opengl,${PYTHON_USEDEP}] )
+ ')
+ )
+ qt6? (
+ dev-qt/qt5compat:6
+ dev-qt/qtbase:6[gui,opengl,sql]
+ dev-qt/qtdeclarative:6
+ dev-qt/qtsvg:6
+ dev-qt/qttools:6[assistant,designer,widgets]
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ tk? ( dev-lang/tk:0= )
+ webengine? ( dev-qt/qtwebengine:6[widgets] )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ boost? (
+ $(python_gen_cond_dep '
+ dev-libs/boost[mpi?,python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+BDEPEND="
+ openmp? ( virtual/fortran )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.5.0-allow_custom_build_type.patch
+)
+
+# false positive when checking for available HDF5 interface, bug #904731
+QA_CONFIG_IMPL_DECL_SKIP=(
+ H5Pset_coll_metadata_write
+ H5Pset_all_coll_metadata_ops
+)
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+ use python && python-single-r1_pkg_setup
+ PVLIBDIR=$(get_libdir)/${PN}-${MAJOR_PV}
+}
+
+src_prepare() {
+ # Bug #661812
+ mkdir -p Plugins/StreamLinesRepresentation/doc || die
+
+ cmake_src_prepare
+
+ # lib64 fixes
+ sed -i \
+ -e "s:/lib/python:/$(get_libdir)/python:g" \
+ VTK/ThirdParty/xdmf3/vtkxdmf3/CMakeLists.txt || die
+ sed -i \
+ -e "s:lib/paraview-:$(get_libdir)/paraview-:g" \
+ Remoting/Application/vtkInitializationHelper.cxx || die
+}
+
+src_configure() {
+ # Needed to compile bundled VTK in ParaView 5.11.1 with gcc 12
+ # see also, bug #863299
+ filter-lto
+ append-cflags $(test-flags-CC -fno-strict-aliasing \
+ -Wno-error=incompatible-function-pointer-types -Wno-error=int-conversion)
+ append-cxxflags $(test-flags-CXX -fno-strict-aliasing \
+ -Wno-error=incompatible-function-pointer-types -Wno-error=int-conversion)
+
+ # Make sure qmlplugindump is in path:
+ export PATH="$(qt6_get_bindir):${PATH}"
+
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="${PVLIBDIR}"
+ -UBUILD_SHARED_LIBS
+ -DPARAVIEW_BUILD_SHARED_LIBS=ON
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+
+ # boost
+ -DVTK_MODULE_ENABLE_VTK_IOInfovis="$(usex boost YES NO)"
+
+ # doc
+ -DPARAVIEW_BUILD_DEVELOPER_DOCUMENTATION="$(usex doc)"
+
+ # examples
+ -DBUILD_EXAMPLES="$(usex examples)"
+
+ # ffmpeg
+ -DPARAVIEW_ENABLE_FFMPEG="$(usex ffmpeg)"
+
+ # mpi
+ -DPARAVIEW_USE_MPI="$(usex mpi)"
+ -DXDMF_BUILD_MPI="$(usex mpi)"
+ -DVTK_GROUP_ENABLE_MPI="$(usex mpi YES NO)"
+
+ # offscreen
+ -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
+ -DVTK_OPENGL_HAS_OSMESA="$(usex offscreen)"
+
+ # plugins
+ -DPARAVIEW_PLUGINS_DEFAULT="$(usex plugins)"
+
+ # python
+ -DModule_pqPython="$(usex python)"
+ -DPARAVIEW_USE_PYTHON="$(usex python)"
+
+ # qt6
+ -DPARAVIEW_USE_QT="$(usex qt6)"
+ -DPARAVIEW_QT_VERSION="6"
+ -DVTK_QT_VERSION="6"
+ -DModule_pqPython="$(usex qt6 "$(usex python)" "off")"
+ -DVTK_USE_NVCONTROL="$(usex nvcontrol)"
+ -DVTK_GROUP_ENABLE_Qt="$(usex qt6 YES NO)"
+ -DCMAKE_INSTALL_QMLDIR="${EPREFIX}/usr/$(get_libdir)/qt6/qml"
+
+ # sqlite
+ -DVTK_MODULE_ENABLE_VTK_sqlite="$(usex sqlite YES NO)"
+
+ # test
+ -DBUILD_TESTING="$(usex test)"
+
+ # tk
+ -DVTK_USE_TK="$(usex tk)"
+ -DVTK_GROUP_ENABLE_Tk="$(usex tk YES NO)"
+
+ # webengine
+ -DPARAVIEW_USE_QTWEBENGINE="$(usex webengine)"
+ -DVTK_GROUP_ENABLE_Web="$(usex webengine YES NO)"
+ )
+
+ if use openmp; then
+ mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE=OpenMP )
+ fi
+
+ if use qt6; then
+ mycmakeargs+=(
+ -DOPENGL_gl_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGL.so
+ -DOPENGL_glu_LIBRARY="${EPREFIX}"/usr/$(get_libdir)/libGLU.so
+ )
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # remove wrapper binaries and put the actual executable in place
+ for i in {paraview-config,pvserver,pvdataserver,pvrenderserver,pvbatch,pvpython,paraview}; do
+ if [ -f "${ED}"/usr/lib/"$i" ]; then
+ mv "${ED}"/usr/lib/"$i" "${ED}"/usr/bin/"$i" || die
+ fi
+ done
+
+ # set up the environment
+ echo "LDPATH=${EPREFIX}/usr/${PVLIBDIR}" > "${T}"/40${PN} || die
+ doenvd "${T}"/40${PN}
+
+ newicon "${S}"/Clients/ParaView/pvIcon-96x96.png paraview.png
+ make_desktop_entry paraview "Paraview" paraview
+
+ use python && python_optimize "${ED}/usr/$(get_libdir)/${PN}-${MAJOR_PV}"
+}