summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/meep/meep-1.1.1.ebuild')
-rw-r--r--sci-physics/meep/meep-1.1.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-physics/meep/meep-1.1.1.ebuild b/sci-physics/meep/meep-1.1.1.ebuild
new file mode 100644
index 000000000000..4edfc1f664e7
--- /dev/null
+++ b/sci-physics/meep/meep-1.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Simulation software to model electromagnetic systems"
+HOMEPAGE="http://ab-initio.mit.edu/meep/"
+SRC_URI="http://ab-initio.mit.edu/meep/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples hdf5 guile mpi"
+
+DEPEND="sci-libs/fftw
+ sci-libs/gsl
+ sci-physics/harminv
+ guile? ( >=sci-libs/libctl-3.0.3 )
+ hdf5? ( sci-libs/hdf5 )
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_with mpi) \
+ $(use_with hdf5) \
+ $(use_with guile libctl)
+}
+
+src_test() {
+ # bug #423247
+ emake pml -C tests CXXFLAGS=-O0 || die
+ emake check || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die "install examples failed"
+ fi
+}