summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/polymake/polymake-2.13.ebuild')
-rw-r--r--sci-mathematics/polymake/polymake-2.13.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sci-mathematics/polymake/polymake-2.13.ebuild b/sci-mathematics/polymake/polymake-2.13.ebuild
new file mode 100644
index 000000000000..26e172f13b05
--- /dev/null
+++ b/sci-mathematics/polymake/polymake-2.13.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic
+
+MY_PV=${PV}-1
+
+DESCRIPTION="research tool for polyhedral geometry and combinatorics"
+SRC_URI="http://polymake.org/lib/exe/fetch.php/download/${PN}-${MY_PV}.tar.bz2"
+HOMEPAGE="http://polymake.org"
+
+IUSE="libpolymake"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="dev-libs/gmp
+ dev-libs/boost
+ dev-libs/libxml2:2
+ dev-perl/XML-LibXML
+ dev-libs/libxslt
+ dev-perl/XML-LibXSLT
+ dev-perl/XML-Writer
+ dev-perl/Term-ReadLine-Gnu"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ # Don't strip
+ sed -i '/system "strip $to"/d' support/install.pl || die
+ epatch "${FILESDIR}/${PN}_gcc49.patch"
+
+ einfo "During compile this package uses up to"
+ einfo "750MB of RAM per process. Use MAKEOPTS=\"-j1\" if"
+ einfo "you run into trouble."
+}
+
+src_configure () {
+ export CXXOPT=$(get-flag -O)
+ # Configure does not accept --host, therefore econf cannot be used
+ ./configure --prefix="${EPREFIX}/usr" \
+ --without-java \
+ $(use_with libpolymake callable) \
+ --without-prereq \
+ --libdir="${EPREFIX}/usr/$(get_libdir)" \
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/polymake" \
+ "${myconf}" || die
+}
+
+src_install(){
+ emake -j1 DESTDIR="${D}" install
+ dosym libpolymake.so "${EPREFIX}/usr/$(get_libdir)/libpolymake.so.0"
+}
+
+pkg_postinst(){
+ elog "Docs can be found on http://www.polymake.org/doku.php/documentation"
+ elog " "
+ elog "Support for jreality is missing, sorry (see bug #346073)."
+}