summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/suitename')
-rw-r--r--sci-chemistry/suitename/Manifest1
-rw-r--r--sci-chemistry/suitename/metadata.xml22
-rw-r--r--sci-chemistry/suitename/suitename-0.3.070628.ebuild37
3 files changed, 60 insertions, 0 deletions
diff --git a/sci-chemistry/suitename/Manifest b/sci-chemistry/suitename/Manifest
new file mode 100644
index 000000000000..eac0c677a2bb
--- /dev/null
+++ b/sci-chemistry/suitename/Manifest
@@ -0,0 +1 @@
+DIST suitename.0.3.070628.src.tgz 29914 SHA256 5c2a709aa2d815b259475344aa2b982c157868eb9a7e5d6407b8f525f7e28c4c
diff --git a/sci-chemistry/suitename/metadata.xml b/sci-chemistry/suitename/metadata.xml
new file mode 100644
index 000000000000..06ac91e5fb9e
--- /dev/null
+++ b/sci-chemistry/suitename/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Suitename is a new C program that supports the ROC RNA Ontology Consortium
+consensus RNA backbone nomenclature and conformer-list development (see our RNA
+backbone rotamer section.
+From dihedral-angle input for a specific RNA structure (usually from Dangle),
+Suitename categorizes the RNA backbone geometry of each suite (the
+sugar-to-sugar version of a residue) either as an outlier ("!!") or as belonging
+to one of the 53 defined conformer bins. The output is either a
+one-line-per-suite report, or a linear conformer string (as shown below the
+image here) in one of several variant formats. Suitename is built into
+MolProbity, producing entries in the multi-criterion chart for an RNA model and
+also a suitestring file. The Suitename code is made available here for bulk or
+individual command-line use.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/suitename/suitename-0.3.070628.ebuild b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
new file mode 100644
index 000000000000..fb11e075c8d6
--- /dev/null
+++ b/sci-chemistry/suitename/suitename-0.3.070628.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+MY_P="${PN}.${PV}"
+
+DESCRIPTION="The ROC RNA Ontology Consortium consensus RNA backbone nomenclature and conformer-list development"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/suitename.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${MY_P}.src.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="richardson"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ tc-export CC
+ cp Makefile.linux Makefile || die
+ sed \
+ -e 's:cc:${CC}:g' \
+ -e "s:-o:${LDFLAGS} -o:g" \
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+}