summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index a946e1511962..24631e72b86e 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils
+inherit cmake-utils gnome2-utils xdg-utils
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="https://www.qbittorrent.org/"
@@ -34,6 +34,7 @@ RDEPEND="
dbus? ( dev-qt/qtdbus:5 )
X? (
dev-qt/qtgui:5
+ dev-qt/qtsvg:5
dev-qt/qtwidgets:5
)"
DEPEND="${RDEPEND}
@@ -51,3 +52,13 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}