summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/netsed/Manifest1
-rw-r--r--net-misc/netsed/files/netsed-0.01c-man.patch79
-rw-r--r--net-misc/netsed/netsed-0.01c.ebuild29
3 files changed, 109 insertions, 0 deletions
diff --git a/net-misc/netsed/Manifest b/net-misc/netsed/Manifest
index e8a114c09dca..f70f0907f00e 100644
--- a/net-misc/netsed/Manifest
+++ b/net-misc/netsed/Manifest
@@ -1,2 +1,3 @@
DIST netsed-0.01b.tgz 6352 BLAKE2B 0aa8ed9f282f32d139e50af1a1c8d1aae118ff6e892475774125b45c229707c40544199ea70708827636a50e43b8f652138b244cb2f3857c854d49018b996fb7 SHA512 edef6ef6e39a17a46a3b4d8019ba2e742b2b5852f804df5e952461a792e3ba7a49fcc33353abf7e532e51586927f28f4b7c6da4f4fbd34a32cdf093f26163dd7
+DIST netsed-0.01c.tgz 12987 BLAKE2B 9d31a2cde79adc944f69cc2bf522a615201fd48dd1b46152b39368f36657ebebbfa5dbdecd91c965fb63d6e06a2a37317e005483a0c60be30a3ad178157418c2 SHA512 de1a1f38698cdcfa3b39975eb7b701abb97fd5035e306b63a6d5a459e4180cf8bb49dc2430acf4767e6d9f9c673f3e1e83040edfb8f331b9b1e10b0036058c57
DIST netsed_0.01c-2.diff.gz 3140 BLAKE2B 211c7f71a76b74fc47cc32dbd5e9ad05a2c7c67bd95de73b0bdb09249f245ab8b0190ee79b51cf1d2f2bc99cc0b7fdf8d358851fddafb2815adc640260122c77 SHA512 5a729e9800051449f7f52989cb65232e262ac6023f21b8ec688f3ce33ed4be79f9d00993aed7773d83dbe109927a5fc6c64e4775d4958136e5c891b6b82e6b83
diff --git a/net-misc/netsed/files/netsed-0.01c-man.patch b/net-misc/netsed/files/netsed-0.01c-man.patch
new file mode 100644
index 000000000000..a35a88b87b02
--- /dev/null
+++ b/net-misc/netsed/files/netsed-0.01c-man.patch
@@ -0,0 +1,79 @@
+--- netsed-0.01c.orig/debian/netsed.1
++++ netsed-0.01c/debian/netsed.1
+@@ -0,0 +1,76 @@
++.TH NETSED 1 "June 23, 2001" NETSED
++.SH NAME
++netsed \- network packet stream editor
++.SH SYNOPSIS
++.B netsed
++.I proto lport rhost rport rule1
++.RI [ rule2 ] " " ...
++.SH DESCRIPTION
++NetSED is small and handful utility designed to alter the contents of
++packets forwarded thru your network in real time. It is really useful
++for network hackers in following applications:
++.TP
++.B black\-box protocol auditing
++whenever there are two or more propertiary boxes communicating over
++undocumented protocol (by enforcing changes in ongoing transmissions,
++you will be able to test if tested application is secure)
++.TP
++.B fuzz\-alike experiments, integrity tests
++whenever you want to test stability of the application and see how it
++ensures data integrity,
++.TP
++.B other common applications
++fooling other people, content filtering, etc etc \- choose whatever
++you want to.
++.LP
++It perfectly fits netgrep, netcat and tcpdump tools suite :P
++.SH OPTIONS
++.TP
++.B proto
++protocol specification (tcp or udp)
++.TP
++.B lport
++local port to listen on (see README for transparent traffic intercepting
++on some systems)
++.TP
++.B rhost
++where connection should be forwarded (0 = use destination address of
++incoming connection, see README)
++.TP
++.B rport
++destination port (0 = dst port of incoming connection)
++.TP
++.B rule\fIN\fR
++replacement rules (see below)
++.LP
++General replacement rules syntax: s/\fBpat1\fR/\fBpat2\fR\fI[/expire]\fR
++
++This will replace all occurences of \fBpat1\fR with \fBpat2\fR in matching
++packets. Additional parameter (count) can be used to expire rule after 'count'
++succesful substitutions. Eight\-bit characters, including NULL and '/', can
++be passed using HTTP\-alike hex escape sequences (eg. %0a%0d). Single '%'
++can be reached by using '%%'. Examples:
++.TP
++.B 's/andrew/mike/1'
++replace 'andrew' with 'mike' (once)
++.TP
++.B 's/andrew/mike'
++replace all occurences of 'andrew' with 'mike'
++.TP
++.B 's/andrew/mike%00'
++replace 'andrew' with 'mike\\x00\\x00' (to keep orig. size)
++.TP
++.B 's/%%/%2f/20'
++replace '%' with '/' in first 20 packets
++.LP
++Rules are not working on cross\-packet boundaries and are evaluated from
++first to last not expired rule.
++.SH SEE ALSO
++.BR ngrep (8),
++.BR nc (1),
++
++.BR /usr/share/doc/netsed/README.gz
++.SH AUTHOR
++\fBnetsed\fR was written by Michal Zalewski <lcamtuf@ids.pl>.
++
++This manual page was written by Gergely Nagy <algernon@debian.org>.
diff --git a/net-misc/netsed/netsed-0.01c.ebuild b/net-misc/netsed/netsed-0.01c.ebuild
new file mode 100644
index 000000000000..979b23a2ae47
--- /dev/null
+++ b/net-misc/netsed/netsed-0.01c.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small tool for altering forwarded network data in real time"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://lcamtuf.coredump.cx/soft/obsolete/netsed.tgz -> ${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+PATCHES=(
+ "${FILESDIR}/${P}-man.patch"
+)
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin netsed
+ doman debian/netsed.1
+ dodoc README
+}