summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ttytter/ttytter-2.1.00.ebuild')
-rw-r--r--net-misc/ttytter/ttytter-2.1.00.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/ttytter/ttytter-2.1.00.ebuild b/net-misc/ttytter/ttytter-2.1.00.ebuild
new file mode 100644
index 000000000000..5d16ba1ad70f
--- /dev/null
+++ b/net-misc/ttytter/ttytter-2.1.00.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit readme.gentoo
+
+DESCRIPTION="A multi-functional, console-based Twitter client"
+HOMEPAGE="http://www.floodgap.com/software/ttytter/"
+SRC_URI="http://www.floodgap.com/software/ttytter/dist2/${PV}.txt"
+
+LICENSE="FFSL"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.8
+ || ( net-misc/curl www-client/lynx )"
+
+pkg_setup() {
+ DOC_CONTENTS="Please consult the following webpage on how to
+ configure your client.
+ http://www.floodgap.com/software/ttytter/dl.html"
+}
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${DISTDIR}"/${A} ${WORKDIR}/${PN} || die
+}
+
+src_install() {
+ dobin ${PN}
+ readme.gentoo_create_doc
+}